Bug 7851 - Short number displayed as "unknown number"
: Short number displayed as "unknown number"
Status: RESOLVED DUPLICATE of bug 6769
Product: Chat & Call & SMS
Call Application UI
: 5.0/(2.2009.51-1)
: N900 Maemo
: Unspecified critical with 1 vote (vote)
: ---
Assigned To: rtcomm@maemo.org
: communication-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-12 13:32 UTC by Juha Suominen
Modified: 2010-01-22 17:01 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Juha Suominen (reporter) 2010-01-12 13:32:48 UTC
SOFTWARE VERSION: 1.2009.44-1

EXACT STEPS LEADING TO PROBLEM: 
1. call to you cell phone using your short number


EXPECTED OUTCOME: Phone should display the short number, eg "883860" or "3860" 

ACTUAL OUTCOME: Phone identifies caller as a unknown number. As a result of
that you can't call back to the caller. 

REPRODUCIBILITY: always

EXTRA SOFTWARE INSTALLED: none

OTHER COMMENTS: Similar bug already filed here (ID: 6769), but not sure if it's
exactly same issue. We can answer incoming calls with out problems, but cannot
call back because number is not known. The number format we use here consists
of four digits, eg 3860. If the caller is using his cellphone the number is 6
digits long, eg 883680.

This issue has been tested with different phone models. Including Nokia N97,
E90, E71, E75, 9210 and other older nokia phones + with Samsung, HTC and iphone
models. All test were done with the same SIM. Nokia N900 is the only phone with
difficulties to display incoming caller id correctly. We have few N900's here,
all with the same issue. Other SIMs also have the same problem. Our network
operator is DNA Finland
(http://www.dna.fi/en/PrivateCustomers/Sivut/Default.aspx). Not sure if this is
a GUI problem or telephony backend problem.  

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.7)
Gecko/20091221 Firefox/3.5.7
Comment 1 Juha Suominen (reporter) 2010-01-14 13:17:52 UTC
Tested also with version 2.2009.51-1 with same results.
Comment 2 Andre Klapper maemo.org 2010-01-22 16:59:38 UTC
Thanks for reporting this.
(Please don't file bugs under UI Spec.)
Comment 3 Andre Klapper maemo.org 2010-01-22 17:01:23 UTC
Same issue as bug 8081 which is marked as duplicate of bug 6769.

*** This bug has been marked as a duplicate of bug 6769 ***