Bug 7843 - (int-144219) BH-103 - Annoying Beeps when calling or receiving a phone call or SMS
(int-144219)
: BH-103 - Annoying Beeps when calling or receiving a phone call or SMS
Status: RESOLVED FIXED
Product: Connectivity
Bluetooth
: 5.0/(3.2010.02-8)
: All Maemo
: Unspecified normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: bluetooth-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-12 08:27 UTC by amitkankani
Modified: 2010-03-15 20:52 UTC (History)
2 users (show)

See Also:


Attachments
Syslog extract (5.45 KB, text/plain)
2010-01-28 12:37 UTC, Tomas Walch
Details
Logging made with hcidump (6.62 KB, text/plain)
2010-01-28 12:38 UTC, Tomas Walch
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description amitkankani (reporter) 2010-01-12 08:27:21 UTC
SOFTWARE VERSION:
(Settings > General > About product)
1.2009.44-1

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Connect the Bluetooth headset
2. Try making a phone call
3. Annoying beeps (4-5 beeps) are heard
4. Disconnect the call
5. Make a call to this device from another mobile
6. Not that when the ringing starts, the beeps are heard again.
7. Pick up the call, notice that when the call is picked up, the 4-5 beeps are
heard again

EXPECTED OUTCOME:

The beeps should be 1-2 only and not 4-5 beeps, which is very annoying and
takes more time too.

ACTUAL OUTCOME:

The beeps are heard at specified time and the number of beeps are 4-5 beeps


REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)

ALWAYS

EXTRA SOFTWARE INSTALLED:

Some softwares from Maemo-Extras, nothing pertaining to bluetooth. Happens even
when no 3rd party software is installed.

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US)
AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.25 Safari/532.0
Comment 1 amitkankani (reporter) 2010-01-12 08:33:51 UTC
Also reproducible on BH-604 stereo headset
Comment 2 Andre Klapper maemo.org 2010-01-22 17:47:29 UTC
Thanks for reporting this.
Does this happen again / is this still an issue in version 2.2009.51-1?
Comment 3 amitkankani (reporter) 2010-01-23 14:21:10 UTC
verified to be happening on  2.2009.51-1

also the beeps happen when:

1. when i start dialing a call
2. and again when the call is picked up at the other end... eventually because
of the beeps, i end up talking only after 4-5 seconds after the call is
actually connected...

this issue is making bluetooth unusable as it is way to annoying...
Comment 4 Andre Klapper maemo.org 2010-01-26 12:22:15 UTC
This was most probably fixed in package
pulseaudio 0.9.15-1maemo38+0m5
which is part of the internal build version
2009.51-13
(Note: 2009/2010 is the year, and the number after is the week.)

It is definitely not reproducable in the internal version 2010.04-4 with the BT
stereo headset BH-103.

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 5 Andre Klapper maemo.org 2010-01-27 23:39:39 UTC
*** Bug 8319 has been marked as a duplicate of this bug. ***
Comment 6 Tomas Walch 2010-01-28 12:37:35 UTC
Created an attachment (id=2152) [details]
Logging made with hcidump

I jinxed it again - bug got so scared when I made dumpfiles it became fixed.
Uploading the log files anyway, just in case they will be needed sometime.
Comment 7 Tomas Walch 2010-01-28 12:38:42 UTC
Created an attachment (id=2153) [details]
Logging made with hcidump
Comment 8 Andre Klapper maemo.org 2010-01-28 14:31:19 UTC
Tomas: Thanks for the logs, but as written this is already fixed internally...
Comment 9 amitkankani (reporter) 2010-01-28 14:33:08 UTC
@ Andre Klapper:

Thanks for confirming that it is fixed internally and may be available in next
firmware update.

However, can you confirm what the new behavior after it being fixed is? Is it 1
or 2 beeps, no beeps at all, or how?

Thanks again,
Comment 10 amitkankani (reporter) 2010-02-16 15:55:19 UTC
verified to be not fixed on 3.2010.02-8
Still the same issue is seen, specially when receiving a call !
Comment 11 Andre Klapper maemo.org 2010-02-16 16:13:32 UTC
Please read comment 4 again:
"This is not always already the next public update."

Also, please never set the Priority. Thanks.

Closing again.
Comment 12 Andre Klapper maemo.org 2010-03-15 20:52:38 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 13 Andre Klapper maemo.org 2010-03-15 20:52:50 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).