Bug 7837 - (int-200535) Do not route ringtone through loudspeakers when audio is already being played through headphones/headset (wired or Bluetooth)
(int-200535)
: Do not route ringtone through loudspeakers when audio is already being played...
Status: RESOLVED WONTFIX
Product: UI Specification
General
: 5.0:(10.2010.19-1)
: All Maemo
: Low normal with 11 votes (vote)
: ---
Assigned To: Mikko Nurmi
: ui-specification-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-12 02:52 UTC by Neil MacLeod
Modified: 2012-03-23 20:15 UTC (History)
8 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Neil MacLeod (reporter) maemo.org 2010-01-12 02:52:50 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Connect headphones (either the in-box Nokia headphones with call answer
button, or third party headphones only)
2. Open Media Player, play a song and listen through the headphones
3. Incoming call is received

EXPECTED OUTCOME:

4. Ringtone is ONLY heard through headphones

ACTUAL OUTCOME:

4. Ringtone is heard loudly through N900 loudspeakers (and very quietly in
headphones)

REPRODUCIBILITY:
Always

EXTRA SOFTWARE INSTALLED:
N/A

OTHER COMMENTS:

Same behaviour in 1.2009.44-1.

All other phones I have owned the ringtone is only heard through the
loudspeakers when headphones are connected.
Comment 1 Rob 2010-01-12 05:07:41 UTC
why can they not just make it so you can do both! would be better to have this
in profile
Comment 2 chavalotetomalosplatanos 2010-01-12 15:23:36 UTC
(In reply to comment #0)
> SOFTWARE VERSION:
> 2.2009.51-1
> 
> EXACT STEPS LEADING TO PROBLEM: 
> 1. Connect headphones (either the in-box Nokia headphones with call answer
> button, or third party headphones only)
> 2. Open Media Player, play a song and listen through the headphones
> 3. Incoming call is received
> 
> EXPECTED OUTCOME:
> 
> 4. Ringtone is ONLY heard through headphones
> 
> ACTUAL OUTCOME:
> 
> 4. Ringtone is heard loudly through N900 loudspeakers (and very quietly in
> headphones)
> 
> REPRODUCIBILITY:
> Always
> 
> EXTRA SOFTWARE INSTALLED:
> N/A
> 
> OTHER COMMENTS:
> 
> Same behaviour in 1.2009.44-1.
> 
> All other phones I have owned the ringtone is only heard through the
> loudspeakers when headphones are connected.
> 

That's how it should work if you ask me and I'm very glad they've changed it,
it was one of my main concerns regarding N900 usability. I want to use the
headphone regularly to speak since the phone is quite heavy and it's better
overall, but I don't want to have to keep it on my ear the whole day! Say...
I'm at home having a shower or whatever, why should I miss a call because I'm
unable to hear it?
Comment 3 Rob 2010-01-12 15:44:07 UTC
> 
> That's how it should work if you ask me and I'm very glad they've changed it,
> it was one of my main concerns regarding N900 usability. I want to use the
> headphone regularly to speak since the phone is quite heavy and it's better
> overall, but I don't want to have to keep it on my ear the whole day! Say...
> I'm at home having a shower or whatever, why should I miss a call because I'm
> unable to hear it?
> 

well if your not using headset turn it off what if your sitting in public place
like a bus i don't want people hearing everytime someone txt you or a call. 
i think it should have option for both!
Comment 4 Neil MacLeod (reporter) maemo.org 2010-01-12 15:48:26 UTC
(In reply to comment #2)
> That's how it should work if you ask me and I'm very glad they've changed it,
> it was one of my main concerns regarding N900 usability. I want to use the
> headphone regularly to speak since the phone is quite heavy and it's better
> overall, but I don't want to have to keep it on my ear the whole day! Say...
> I'm at home having a shower or whatever, why should I miss a call because I'm
> unable to hear it?
> 

OK, let's not debate this too much or it will get moved to Brainstorm and
nothing will happen. :)

An option probably isn't required and I think everyone can be happy. Thinking
about it logically, playing the ringtone through the device speakers while
headphones are attached is really only necessary when the device is NOT playing
a media file (either video or audio).

When the device IS playing a media file through headphones it should be assumed
the user has the headphones placed in his or her ears, in which case playing
the ringtones through the device speakers is completely unnecessary.

A corner case would be a user who is away from their device which has been left
playing a media file through headphones, yet the user wants to hear the
ringtone. I would say tough in this case. And this shouldn't be an issue if the
device has been connected to a HiFi system as the ringtone will play over the
HiFi.

Also this proposed behaviour should apply to Bluetooth and wired headphones
alike.
Comment 5 Neil MacLeod (reporter) maemo.org 2010-01-12 15:50:50 UTC
(In reply to comment #3)
> 
> well if your not using headset turn it off what if your sitting in public place
> like a bus i don't want people hearing everytime someone txt you or a call. 
> i think it should have option for both!
> 

Muting the volume or selecting the Silent profile might be the best solution in
that case - both accessible from the Power Button menu so relatively quick to
enable/disable.
Comment 6 Rob 2010-01-12 16:11:12 UTC
all they need to do is put option in profile to do both i would say that would
be easy
Comment 7 Neil MacLeod (reporter) maemo.org 2010-01-12 16:24:57 UTC
(In reply to comment #6)
> all they need to do is put option in profile to do both i would say that would
> be easy
> 

Agreed, but if the decision was to do nothing and WONTFIX this bug because
adding an option is against "the specification" (which, I fear, will almost
certainly the case) then having the ringtone only play through the speakers
when audio is NOT playing through the connected headphones (wired or bluetooth)
is probably the best solution as it wouldn't require an option and would work
automatically in virtually all cases.

It also might be quite useful when you think about it, and better than an ON or
OFF option. Imagine you've just got home, turned off the media player, put down
your N900 with wired headphones still attached... you want to hear that
ringtone don't you? Yet when you're listening to music or watching a video on
the bus etc. you don't need all the passengers to hear your phone ringing. The
solution outlined in comment #4 works in both cases.
Comment 8 Johan Compagner 2010-01-12 21:18:11 UTC
i already also commented on the bug that was fixed and that introduced this
behavior. Problem is that there are many different use cases.

1> in my car i have a bluetooth headset on for phone calls:
  Then i want to hear the ring over the phone, also i want to hear the
navigation voice over the phone and not over the headset because the headset i
just have for calls

2> in my car i have a bluetooth car kit:
  Now i want everything over the car kit and the phone doesnt have to do
anything.

3> in the train i am listening to the music through a headset
  Now when i get a call i do want to just hear it over the headset..

4> walking in the city, listening to music and with voice navigation over a
headset
  Now again i only want to hear everything over the headset..

5> in my house i have a bluetooth headset connected for calls (no music or
navigation)
  Now again the ring tone should go over the phone.. and the call itself over
the headset.

As you can see.. there are so many options when you want to hear what..
It would be very nice to have something like this to be profiles, so a profile
defines what kind of sound should go over what...
Comment 9 Neil MacLeod (reporter) maemo.org 2010-01-12 21:50:18 UTC
@Johan (comment 8):

Excellent, let's see...

1) Handled by comment #4
-> As long as the N900 is NOT playing audio, the ringtone will be output from
the N900 speakers and not the attached headset. Can't speak for the voice
navigation app, depends on the Navigation application. Presumably if your BT
headset doesn't support A2DP you'll only get voice calls over the headset, with
everything else (audio and voice nav) through the N900 speakers?

2) Handled by comment #4 (I think if I've understood what you want to happen)
-> As long as the phone is not playing audio, the ringtone would be heard
through the N900 speakers, and the call will take place over the car Bluetooth
system. If you were playing audio from the N900 over the car Bluetooth system
then the ringtone would be heard through the car speakers (see HiFi example in
comment 4).

3) Handled by comment #4
-> Audio playing, so ringtone will be output through headset only, but speakers
would be used if no audio/music were being played.

4) Handled by comment #4
-> You're playing music so the ringtone should be heard through the headset
only, not sure about voice navigation - possibly out of scope for this bug?
Could be played through the headset, really depends on the navigation
application?

5) Handled by comment #4
-> No audio playing so ringtone would be heard through the N900 speakers, with
the call taking place through the Bluetooth headset

Or have I misunderstood?
Comment 10 Johan Compagner 2010-01-12 22:08:15 UTC
yes you are right except that i take into account the voice navigation.
Because on the E90 this was very annoying.. (the bluetooth headset was also
used by voice app)
I hope that a voice navigation application can configure itself where the sound
should go over

thats why i had point 1 and 4, because in 1 i want to have it over the speakers
(headset only for calls) and in 5 i want to have it also over the headset..
(point 4 can be with or without music)

But you could be right that it could be out of scope for this bug, i wanted
just to bring on as many examples as possible. I just hope that an application
can have to option where it wants its own sound over, so that a navigation
product can give me options. But i dont know if there is api for that.
Comment 11 chavalotetomalosplatanos 2010-01-12 22:26:37 UTC
(In reply to comment #0)
> SOFTWARE VERSION:
> 2.2009.51-1
> 
> EXACT STEPS LEADING TO PROBLEM: 
> 1. Connect headphones (either the in-box Nokia headphones with call answer
> button, or third party headphones only)
> 2. Open Media Player, play a song and listen through the headphones
> 3. Incoming call is received
> 
> EXPECTED OUTCOME:
> 
> 4. Ringtone is ONLY heard through headphones
> 
> ACTUAL OUTCOME:
> 
> 4. Ringtone is heard loudly through N900 loudspeakers (and very quietly in
> headphones)
> 
> REPRODUCIBILITY:
> Always
> 
> EXTRA SOFTWARE INSTALLED:
> N/A
> 
> OTHER COMMENTS:
> 
> Same behaviour in 1.2009.44-1.
> 
> All other phones I have owned the ringtone is only heard through the
> loudspeakers when headphones are connected.
> 

I just noticed this behaviour does not happen with BT headphones, at least not
with BH-212. The ringtone is only heard thru the headphone and not thru the
phone speakers, which is a pity.
Comment 12 Neil MacLeod (reporter) maemo.org 2010-01-12 22:30:56 UTC
Modification of title to better reflect potential solution to the problem.

(In reply to comment #10)
> yes you are right except that i take into account the voice navigation.
> Because on the E90 this was very annoying.. (the bluetooth headset was also
> used by voice app)
> I hope that a voice navigation application can configure itself where the sound
> should go over
> 

@Johan - many thanks. This bug mainly concerns itself with how the ringtone is
routed when a headset is connected rather than the routing of voice navigation
- any problems with voice navigation would need to be handled by a seperate
enhancement against the specific app, would be my guess.

As things stand I would expect voice navigation to be routed over the headset
if a headset is connected - can you say what currently happens?

Whether there is an API to specify the output device I don't know, but I
suspect it should be possible.
Comment 13 Neil MacLeod (reporter) maemo.org 2010-01-12 22:33:48 UTC
(In reply to comment #11)
> 
> I just noticed this behaviour does not happen with BT headphones, at least not
> with BH-212. The ringtone is only heard thru the headphone and not thru the
> phone speakers, which is a pity.
> 

Interesting... however the solution I have proposed in comment #4 would now
satisfy your requirement too, correct? (Assuming it ever gets implemented...)
Comment 14 Johan Compagner 2010-01-12 22:38:26 UTC
at the moment there are no voice navigation apps, waiting for or Ovi Maps or
Sygic to release that kind of software. If one of them do i will test it and
then discuss with them and i guess through bugs.maemo for a solution (which i
expect to happen because i dont think that it will work out of the box ;) )

Just have in mind that we should have in the end i guess choice for a user what
ever source will go over what ever output.
Comment 15 David Ward 2010-01-13 00:53:06 UTC
(In reply to comment #5)
> (In reply to comment #3)
> > 
> > well if your not using headset turn it off what if your sitting in public place
> > like a bus i don't want people hearing everytime someone txt you or a call. 
> > i think it should have option for both!
> > 
> 
> Muting the volume or selecting the Silent profile might be the best solution in
> that case - both accessible from the Power Button menu so relatively quick to
> enable/disable.
> 

This is the best solution, besides having both ways configurable through
Settings [which I don't know why isn't done more with these types of "bugs"]

The issue that prevents your suggestion working, Neil, is bug 6684
[https://bugs.maemo.org/votes.cgi?action=show_bug&bug_id=6694]

If that is fixed, then using profiles to control this behaviour would work and
was probably Nokia's intention.
Comment 16 Neil MacLeod (reporter) maemo.org 2010-01-13 01:15:09 UTC
David, yes there probably is some dependency on bug 6694 - if the phone is in
silent mode but with headphones connected (and no audio playing) then the
ringtone should not be heard through the speakers (or headphones?) ie. this bug
should respect the current profile (hopefully that was obvious but you never
know so worth spelling out!)

I suspect the phone/audio/profile side of things still needs a fair bit of work
to bring it up to scratch... needless to say I'm not expecting this bug to be
fixed any time soon! :)
Comment 17 Rob 2010-01-13 01:53:28 UTC
i have tested and with headphone pluged in the sound will come out of phone

but if bluetooth with a2dp it only comes through headset!!!

so it does know and must look what type of headset it is 

yay!!!!!!
Comment 18 David Ward 2010-01-13 02:08:56 UTC
(In reply to comment #16)
> David, yes there probably is some dependency on bug 6694 - if the phone is in
> silent mode but with headphones connected (and no audio playing) then the
> ringtone should not be heard through the speakers (or headphones?) ie. this bug
> should respect the current profile (hopefully that was obvious but you never
> know so worth spelling out!)

Right and this is the behaviour from my memory, am I wrong?
So basically, when bug 6694 is fixed for any third party app, then one can
control whether or not phones call rings are heard through the loudspeakers by
setting the Profile. A bit different to other phones, but definately workable
and potentially better as it gives more permutations.

Please correct me if I am wrong or misunderstand.
Comment 19 Neil MacLeod (reporter) maemo.org 2010-01-13 10:39:38 UTC
(In reply to comment #18)
> (In reply to comment #16)
> 
> Right and this is the behaviour from my memory, am I wrong?
> So basically, when bug 6694 is fixed for any third party app, then one can
> control whether or not phones call rings are heard through the loudspeakers by
> setting the Profile. A bit different to other phones, but definately workable
> and potentially better as it gives more permutations.
> 
> Please correct me if I am wrong or misunderstand.
> 

Not really.

The General profile currently routes the ringtone to the speakers when wired
headphones are connected and the user is listening to music... that isn't
useful in most circumstances and I doubt users will want to manually change
their profile each time they listen to the media player to avoid this so an
automatic solution needs to be found to this annoying "bug" without changing
profiles (and ideally without adding more options to each profile as this is
something Nokia don't like implementing).

The proposal offered here seems to satisfy those who do want to hear the
ringtone when headphones are connected and also those who don't want to hear
it, without adding options or changing profiles - it's more common sense,
you'll only hear the ringtone through the speakers when you need to hear it
through the speakers.

I agree there is a connection with profiles but only in the sense that assuming
this bug is implemented as described in comment #4, then when the Silent
(rather than General) profile is selected the ringtone should *never* play
through the speakers under any circumstances - headphones connected or not,
music playing or not (assuming bug 6694 gets fixed).

When the General profile is selected the device behaves as per comment #4.
Comment 20 Neil MacLeod (reporter) maemo.org 2010-01-13 22:02:12 UTC
(In reply to comment #17)
> i have tested and with headphone pluged in the sound will come out of phone
> 
> but if bluetooth with a2dp it only comes through headset!!!
> 
> so it does know and must look what type of headset it is 
> 
> yay!!!!!!
> 

An aside: Just tested with a SonyEricsson HBH-DS970 Bluetooth 2.0 headset which
supports A2DP... and the ringtone for an incoming call is played out of the
N900 speakers!

So ringtone behaviour is not even consistent across different Bluetooth
devices, and this bug is really asking for improved and also consistent
ringtone routing for both wired and Bluetooth headsets/headphones.
Comment 21 Rob 2010-01-15 03:27:21 UTC
i think people are taking this way too far !

all we need is a option to either route sound through both or only headset!

sound pretty easy to me 

if you start asking for too much it will never be done!
Comment 22 Neil MacLeod (reporter) maemo.org 2010-01-15 03:40:19 UTC
(In reply to comment #21)
> i think people are taking this way too far !
> 
> all we need is a option to either route sound through both or only headset!
> 
> sound pretty easy to me 
> 
> if you start asking for too much it will never be done!
> 

Asking for an option is often too much - welcome to Nokia & Maemo. ;)

You might think a new option is the easier solution - and on the face of it I
would tend to agree - but from experience, overloading the GUI with
yet-another-option is looked upon less favourably than a solution that "just
works, automatically, no options required".

And for once I actually think this bug might be solvable without recourse to an
option. In a nutshell, if the user is listening to audio then route the
ringtone to the same output device they are currently listening to, but if not
then route it to the built-in speakers.
Comment 23 Rob 2010-01-15 04:16:16 UTC
(In reply to comment #22)
> (In reply to comment #21)
> > i think people are taking this way too far !
> > 
> > all we need is a option to either route sound through both or only headset!
> > 
> > sound pretty easy to me 
> > 
> > if you start asking for too much it will never be done!
> > 
> 
> Asking for an option is often too much - welcome to Nokia & Maemo. ;)
> 
> You might think a new option is the easier solution - and on the face of it I
> would tend to agree - but from experience, overloading the GUI with
> yet-another-option is looked upon less favourably than a solution that "just
> works, automatically, no options required".
> 
> And for once I actually think this bug might be solvable without recourse to an
> option. In a nutshell, if the user is listening to audio then route the
> ringtone to the same output device they are currently listening to, but if not
> then route it to the built-in speakers.
> 

once again your over thinking with the whole idea of only through headset.

what if i was only web surfing or playing with device and no audio playing i
still don't want it to come out of loud specker full stop.

it would not be too hard to build this into the profile as i stated above. or
build it into bluetooth settings.

it was working well before the update. was loving it but to have to put in
silent all the time sucks as not always feel vibrate.

i really hope this gets done so both partys can have what they want
Comment 24 Neil MacLeod (reporter) maemo.org 2010-01-15 04:26:35 UTC
(In reply to comment #23)
> what if i was only web surfing or playing with device and no audio playing i
> still don't want it to come out of loud specker full stop.
> 

I believe that is what the Silent profile is for.

> 
> i really hope this gets done so both partys can have what they want
> 

Indeed.
Comment 25 Rob 2010-01-15 05:53:08 UTC
(In reply to comment #24)
> (In reply to comment #23)
> > what if i was only web surfing or playing with device and no audio playing i
> > still don't want it to come out of loud specker full stop.
> > 
> 
> I believe that is what the Silent profile is for.
> 
> > 
> > i really hope this gets done so both partys can have what they want
> > 
> 
> Indeed.
> 

dude silent is for silent!! if i stopped to do something and put device in
pocket i still want to hear it only in headset as its on both ears

we keep going around in circles this bug is to try to sort something to impove
this tablet + phone 

does your laptop play out loud speckers when your playing games with bluetooth
or headphones and you get a message NO it does not.

this is what we want fixed! or improved
Comment 26 Johan Compagner 2010-01-16 17:12:01 UTC
by the way there are on the N900 3 ways to do the output.

1> speakers
2> bluetooth/headset
3> fm

and maybe 2 is even split up in 2 because with bluetooth you have headsets and
for example in car speakers.. and the last one falls more into the fm category
especially when i am thinking about voice navigation..

So i think in the end, #4 will improve it for the most people, it will be best
if this was handled by profiles, where you can have profiles where you exactly
say where the sound can or should go over.

The applications dont have to have extra options no it is handled by a general
profile setting.
Comment 27 Neil MacLeod (reporter) maemo.org 2010-03-17 17:01:32 UTC
*** Bug 9578 has been marked as a duplicate of this bug. ***
Comment 28 Andre Klapper maemo.org 2010-10-11 18:01:38 UTC
--> audio policy

I assume this is still valid for 10.2010.19-1, right?
Comment 29 Andre Klapper maemo.org 2010-10-13 20:35:02 UTC
(In reply to comment #4)
> When the device IS playing a media file through headphones it should be 
> assumed the user has the headphones placed in his or her ears, in which 
> case playing the ringtones through the device speakers is completely 
> unnecessary.


Quoting from Nokia's internal Maemo5 Sound Interaction UI Specification:
»When routing audio and sounds the following rules should be complied:
 7. If user has paired Bluetooth headset, all audio is routed there.
 8. If user has plugged wired headset, all audio is routed there.
 10. Ringtone and alarm is always routed to loudspeaker in addition to
 the normal routing.«

There are no changes to audio policy for Maemo5 planned by Nokia as far as I
know (=WONTFIX).
And for Maemo6/Harmattan I cannot find an audio policy specification yet...
Comment 30 Andre Klapper maemo.org 2010-10-26 17:04:10 UTC
Currently still valid for Nokia's internal Harmattan Audio policy:
"The Ringtone and other incoming event sounds are routed to both the device’s
loudspeakers and a possibly connected headset."
Comment 31 Andre Klapper maemo.org 2010-12-30 18:50:34 UTC
Internal WONTFIX comment by Sami Ronkainen:
"The reason for duplicating certain sounds to the device IHF is that there's no
guarantee that when a headset (especially a Bluetooth one) is connected, it
would be on the user's ear. If one forgets to disconnect a headset, or if one
has connected a line-out cable to the device but the other end of the cable is
on a stereo that has been turned down/off, the user would miss calls and
alarms. In other words, the user cannot use a headset to mute the phone (from
outsiders). If avoiding disturbance to the environment is desired, the user
must use the silent profile."
Comment 32 David Ward 2010-12-31 03:01:39 UTC
Can this not just be configurable so the user can decide which way they like it
best for them?
Comment 33 Andre Klapper maemo.org 2010-12-31 03:44:43 UTC
(In reply to comment #32)
> Can this not just be configurable

Feel free to file a report for MeeGo in bugs.meego.com and post the URL here.
For Maemo it's WONTFIX.
Comment 34 chantinhvn 2012-03-23 20:15:00 UTC
juh jjj