Bug 7832 - Browser process opens UDP ports on all interfaces.
: Browser process opens UDP ports on all interfaces.
Status: RESOLVED DUPLICATE of bug 7620
Product: Browser
MicroB engine
: 5.0/(1.2009.44-1)
: N900 Maemo
: Unspecified normal (vote)
: ---
Assigned To: unassigned
: microb-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-12 01:13 UTC by r.c.g
Modified: 2010-10-25 18:40 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description r.c.g (reporter) 2010-01-12 01:13:36 UTC
EXACT STEPS LEADING TO PROBLEM: 
1. Boot/Reboot (.. the below described behavior could be observed even on a
newly flashed device booted for the first time)
2. Wait about 3-5 minutes for all background tasks to finish/start up..
3. Open xterm
4. lsof -i4
   --> browser is listening on a random unprivileged UDP port (e.g. 52821 or
64976 after another reboot) on all interfaces.

EXPECTED OUTCOME:
Browser should not listen on any "external" interfaces.

ACTUAL OUTCOME:
Browser is listening on a random unprivileged UDP port on all interfaces by
default.

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.7)
Gecko/20100109 Gentoo Firefox/3.5.7
Comment 1 timeless 2010-01-12 01:50:31 UTC
doesn't happen in 53-2. this will not make the coming major update. and i doubt
it will make any minor updates before the subsequent major update.

btw, your bug still sucks. the template is meant to be filled in properly.

> REPRODUCIBILITY:
> (always, less than 1/10, 5/10, 9/10)

you're supposed to pick one.

and given that i gave you a much better steps to reproduce in the other bug, i
don't approve of your failure to use copy and paste.

thank you for wasting my time.
Comment 2 Andre Klapper maemo.org 2010-01-12 14:00:35 UTC
Please avoid wasting everybody's time by filing duplicates, otherwise your
account will be disabled.
Comment 3 Andre Klapper maemo.org 2010-01-12 14:00:43 UTC

*** This bug has been marked as a duplicate of bug 7620 ***