Bug 7811 - Release source code of Calendar on open licence
: Release source code of Calendar on open licence
Status: CLOSED WONTFIX
Product: Licensing Change Requests
General
: 5.0/(3.2010.02-8)
: All Maemo
: Unspecified enhancement with 9 votes (vote)
: ---
Assigned To: Quim Gil
: licensing-requests
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-11 19:05 UTC by Marcin Juszkiewicz
Modified: 2010-02-19 14:20 UTC (History)
7 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Marcin Juszkiewicz (reporter) 2010-01-11 19:05:15 UTC
SOFTWARE VERSION:
42.11

EXACT STEPS LEADING TO PROBLEM: 
1. open browser and go to
https://bugs.maemo.org/buglist.cgi?bug_status=__all__&product=Calendar
2. read bugs
3. think few minutes on how much time is needed to fix simpler ones

EXPECTED OUTCOME:
Source code available in maemo.gitorious.org

ACTUAL OUTCOME:
No sources

REPRODUCIBILITY:
always

OTHER COMMENTS:
I am thinking that quality of calendar source code is just poor so that's why
it was not released into public...

------- Comment #1 from aklapper@openismus.com  2010-01-09 00:25 GMT+3 -------
Added the Calendar to the list at
http://wiki.maemo.org/Open_development/Why_the_closed_packages#Waiting_list

Assigning to Quim to get the reasons why this is closed source, or why Nokia
maybe plans to keep this closed source.
Comment 1 Jeff Moe 2010-01-11 19:37:43 UTC
I'm not sure what all packages you are looking for, but "calendar-backend" is
in 
git:

http://maemo.gitorious.org/calendar-backend

git://gitorious.org/calendar-backend/calendar-backend.git
Comment 2 Martin Dengler 2010-01-11 21:41:16 UTC
I don't share the tone of the original report, but (as a professional
programmer and n900 owner) I would be interested in contributing patches to the
GUI.  Please open source it or move to an open sourcde GUI.
Comment 3 Quim Gil nokia 2010-01-12 15:07:35 UTC
In general the open source strategy in Maemo puts the stress on the platform
components, but not on the applications.
Comment 4 Martin Dengler 2010-01-12 15:25:43 UTC
Fair enough, and a balance has to be struck.  In light of [1], I think it's
worth pointing out that the proposal to open-source Calendar seems to have the
following justifications:

a) Nurture application development
b) Community maintenance

(from [1]).

Would you prefer we use Brainstorm for this request?

If it's not going to happen now, then let's just close the bug and move on (to
other calendars, for some :( ).  Better clarity than the eventual bitterness of
false hope.

1.
http://wiki.maemo.org/Why_the_closed_packages#Requesting_the_opening_of_closed_components
Comment 5 Fino Fluxper 2010-01-16 14:00:25 UTC
I would like to support this request. I'm especially interested in the Calendar
Home Desktop widget.
Comment 6 David Sommerseth 2010-02-08 15:20:05 UTC
I would also like to see the Calendar app being opened up.  I find the app
initially nice and feel no immediate need to start something from scratch.  But
there are things which I would like to see different and would like to
contribute with patches.

If getting involved in other Calendar projects is what's needed, I'll probably
end up by doing that.  But I would like to contribute to *this* calendar,
because I do mostly like it.
Comment 7 Andre Klapper maemo.org 2010-02-16 19:57:56 UTC
(Moving all Licensing Change Requests to a separate Product in Bugzilla.
Sorry for the bugmail noise)
Comment 8 Carsten Munk maemo.org 2010-02-18 16:50:05 UTC
Temporarily setting this to priority unspecified while it gets evaluated.
Comment 9 Quim Gil nokia 2010-02-19 09:50:46 UTC
After checking...

The Fremantle Calendar application won't be opened. Note that the Calendar
backend component in the platform is open source.

The Calendar application in MeeGo devices from Nokia has no plans to be open
source.

MeeGo plans to offer a set of reference applications under an open source
license. The concrete list of applications hasn't been published but maybe a
Calendar is included in the list (I don't know myself). Please ask in the MeeGo
project directly if you are interested.
Comment 10 Marcin Juszkiewicz (reporter) 2010-02-19 14:20:43 UTC
(In reply to comment #9)

> The Fremantle Calendar application won't be opened. The Calendar application in 
> MeeGo devices from Nokia has no plans to be open source.

Sad. This means that MeeGo based nokia phones will still have non-working
calendar app.

> Note that the Calendar backend component in the platform is open source.

I know. Time to write proper Calendar by community?

> MeeGo plans to offer a set of reference applications under an open source
> license. The concrete list of applications hasn't been published but maybe a
> Calendar is included in the list (I don't know myself). Please ask in the MeeGo
> project directly if you are interested.

So far MeeGo project is promises and discussions with big noise to signal
ratio. No code was offered, no informations which devices will be supported.
But this is outside of scope of that bug.

I am closing bug.