Bug 7806 - (int-141951) Browser crashes while sending a comment to Maemo.org
(int-141951)
: Browser crashes while sending a comment to Maemo.org
Status: CLOSED FIXED
Product: Browser
MicroB engine
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low major (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: microb-bugs
:
: crash
:
:
  Show dependency tree
 
Reported: 2010-01-11 16:25 UTC by EC
Modified: 2010-03-15 20:51 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description EC (reporter) 2010-01-11 16:25:54 UTC
EXACT STEPS LEADING TO PROBLEM: 
1. Open your browser and go to Maemo.org
2. Select an application in the Download section (or in the Extras
Testing/Devel section, where you can send a comment to the apps in testing
phase)
3. Write a comment and send it
4. While sending the comment (it will take ages), press Ctrl+Backspace, go to
the menu and open another browser session.
5. While it is uploading the comment in the background, browse the web in the
second session

EXPECTED OUTCOME: the comment is sent while you are able to navigate with the
second page opened

ACTUAL OUTCOME: Web application crashes, "Internal error. "Web" application
closed" message appeares.

REPRODUCIBILITY: 7/10, depends on the load of the pages you are browsing in the
second session.

OTHER COMMENTS: I've already reported this bug, under Maemo Official
Applications category (Maemo browser), but it was INVALID because too general.
Now I think that this is not a bug of the browser, because I can reproduce it
with about 100% probabilities only with Maemo.org, and only while sending a
comment. 

User-Agent:       Mozilla/5.0 (X11; U; Linux armv7l; it-IT; rv:1.9.2a1pre)
Gecko/20090928 Firefox/3.5 Maemo Browser 1.4.1.22 RX-51 N900
Comment 1 EC (reporter) 2010-01-11 16:29:01 UTC
Ah, I've forgotten: I've already sent 2 crash reports using Crash Reporter, the
first one with a general description of the problem and the second one with a
more accurate description, as timeless@gmail.com suggested to me when he closed
my previous bug report. I'll continue sending core dumps including this bug
number, as he said.
Comment 2 Andre Klapper maemo.org 2010-01-11 22:11:14 UTC
Please file software bugs against software and not against Websites. Also, this
does not mention a version number at all. Please always fill out the complete
template.
Comment 3 Andre Klapper maemo.org 2010-01-11 22:11:54 UTC
I wonder if this is related to bug 7416.
Comment 4 EC (reporter) 2010-01-11 22:56:50 UTC
Sorry for version missing, I'll be more careful next time. I don't think this
is related to the bug you mentioned, I can't reproduce it and I've never had
problem with bugs.maemo.org.
Comment 5 EC (reporter) 2010-01-14 13:30:54 UTC
I'm able to reproduce this bug after the new fw upgrade PR1.1, I'm updating the
version field.
Comment 6 Andre Klapper maemo.org 2010-01-14 17:58:02 UTC
Hmm, must admit that I don't have access to the server infrastructure behind
Crash Reporter...
Comment 7 EC (reporter) 2010-01-14 18:09:41 UTC
(In reply to comment #6)
> Hmm, must admit that I don't have access to the server infrastructure behind
> Crash Reporter...
> 

Could not understand what you are trying to say. What's the point?
Comment 8 timeless 2010-01-15 00:16:43 UTC
sorry. he's saying that i need to look this up.

can you please indicate what unique word or phrase you used? I tried searching
for '7806' and 'Cassioli', but neither turned up. note that 'maemo' and
'maemo.org' are not good choices of unique words.
Comment 9 EC (reporter) 2010-01-15 10:07:50 UTC
In every core dump sent I've written "Bug #7806" or "Bug 7806", and something
like "sending a comment to Maemo.org". Hope this helps
Comment 10 timeless 2010-01-15 13:18:26 UTC
tuukka: i can't find those using the external server, can you look for them
internally? (my day has expired)
Comment 11 tuukka.tolvanen nokia 2010-01-19 16:05:11 UTC
> tuukka: i can't find those using the external server, can you look for them

It should be working again.

"7806" found four incidents:
 * two from 1.2009.44-1 matching int-141951 fixed in internal 2.2009.47-5
 * two from 2.2009.51-1 matching int-136148 fixed in internal 10.2009.53-2
Comment 12 EC (reporter) 2010-01-19 16:12:01 UTC
Ok after the last PR1.1 update and the Maemo.org server moving I can't
reproduce it anymore, don't know if the update fixed it or it was just a site
problem. Anyway, VERIFIED for me
Comment 13 Andre Klapper maemo.org 2010-03-15 20:51:41 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).