Bug 7777 - Portrait mode rotation: Choppy
: Portrait mode rotation: Choppy
Status: RESOLVED DUPLICATE of bug 6203
Product: StockThis
General
: unspecified
: N900 Maemo
: Medium normal (vote)
: ---
Assigned To: Daniel Martin Yerga
: general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-10 07:27 UTC by Sanjeev Visvanatha
Modified: 2010-01-10 13:34 UTC (History)
0 users (show)

See Also:


Attachments
Bottom row of buttons appear 1/3 from bottom right after switch to portrait mode (31.65 KB, image/png)
2010-01-10 07:29 UTC, Sanjeev Visvanatha
Details
after portrait mode is enabled fully, the bottom row of 3 buttons are in the correct location (38.83 KB, image/png)
2010-01-10 07:30 UTC, Sanjeev Visvanatha
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Sanjeev Visvanatha (reporter) 2010-01-10 07:27:08 UTC
SOFTWARE VERSION:
(Settings > General > About product)
1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Open Stock This app in landscape mode
2. Switch to portrait mode by turning phone 90 degrees clockwise
3. 

EXPECTED OUTCOME:
1. portrait mode enabled and all ui buttons are in portrait mode locations
right away like the Phone app

ACTUAL OUTCOME:
1. The 3 buttons at the bottom (portfolio, info and search) appear about 1/3
from the bottom momentarily, and then move to the buttom of the portrait
screen.   

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
always

EXTRA SOFTWARE INSTALLED:
many apps from extras.

OTHER COMMENTS:
see attaached screenshots 

User-Agent:       Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.2a1pre)
Gecko/20090928 Firefox/3.5 Maemo Browser 1.4.1.21 RX-51 N900
Comment 1 Sanjeev Visvanatha (reporter) 2010-01-10 07:29:01 UTC
Created an attachment (id=1950) [details]
Bottom row of buttons appear 1/3 from bottom right after switch to portrait
mode
Comment 2 Sanjeev Visvanatha (reporter) 2010-01-10 07:30:48 UTC
Created an attachment (id=1951) [details]
after portrait mode is enabled fully, the bottom row of 3 buttons are in the
correct location
Comment 3 Daniel Martin Yerga 2010-01-10 13:34:39 UTC
Thanks for reporting this.

It is a general problem with 3rd party applications that support rotation.

Fortunately it is fixed in the PR 1.1 version (2.2009.51-1).

*** This bug has been marked as a duplicate of bug 6203 ***