Bug 7758 - (int-152532) Daily image counter in photo filenames not incrementing in some cases
(int-152532)
: Daily image counter in photo filenames not incrementing in some cases
Status: RESOLVED FIXED
Product: Images and Camera
Camera
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: camera-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-07 20:37 UTC by Lucas Maneos
Modified: 2010-03-15 20:54 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Lucas Maneos (reporter) 2010-01-07 20:37:07 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Start camera app.
2. Set storage to internal storage.
3. Take a photo.
4. Transfer photo via USB, scp, sharing service etc.
5. Delete photo.
6. Take another photo.
7. Set storage to memory card.
8. Take another photo.

EXPECTED OUTCOME:
The image counter should increment in all cases.

ACTUAL OUTCOME:
The filenames of saved photos after steps 3, 6 and 8 are identical.

REPRODUCIBILITY:
Always.

OTHER COMMENTS:
Could lead to losing photos (by overwriting existing ones) if one is not
careful when moving out of the device.
Comment 1 Andre Klapper maemo.org 2010-01-11 15:39:44 UTC
------- Comment #1 from jfernandez  2010-01-08 13:10 GMT+3 -------
I can confirm this bug. 
I think the patch is being tested right now, so hopefully it will be integrated
soon in the next release; let see.
Comment 2 Venomrush 2010-01-13 06:30:40 UTC
(In reply to comment #2)

> 7. Set storage to memory card.

This is new. No option to set storage in 44-1
Comment 3 Lucas Maneos (reporter) 2010-01-22 07:58:56 UTC
*** Bug 8292 has been marked as a duplicate of this bug. ***
Comment 4 Andre Klapper maemo.org 2010-02-09 20:10:15 UTC
This has been fixed in the internal build version
10.2010.06-3
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 5 Andre Klapper maemo.org 2010-03-15 20:54:33 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).