Bug 7757 - (int-152534) wrong cmt-firmware-rx51 (cell modem) version in published firmware?
(int-152534)
: wrong cmt-firmware-rx51 (cell modem) version in published firmware?
Status: CLOSED FIXED
Product: Telephony
General
: 5.0/(2.2009.51-1)
: All Maemo
: Low normal with 2 votes (vote)
: 5.0/(3.2010.02-8)
Assigned To: unassigned
: telephony-general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-07 20:29 UTC by Yves-Alexis
Modified: 2010-03-02 23:15 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Yves-Alexis (reporter) 2010-01-07 20:29:45 UTC
SOFTWARE VERSION:
(Settings > General > About product)

1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. apt-cache show cmt-firmware-rx51 
2. 
3. 

Long description for cmt-firmware-rx51 says:

Description: Nokia RX51 cellular modem firmware
 This package contains the proprietary flashable binary blob for the
 cellular modem terminal found on the Nokia RX51 device.
 .
 This verison sends an SMS automatically to report crashes.
 The normal firmware is in the FTDOP variant.
 Do not put this in final products!!

Package version is:

Version: 8.2.2009.34.3-2+0m5

EXPECTED OUTCOME:

firmware doesn't appear in final product.

ACTUAL OUTCOME:

the firmware did appear in final product.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
n/a

OTHER COMMENTS:
I'm a bit puzzled by the “Do not put this in final products!!”, and even more
by the “This verison sends an SMS automatically to report crashes.”. I guess
this shouldn't really have been pushed to a public release.

If you need any more info, feel free to ask. I hope I set the component
correctly.

Cheers,
--
Yves-Alexis


User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.1.6)
Gecko/20091221 Shiretoko/3.5.6
Comment 1 Valério Valério maemo.org 2010-01-07 20:33:43 UTC
Confirmed in 51.1.
Comment 2 Valério Valério maemo.org 2010-01-07 20:43:15 UTC
(In reply to comment #1)
> Confirmed in 51.1.
> 

Here is the text used in the package available in 51.1:

"Description: Nokia RX51 cellular modem firmware
 This package contains the proprietary flashable binary blob for the
 cellular modem terminal found on the Nokia RX51 device.
 .
 This version sends an SMS automatically to report crashes.
 The normal firmware is in the FTDOP variant.
 Do not put this in final products!!"
Comment 3 Lucas Maneos 2010-01-07 20:44:13 UTC
Now the question is whether we have debug firmware or someone just forgot to
update the package description ;-)

Anyone notice unusual SMS charges?
Comment 4 Yves-Alexis (reporter) 2010-01-07 20:49:48 UTC
In 42-11 the “verison” typo is genuine (at first I thought it was sending SMS
to verizon).

Didn't notice SMS charges but I didn't have crashes yet, afaik. (I have
unlimited sms but I still have some details on the sent SMS)
Comment 5 Andre Klapper maemo.org 2010-01-07 23:26:52 UTC
Confirming, and the Product guess was correct. :)
Comment 6 Andre Klapper maemo.org 2010-01-21 16:23:22 UTC
This has been fixed in package
cmt-firmware-rx51 8.2.2009.47-1.97+0m5
which is part of the internal build version
3.2010.02-3
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 7 Yves-Alexis (reporter) 2010-01-21 16:33:35 UTC
(In reply to comment #6)
> This has been fixed in package
> cmt-firmware-rx51 8.2.2009.47-1.97+0m5
> which is part of the internal build version
> 3.2010.02-3
> (Note: 2009/2010 is the year, and the number after is the week.)
> 
> A future public update released with the year/week later than this internal
> build version will include the fix. (This is not always already the next public
> update.)
> Please verify that this new version fixes the bug by marking this bug report as
> VERIFIED after the public update has been released and if you have some time.

Thanks! I'll keep you posted.

Cheers,
--
Yves-Alexis
Comment 8 Andre Klapper maemo.org 2010-02-16 14:06:53 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 3.2010.02-8 (also called "PR1.1.1"
sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 9 Lucas Maneos 2010-02-16 14:50:19 UTC
Well, the package description does not contain second paragraph anymore. 
Whether the actual firmware contained inside is a production or debug version
is just as hard to tell as before :-)
Comment 10 Yves-Alexis (reporter) 2010-02-16 23:47:29 UTC
Ok, confirmed the description has been updated. No way to know if the firmware
itself has been updated too but I guess so :)