Bug 7737 - HildonDateSelector should show day of the week on the day list
: HildonDateSelector should show day of the week on the day list
Status: RESOLVED WONTFIX
Product: Desktop platform
hildon-widgets
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified enhancement with 18 votes (vote)
: ---
Assigned To: Claudio Saavedra
: hildon-libs-bugs
:
: patch
:
:
  Show dependency tree
 
Reported: 2010-01-07 11:17 UTC by Brad Grigor
Modified: 2012-03-24 13:54 UTC (History)
7 users (show)

See Also:


Attachments
date selector showing day of the week (46.87 KB, image/png)
2010-03-16 00:29 UTC, Claudio Saavedra
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Brad Grigor (reporter) 2010-01-07 11:17:42 UTC
SOFTWARE VERSION:
(Settings > General > About product)
N900 Maemo 5 1.2009.42-11.002

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. In Calendar app, choose New Event, see New Event dialog display.
2. Click either the "From" or "To" date buttons.
3. The scrolly "odometer" date picker shows Month, Day, Year.

EXPECTED OUTCOME:
The date picker should also show the day of week as you scroll as the day of
week is often very important when setting the date for an event, e.g. must be
on a Friday.

Even better (IMHO :-)... abandon this scrolly "odometer" paradigm and present
me with a real calendar grid for picking dates. It is much faster, more
informative and more visual (e.g. it is much easier on a grid to pick a date
that is, say, 3 weeks after a given date).

ACTUAL OUTCOME:
The day of week is not provided while picking a "From" or "To" date, which
reduces the efficiency of the app.

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
Always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
Personal opinion: "Touch" is a great concept, but scrolling through long lists
is an awefully inefficient way to find/choose things. So while I admit that the
scrolly "odometer" interface might look cool as a "touch" demonstration,
please, please refrain from actually using it in real applications. For date
picking, please give me a calendar grid and for time picking, please give me a
number pad--it's a lot faster.

User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1;
Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729;
Media Center PC 6.0; OfficeLiveConnector.1.4; OfficeLivePatch.1.3; Tablet PC
2.0)
Comment 1 Fredrik Wendt 2010-01-11 19:30:57 UTC
I agree totally. The current way the Calendar works is not sufficient for
people that use a calendar to play their days work. It's almost impossible to
answer questions like "won't three weeks from now be too late?" or "is that two
or three weeks before we go into production" or simply "why do you propose a
non-work day (saturday) as the day for next meeting" ...

I could settle on having a button next to Done that lets me pick from a month
or week view. But the current state is REALLY counter productive for business
usage. Makes me regret I didn't go for an Android-based phone, or any that
supports my business instead of hinders. :(
Comment 2 Fredrik Wendt 2010-01-11 19:31:05 UTC
*** This bug has been confirmed by popular vote. ***
Comment 3 RogerL 2010-01-25 21:42:52 UTC
Color coding the dates (red for Sunday or whatever day is sacred/free of work
in your region) would help.

But an actual month view is faster (and does already exist)
Comment 4 Johannes Twittmann 2010-01-26 16:14:21 UTC
This seems to be a duplicate of bug no. 5296
https://bugs.maemo.org/show_bug.cgi?id=5296
I can't update though.
Comment 5 Andre Klapper maemo.org 2010-01-29 15:01:50 UTC
*** Bug 8647 has been marked as a duplicate of this bug. ***
Comment 6 Andre Klapper maemo.org 2010-03-10 19:03:08 UTC
According to duplicate bug 9474 this is currently a WONTFIX for Nokia.
Comment 7 Andre Klapper maemo.org 2010-03-10 19:03:26 UTC
*** Bug 9474 has been marked as a duplicate of this bug. ***
Comment 8 Vincent Lefevre 2010-03-12 03:20:13 UTC
I'm very disappointed by this WONTFIX. How can users make Nokia change its
decision?

I could find a thread: http://talk.maemo.org/showthread.php?t=38723
and a brainstorm:
https://maemo.org/community/brainstorm/view/day_picker-could_be_replaced_by_a_true-date_picker--calendar_view-in_maemo_5/

Please vote there.
Comment 9 Claudio Saavedra 2010-03-16 00:28:02 UTC
As per popular request and out of boredom, reopening this. There's a chance
that we get this in at some point. I doubt it's gonna be soon, because of
localization requirements.
Comment 10 Claudio Saavedra 2010-03-16 00:29:42 UTC
Created an attachment (id=2478) [details]
date selector showing day of the week

This is the proposal. It is not really cluttered as I thought and switching the
month/year doesn't cause any odd effect while the days change.

I'll push it to a branch in gitorious tomorrow, for those who want to give it a
try.
Comment 11 Claudio Saavedra 2010-03-16 01:01:49 UTC
OK, pushed already, you can check it from here: 

http://maemo.gitorious.org/hildon/hildon/commits/date-selector-improvements
Comment 12 Andre Klapper maemo.org 2012-03-24 11:42:08 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )
Comment 13 RogerL 2012-03-24 13:01:36 UTC
There is already a patch for this, why havent it been applied?
Comment 14 Andre Klapper maemo.org 2012-03-24 13:54:58 UTC
RogerL: Don't know, maybe because Nokia designers didn't agree?