Bug 7734 - Passwords are shown when typing text that starts with similar letters.
: Passwords are shown when typing text that starts with similar letters.
Status: RESOLVED DUPLICATE of bug 5419
Product: Desktop platform
Input method framework
: 5.0/(1.2009.42-11)
: N900 Maemo
: Medium normal (vote)
: ---
Assigned To: Joaquim Rocha
: input-method-framework-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-07 09:17 UTC by Michiel
Modified: 2010-01-08 06:22 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Michiel (reporter) 2010-01-07 09:17:38 UTC
SOFTWARE VERSION: 1.2009.42-11
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. At several places in the device I've entered my password (i.e. e-mail
account, when logging on on websites etc.
2. When typing text (i.e. SMS or just notes) and start a word with the first
letter of my password, the suggested word that shows up is my password... 


EXPECTED OUTCOME:
- I'd expect that passwords that are typed in anywhere on the device (through
applications, browser etc.) are not cached in any matter and therefore do not
accidently show up when typing (Most likely the password is cached somewhere in
clear text as well)

ACTUAL OUTCOME:
- Password is stored somewhere (in clear text) and showed as visible when
typing text.

REPRODUCIBILITY:
Always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5)
Gecko/20091111 Firefox/3.5.5 (.NET CLR 3.5.30729)
Comment 1 Andre Klapper maemo.org 2010-01-07 19:16:18 UTC
> EXTRA SOFTWARE INSTALLED:

This part is missing.

I assume that this is a duplicate of bug 5419?
Comment 2 Michiel (reporter) 2010-01-08 06:22:43 UTC
Might be indeed duplicate of 5419. This is however not a WiFi password. The
password was either stored from the default e-mail client or by the browser as
those are the place I used to enter that password (hardware keyboard)

*** This bug has been marked as a duplicate of bug 5419 ***