Bug 7730 - Email drafts appear in all draft folders of all email accounts
: Email drafts appear in all draft folders of all email accounts
Status: RESOLVED DUPLICATE of bug 2557
Product: Email
General
: 5.0/(1.2009.42-11)
: N900 Maemo
: Medium enhancement (vote)
: ---
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-07 01:42 UTC by Jon Hedemann
Modified: 2010-01-07 12:32 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Jon Hedemann (reporter) 2010-01-07 01:42:04 UTC
SOFTWARE VERSION:
1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
1. Open the Email app.
2. Create a primary email account.
3. Create one or more secondary email accounts.
4. Open any one of your accounts.
5. Create a new email and close it (save is as a draft).

EXPECTED OUTCOME:
The draft email only appears in the draft folder of the email account in which
it has been created.

ACTUAL OUTCOME:
The draft email appears in all draft folders of all email accounts.

REPRODUCIBILITY:
Always.

EXTRA SOFTWARE INSTALLED:
None.

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7)
Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Comment 1 Vitaly Repin 2010-01-07 11:16:00 UTC
modest has only 1 draft folder for all the email accounts configured.
Comment 2 Jon Hedemann (reporter) 2010-01-07 11:48:27 UTC
(In reply to comment #1)
> modest has only 1 draft folder for all the email accounts configured.
> 

Well, that may be so, but then I believed this should be viewed as
illogigical/unintuitive behaviour, which should be changed.
Comment 3 Andre Klapper maemo.org 2010-01-07 12:32:47 UTC
As Drafts are not stored on the server (bug 2557) this is currently not
possible.
For IMAP this is just the same as bug 2557, hence marking as dup.

*** This bug has been marked as a duplicate of bug 2557 ***