Bug 7701 - (int-143290) Arabic language not shown or encoded in Modest
(int-143290)
: Arabic language not shown or encoded in Modest
Status: RESOLVED FIXED
Product: Email
General
: 5.0/(3.2010.02-8)
: N900 Maemo
: Low normal with 4 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-06 13:01 UTC by ginuwine51
Modified: 2010-04-06 23:14 UTC (History)
5 users (show)

See Also:


Attachments
Arabic language email through Modest N900 (32.10 KB, image/png)
2010-01-06 13:07 UTC, ginuwine51
Details
Arabic Headers from the modest (36.75 KB, image/png)
2010-01-06 14:35 UTC, ginuwine51
Details
Arabic language shown with Verdana writing style (43.84 KB, image/png)
2010-01-06 18:11 UTC, ginuwine51
Details
the Modest Arabic email after installing the more-gconv-modules package from diablo (111.11 KB, image/png)
2010-01-15 10:24 UTC, ginuwine51
Details
the same above Arabic email in the Modest inbox headers!! (48.41 KB, image/png)
2010-01-15 10:26 UTC, ginuwine51
Details
Email Content (96.94 KB, image/png)
2010-01-23 22:38 UTC, salah99
Details
iso-8859-15 encoding (1.02 KB, text/plain)
2010-01-23 22:39 UTC, salah99
Details
Screenshot of the fix (121.01 KB, image/png)
2010-03-15 14:57 UTC, Andre Klapper
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description ginuwine51 (reporter) 2010-01-06 13:01:20 UTC
I have my N900 with the firmware version 1.2009.42-11.003 which is the middle
east version with full zarabic support as i can read arabic sms and websites
and i can even write or type through the ukeyboard Arabic but the problem which
i'm facing since my N810 which i thought it's fixed in Maemo 5 is the email
application can't encode or show the arabic language and alawyas show
?????.???? sympols!! therefore can't read or use my N900 for checking or
reading my emails!


***hope this is a very simple problem to be fixed through some additional
program or software to be added to my phone or with the upcoming Firmware.
Comment 1 ginuwine51 (reporter) 2010-01-06 13:07:48 UTC
Created an attachment (id=1938) [details]
Arabic language email through Modest N900
Comment 2 Andre Klapper maemo.org 2010-01-06 14:04:58 UTC
Thanks for reporting this.
For future reference, please always use the bug template.

Can you please attach a complete email including headers here as an attachment?
(Please make sure that no confidential data is shown.)

Is Arabic correctly shown in the Browser on webpages?
Comment 3 ginuwine51 (reporter) 2010-01-06 14:35:30 UTC
Created an attachment (id=1939) [details]
Arabic Headers from the modest

yes Arabic websites are fukky supported and perfectly viewed along with the sms
too
Comment 4 Andre Klapper maemo.org 2010-01-06 15:12:44 UTC
(In reply to comment #3)
> Created an attachment (id=1939) [details] [details]
> Arabic Headers from the modest

Please attach an email. This is just another screenshot.
Comment 5 ginuwine51 (reporter) 2010-01-06 18:01:44 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > Created an attachment (id=1939) [details] [details] [details]
> > Arabic Headers from the modest
> 
> Please attach an email. This is just another screenshot.
> 

SORRY! but i don't know how to attach an email from the modest!! you will save
soo much trouble for me if u teach me how?!!:s but here is the thing, i did an
intensive experiment on forwarding emails to my modest on n900 from my laptop
and i just noticed and discovered something very important which is the arabic
language will perfectly shown in the modest if it's written in certain styles
like Verdana which is perfectly encoded in the modest also the if i write an
email from the n900 Arabic virtual keyboard which i don't know what writing
style is set as default for it and send it to myself in the modest the ARABIC
Language is also perfectly shown!! am i getting close to figure out the problem
here!? don't know really! :-) sooo what i think is that the ARABIC language in
the modest will only shown if certain writing style wither Times New ROMAN or
Verdana or Arial..ect 

i hope i was clear of my findings over here in addition i'll attach some screen
shots of my findings and i wish to tell me how to attach an email from the
modest to over here.
thanx
Comment 6 Andre Klapper maemo.org 2010-01-06 18:08:39 UTC
Easiest way propably is to access the account from another computer that can
easily save an email as a separate textfile.
Comment 7 ginuwine51 (reporter) 2010-01-06 18:11:56 UTC
Created an attachment (id=1941) [details]
Arabic language shown with Verdana writing style
Comment 8 ginuwine51 (reporter) 2010-01-06 18:24:47 UTC
(In reply to comment #7)
> Created an attachment (id=1941) [details] [details]
> Arabic language shown with Verdana writing style
> 

one more thing now it's Confirmed that Times New Roman style doesn't show or
encode in the modest so this is a big proof of different Arabic writing style
coding issue
Comment 9 Andre Klapper maemo.org 2010-01-06 18:28:21 UTC
This will not see any progress without an example message.
That's all to say currently.
Comment 10 salah99 2010-01-15 07:53:11 UTC
Looks like the bugzilla lost some comments. I want to confirm that this
solution has solved part of the problem
(http://talk.maemo.org/showpost.php?p=450244&postcount=7) and the other part
was around the Windows-1256 encoding!!

Please, confirm.
Comment 11 ginuwine51 (reporter) 2010-01-15 10:18:23 UTC
(In reply to comment #10)
> Looks like the bugzilla lost some comments. I want to confirm that this
> solution has solved part of the problem
> (http://talk.maemo.org/showpost.php?p=450244&postcount=7) and the other part
> was around the Windows-1256 encoding!!
> 
> Please, confirm.
> 


yes i confirm both that the more gcogn package solved big part of the problem
as You will see in the attchment above but still the headers on the Inbox not
fixed with more cogn package(attchment) so we r getting somewhere for solving
this bug. and yes i can confirm that many of the previous comments and
attachments disappeared!?
Comment 12 ginuwine51 (reporter) 2010-01-15 10:24:24 UTC
Created an attachment (id=1984) [details]
the Modest Arabic email after installing the more-gconv-modules package from
diablo
Comment 13 ginuwine51 (reporter) 2010-01-15 10:26:56 UTC
Created an attachment (id=1985) [details]
the same above Arabic email in the Modest inbox headers!!
Comment 14 Sergio Villar Senin 2010-01-21 15:03:00 UTC
Ok, so it seems that now the problem is in the headers view window right?
Comment 15 Andre Klapper maemo.org 2010-01-23 22:29:36 UTC
*** Bug 8443 has been marked as a duplicate of this bug. ***
Comment 16 salah99 2010-01-23 22:36:43 UTC
(In reply to comment #14)
> Ok, so it seems that now the problem is in the headers view window right?
> 

Look to this https://bugs.maemo.org/show_bug.cgi?id=8443
"?" in the email content with a different encoding (iso-8859-15)
Comment 17 salah99 2010-01-23 22:38:48 UTC
Created an attachment (id=2110) [details]
Email Content
Comment 18 salah99 2010-01-23 22:39:20 UTC
Created an attachment (id=2111) [details]
iso-8859-15 encoding
Comment 19 Adib 2010-02-14 13:57:56 UTC
it should be update here..
the new version 51-1 ..
also for me the priority..

we have now the solution for the email boddy.. with this package 
http://repository.maemo.org/extras-devel/pool/diablo/free/m/more-gconv-modules/more-gconv-modules_2.5.0-1osso10-2_armel.deb

but we still have the problem in title in the emails list..
Comment 20 Andre Klapper maemo.org 2010-03-12 16:20:08 UTC
Internally fixed in package glibc 2.5.1-1eglibc25.
Waiting for internal verification before I can say more here.
Comment 21 Andre Klapper maemo.org 2010-03-15 14:56:28 UTC
I have verified this in the internal newer version 10.2010.10-10 - arabic
correctly shown both in inbox lists and in single message view.

The next public update will include the fix.

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 22 Andre Klapper maemo.org 2010-03-15 14:57:01 UTC
Created an attachment (id=2472) [details]
Screenshot of the fix