Bug 7694 - (int-152644) FN/Shift Locks get disabled by inserting a symbol with Sym
(int-152644)
: FN/Shift Locks get disabled by inserting a symbol with Sym
Status: RESOLVED FIXED
Product: Desktop platform
Input method framework
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low minor (vote)
: 5.0/(10.2010.19-1)
Assigned To: Joaquim Rocha
: input-method-framework-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-06 05:06 UTC by maemo-bugzilla
Modified: 2010-03-15 20:54 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description maemo-bugzilla (reporter) 2010-01-06 05:06:42 UTC
SOFTWARE VERSION:
1.2009.42-11.002

EXACT STEPS LEADING TO PROBLEM: 
1. Enable FN Lock (pressing 2x FN, blue arrow).
2. Press Sym (Ctrl, HW keyboard) and choose a symbol (virtual keyboard).
3. Press any letter-key on the HW keyboard.

EXPECTED OUTCOME:
FN lock is enabled until you disable it.
eg. you can type 2²+4=2³ (or any other combination of symbols and FN+letter
combination) without repressing FN again.

ACTUAL OUTCOME:
FN Lock is disabled after a symbol(with the virtual keyboard) is inserted.
the same example from above would look like: 2²sr,w (should be 2²+4=2³)

REPRODUCIBILITY:
always

OTHER COMMENTS:
I tested it with xterm and the notes application.

My device has a qwerty keyboard (configured as English, Netherlands in the Text
input settings).

I guess this behavior could be because of symbols like ^, ~ and ", which could
be combined to a letter like â, ã or ä. 
But I think it still shouldn't disable the FN Lock.
Comment 1 Lucas Maneos 2010-01-06 14:58:06 UTC
Thanks for reporting this, confirming also in 2.2009.51-1.  Shift lock is also
reset.
Comment 2 Andre Klapper maemo.org 2010-02-09 19:28:57 UTC
This has been fixed in package
hildon-input-method-framework 1:2.1.47-1+0m5
which is part of the internal build version
10.2010.05-4
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 3 Andre Klapper maemo.org 2010-03-15 20:54:18 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).