Bug 7657 - Using spacebar scrolls more than one screen at a time
: Using spacebar scrolls more than one screen at a time
Status: RESOLVED DUPLICATE of bug 5367
Product: Browser
User interface
: 5.0/(1.2009.42-11)
: All Maemo
: Low normal (vote)
: ---
Assigned To: unassigned
: browser-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-04 23:59 UTC by sc
Modified: 2010-01-05 01:09 UTC (History)
0 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description sc (reporter) 2010-01-04 23:59:10 UTC
SOFTWARE VERSION:
(Settings > General > About product)

1.2009.42-11.002


EXACT STEPS LEADING TO PROBLEM: 
1. Load any website in the Web Browser
2. Using arrow keys or finger to scroll through page, line up an image,
heading, sentence or similar so that is just *below* the section of the page
currently visible on screen. (It does not matter if Web Browser is in
fullscreen or windowed mode.)
3. Press the spacebar to scroll one page down (same as hitting the "Page Down"
key on a desktop computer's keyboard)

EXPECTED OUTCOME:

The image, heading, sentence, or similar marker used should now be at the very
top of the screen area. In other words the "page down" scroll function of the
spacebar should scroll exactly one screen length.

ACTUAL OUTCOME:

The Web Browser will scroll more than a single screen length. Therefore when
using a device such as the n900 to read long articles or forums, it is
necessary to scroll using your finger or the arrow keys, since the "page down"
function of the space bar always requires you scroll back *up* slightly every
time it is used, because it always passed over a couple lines or sentences.


REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)

Always, including both when in fullscreen and windowed browsing mode (when the
title and bookmark bars are visible)

EXTRA SOFTWARE INSTALLED:

This should be a pretty easy fix, just a matter of changing the number of
pixels the "page down" function uses when scroll. Firefox on full desktops
already does this exactly correct.


OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.6)
Gecko/20091216 Fedora/3.5.6-1.fc11 Firefox/3.5.6
Comment 1 timeless 2010-01-05 01:09:37 UTC
please search for bugs before filing.

*** This bug has been marked as a duplicate of bug 5367 ***