Bug 7636 - battery level not showing 100% when full.
: battery level not showing 100% when full.
Status: RESOLVED INVALID
Product: System software
HAL
: 5.0/(1.2009.42-11)
: All Maemo
: Low normal with 5 votes (vote)
: ---
Assigned To: unassigned
: hal-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-04 15:53 UTC by krk969
Modified: 2010-02-09 10:08 UTC (History)
9 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description krk969 (reporter) 2010-01-04 15:53:32 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. charge the Nokia N900 until the green led flashes to indicate battery is
full
2. check the output of the lshal | grep percentage
3. 

EXPECTED OUTCOME:
shows (atleast most of the times, in my case all the time) < 100%
ACTUAL OUTCOME: 100%

I even created a desktop widget based on QT api's , not sure if this is also
reading from the HAL, but my guess is it is, the ouput of the lshal command
always matches the widget and this always show me about 95% when full, Ive even
seen 76% once, but most of the time full between 90-95%

I did a search here, didnt find any bug close to this one, feel free to
duplicate if it is.

thanks. 

REPRODUCIBILITY:
atleast most of the times, in my case all the time.
There are several threads discussing this in the maemo forum but didnt think it
would be appropriate putting those references here. Ive got a few of those
threads, and I can post it in the comments if needed.

EXTRA SOFTWARE INSTALLED:
batlevel-1.0-3 ( extras-devel - just to double confirm the lshal output )

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.6)
Gecko/20091201 Firefox/3.5.6 (.NET CLR 3.5.30729)
Comment 1 Andre Klapper maemo.org 2010-01-04 16:43:11 UTC
~ $ lshal | grep percentage
  battery.charge_level.percentage = 77  (-x4d)  (int)

Is the charger still plugged in when doing this, or not?
Comment 2 krk969 (reporter) 2010-01-04 16:47:19 UTC
(In reply to comment #1)
> ~ $ lshal | grep percentage
>   battery.charge_level.percentage = 77  (-x4d)  (int)
> 
> Is the charger still plugged in when doing this, or not?
> 

Ive tried both cases.
That didnt change anything.
Comment 3 Aaron 2010-01-04 17:01:18 UTC
Device has never shown 100% charge when using lshal|grep percen 

Maximum shown is 96-97%
Comment 4 krk969 (reporter) 2010-01-04 17:24:53 UTC
(In reply to comment #3)
> Device has never shown 100% charge when using lshal|grep percen 
> 
> Maximum shown is 96-97%
> 

are you agreeing with the bug or are you suggesting that what lshal shows is
acceptable when battery is full , if so could you please state the reason ?

didnt see your vote for the bug hence the question :-)
Comment 5 krk969 (reporter) 2010-01-04 17:25:38 UTC
*** This bug has been confirmed by popular vote. ***
Comment 6 les_garten 2010-01-04 17:37:10 UTC
Indeed, mine never shows more than 97%.  No matter how long on the charger, or
what type of charger, or off the charger.
Comment 7 Jan Knutar 2010-01-04 17:38:28 UTC
As these battery details haven't received much attention before, I'll add my
observations of the behaviour of N8x0  devices running Diablo.. I haven't poked
and probed N900, but on the surface it seems similar (why change it if it
works,I guess).

None of the devices can run direct on power through charging port. The battery
is always connected to the device. When the battery is full, N8x0 switches off
power from the charger and runs on battery. It's not able to measure and
regulate power from charger fast and precise enough to run from charger power,
and doing so with the battery connected as it is, would cause much wear&tear on
it. When battery level has dropped, the charger is re-connected for a top-up,
and disconnected again. Once battery-full state has been reached once, the
"battery full" light is pretty much always kept on as long as charger is
connected.

This results in the actual charge level fluctuating. Another side-effect on
N8x0 is that the battery wont even get to 90% full if there's high power drain
by the device.

So, the sofware might actually be telling the truth when it says the battery is
at 96% :)
Comment 8 Jan Knutar 2010-01-04 17:45:08 UTC
Oh let me also add that on n8x0 the initial charge cutoff happens at 4200mV,
but when it stays on charger the subsequent top-up charges seem to aim for
4100mV, which wouldn't necessarily make the battery 100% full. At first when I
started looking at it, I assumed Nokia just used 4100 as their full point to
prolong battery lifetime (as in, number of months before it has to be
replaced).
Comment 9 Andre Klapper maemo.org 2010-01-04 17:52:48 UTC
I always get "76" here on my three months old N900.
On my second, brand new N900 (charged exactly once) I get "87".
Comment 10 krk969 (reporter) 2010-01-04 18:12:41 UTC
Oh Ive noticed this as well a couple of times.
Dont know if relevant for this bug, if so pls ignore.

ive seen lshal output 0 many times.
its reporting 0 right now, my phone is connected via my cable and charging.

I dont think its OK to report 0 ever, that would mean my phone should be off
:-).

this makes me think there is some issue while probing using the hal.

has anybody else noticed this as well ?
Comment 11 krk969 (reporter) 2010-01-04 18:19:27 UTC
(In reply to comment #10)
> Oh Ive noticed this as well a couple of times.
> Dont know if relevant for this bug, if so pls ignore.
> 
> ive seen lshal output 0 many times.
> its reporting 0 right now, my phone is connected via my cable and charging.
> 
> I dont think its OK to report 0 ever, that would mean my phone should be off
> :-).
> 
> this makes me think there is some issue while probing using the hal.
> 
> has anybody else noticed this as well ?
> 
adding more info to the above observation

checked the lshal ouput again while it was charging, reported 0.
just ran my widget , it reported 5%
i checked the lshal output immed and it showed 5%.
maybe starting the widget triggered the hal to be probed again ?
Comment 12 Jan Knutar 2010-01-04 18:28:29 UTC
The value is not updated while charging.
On N8x0 it was hardly ever updated unless you tapped the battery icon.
Presumably N900 occasionally updates it if battery stattus icon is visible.
I've noticed on N900 when charging and taking it off charger before full, the
reported value climbed slightly for a few minutes after.

The 77% value is interesting. N8x0 always assumed that full battery = 1500mAh
(or however big the battery reported itself as). This is fine for when your
battery came off the assembly line last week, but when you've got a 2 year old
battery that now only holds 900mAh, the battery meter assuming 90+% of 1500
makes it a tad inaccurate. I hope the 77% means it now actually tries to keep
track of the current actual max capacity of the battery as well.

It would probably be trivial to add a if(charge_level > 90) return 100; type
thing to hald-addon-bme, but personally I would much rather have "unfiltered"
data from bme & hald-addon-bme, and let applets/applications do filtering
instead.
Comment 13 Flandry 2010-01-04 19:18:31 UTC
(In reply to comment #12)
> thing to hald-addon-bme, but personally I would much rather have "unfiltered"
> data from bme & hald-addon-bme, and let applets/applications do filtering
> instead.

I would, as well. If the battery.charge_level.percentage value reflects some
absolute voltage or A-hrs value then it should be left alone, as knowing the
actual value of the battery voltage is useful (e.g. for measuring decreased
capacity over time). If, on the other hand, charge_level.percentage is some
normalized value based on arbitrary presets then it makes sense to re-normalize
it to reach 100 on each particular device.

My N900 shows 96-98 on most recharges, but was at only 94% one time.
Comment 14 Jukka N. 2010-01-04 21:38:14 UTC
This is not a bug. It is a feature that displays the battery capacity compared
to design capacity. As such, as 2 years old battery might never reach above 60
%. But the percentage meter interpreting never changes. Thus, a new battery at
60 % will last as long as 2 years old battery at 60 %.

This can be clearly seen from taking the full information of battery and
calculating from there.
~ $ lshal|grep bat   [many lines removed from output]
  battery.charge_level.percentage = 95  (0xc)  (int)
  battery.reporting.current = 1189  (0xa0)  (int)
  battery.reporting.design = 1248  (0x4e0)  (int)
  battery.reporting.last_full = 1189  (0x0)  (int)

These lines show the last full charge to be 1189 (mAh -unit seen from removed
lines) while design charge (varies from battery to battery. Probably taken as
highest value reached with given battery) is used in percentage calculation.
1189/1248 = 95.3 % -> 95 %. Percentage value shown there is always rounded
down.

See more information about how to get detailed battery information and what the
values mean at http://talk.maemo.org/showthread.php?t=36613


Given the way the feature works, there is no bug to be fixed. The only question
is should the battery meter re-calibrate itself to last charge value instead of
using design charge value. In my opinion current way is better as it actively
shows the user the condition of the battery and allows users to better feel how
long the battery lasts with given percentage of charge left.
Comment 15 krk969 (reporter) 2010-01-04 22:06:06 UTC
(In reply to comment #14)
> This is not a bug. It is a feature that displays the battery capacity compared
> to design capacity. As such, as 2 years old battery might never reach above 60
> %. But the percentage meter interpreting never changes. Thus, a new battery at
> 60 % will last as long as 2 years old battery at 60 %.
> 
> This can be clearly seen from taking the full information of battery and
> calculating from there.
> ~ $ lshal|grep bat   [many lines removed from output]
>   battery.charge_level.percentage = 95  (0xc)  (int)
>   battery.reporting.current = 1189  (0xa0)  (int)
>   battery.reporting.design = 1248  (0x4e0)  (int)
>   battery.reporting.last_full = 1189  (0x0)  (int)
> 
> These lines show the last full charge to be 1189 (mAh -unit seen from removed
> lines) while design charge (varies from battery to battery. Probably taken as
> highest value reached with given battery) is used in percentage calculation.
> 1189/1248 = 95.3 % -> 95 %. Percentage value shown there is always rounded
> down.
> 
> See more information about how to get detailed battery information and what the
> values mean at http://talk.maemo.org/showthread.php?t=36613
> 
> 
> Given the way the feature works, there is no bug to be fixed. The only question
> is should the battery meter re-calibrate itself to last charge value instead of
> using design charge value. In my opinion current way is better as it actively
> shows the user the condition of the battery and allows users to better feel how
> long the battery lasts with given percentage of charge left.
> 


How can anybody rule out the possibility of a bug reading the capacity wrongly
here.
I find it difficult to accept the fact that my battery has degraded 5% already
so quickly , at this rate after a year I may need to charge my phone 4 times a
day.
and how do you then explain the 76% and other values that people including me
have seen ( keep in mind that these are not very old phones atleast not mine ).
clearly to me there is also some software issue here apart from the battery
degrading if it exists.

cheers
Comment 16 Jukka N. 2010-01-04 22:53:04 UTC
(In reply to comment #15)
> How can anybody rule out the possibility of a bug reading the capacity wrongly
> here.
> I find it difficult to accept the fact that my battery has degraded 5% already
> so quickly , at this rate after a year I may need to charge my phone 4 times a
> day.
> and how do you then explain the 76% and other values that people including me
> have seen ( keep in mind that these are not very old phones atleast not mine ).
> clearly to me there is also some software issue here apart from the battery
> degrading if it exists.
> 
> cheers
> 

1) Even on all new phone the battery is at least a couple of months old.

2) Due to the way Lithium-ion batteries work, the varying conditions during the
charging and during the usage cause variations to the capacity the battery is
able to give away.

3) The measurements of the battery capacity are indirect, done through voltage
and current measurements. The inaccuracy of the measurements causes
inaccuracies in the computed quantity.


Summing these all together the seen fully charged battery capacity varies
between every charge (on N900 I have noticed that at least 5 % variations are
very typical between 2 sequential charging cycles) and as the battery has lost
a couple percent or so of the initial charge capacity during the couple months
since manufacture, it is very normal to see figures such as 90-95 % on a new
phone. And most people are reporting figures in such levels.

As for the 76 % figure, that is clearly not normal. May be due to battery
problems, very rapid discharge causing low effective capacity for that charge,
bug etc. In any case I have not seen anyone else than krk969 in this bug post
reporting significantly low full charge conditions. Thus, it can be safely
taken out of the scope of this bug report. In case more people are experiencing
such problems, another bug report may be filed for that.


More complex answers...
1) It is a known fact that Lithium-ion batteries degrade from time as well as
from usage. As such, the battery you get on a new phone has already degraded
somewhat from the time it was manufactured typically at least a couple months
earlier. More information: http://www.batteryuniversity.com/partone-19.htm

2) Lots of things, such as temperature, current amount and pattern, battery age
and any mistreatment the battery has received matter on the effective capacity
of the battery. Many of these things vary a lot during the use. For example
drawing a significant current from a battery for prolonged time will
significantly lower the capacity of that charge. These factors are somewhat
known, but they have various unknowns in them that makes it hard to accurately
measure the capacity. That is why fully charged capacity is only re-measured in
a deep-cycle. That is going from fully charged into (almost) empty charge in
one go. The charge capacity is not measured from the charging cycle as there
are even more uncertainties causing some of the charging to go wasted etc.

3) Considering mobile phone and the battery are very small. The electronics
being used in the intelligent battery controller both for safety and for
information have to be very small and may not use much of the battery capacity.
As such the inaccuracies in measuring the voltage and current are much higher
than those of larger devices. For example a laptop battery can be a lot more
accurate in capacity measurement.
Comment 17 peacock73 2010-01-04 22:56:45 UTC
Additionally - my level will show anywhere between 89% when "fully charged" and
97%. Does my battery randomly degrade then recover then degrade?
Comment 18 Flandry 2010-01-04 23:26:02 UTC
(In reply to comment #17)
> Additionally - my level will show anywhere between 89% when "fully charged" and
> 97%. Does my battery randomly degrade then recover then degrade?
> 

He already answered that. The temperature, discharge/charge rate, and other
factors all influence how much you can charge a battery. Beyond that, as he
pointed out, this is a small device and small battery and precision is limited
as well.

Thanks Jukka, it is as i suspected and there is no bug here. This is good news
to me that the N900 has some idea of its present battery capacity compared to
the maximum it has seen.
Comment 19 Flandry 2010-01-04 23:28:54 UTC
(In reply to comment #18)
> He already answered that. The temperature, discharge/charge rate, and other
> factors all influence how much you can charge a battery. Beyond that, as he
> pointed out, this is a small device and small battery and precision is limited
> as well.

Oops i forgot to also point out that the battery does not charge continuously
when plugged in. It charges to "full" and then switches off, even though the
green light stays on. When the battery has been discharged again below some
min. level, it starts the charge cycle again. This is due to the N900 not being
able to run off of AC directly--it runs off the battery at all times.
Comment 20 Andre Klapper maemo.org 2010-01-04 23:38:19 UTC
So as explained by Jukka this is not a bug, hence closing.
If you want changes to the current behaviour, feel free to file a new report
with severity = enhancement.
Comment 21 krk969 (reporter) 2010-01-05 14:16:30 UTC
dear jukka, thanks for the effort to give us detailed answers for the
behaviour.
with no disregard to the facts that you have stated

how is it other mobile OS's report the battery fine, its quite improbable to
think they extrapolate the values in the application level.

Is this acceptable ( at hardware level ) for batteries to degrade so quickly, I
mean I havent seen other phones being so unstable with respect to the battery
capacity. Im talking about fairly new phones here. 
If what you say is true abt the battery behaviour maybe Nokia should be made
aware of that no ?
Or are you saying this erratic behaviour is acceptable ?

About the battery reporting 75% even in this bug thread Andre Klapper reports
he has seen it, I just seconded that and Ive seen some more having reported
this in the talk forum.
Im not trying to prolong this with no cause, Im just trying to ensure that the
fault is corrected be it in the battery or the software that measures the
capacity.

sorry for this but it just hasnt got me convinced as a feature request this bug
:-) or maybe its just me .

Andre/Jukka feel free to close it again if Im talking gibberish.

Regards
krk969
Comment 22 peacock73 2010-01-05 16:33:06 UTC
Have to say I am not buying the environmental variance etc for the battery
charge discrepancy. I am in a climate controlled environment at a permanent 72
degrees. My battery full charge % ranges wildly.
On top of that is the issue where my battery can be reporting 50%+ charge, I
reboot and suddenly its 10% or less charge. Don't tell me thats due to
variances in the temp.
Comment 23 Ndi 2010-01-05 23:43:15 UTC
Peacock:

All my phones do that (Nokia), the phones are quite optimistic in battery
estimation, since  at ~75% then N900 shows a full battery in the display (from
7 bars plus zero to 4?).

However, I'd like to note that my N900, uncharacteristically, does NOT do that
(yet). 78% battery is around 75+ after reboot, something my N80 never did.
Rebooting my older phones showed 3-4 bars (as should) but left alone they stick
to 7 bars for 80% of the day.

Also, it doesn't vary the charge level. Charging the phone from USB/PC always
yields 96% charge, regardless of previous charge level.

If it's the battery, we have different kinds.

Did anyone use a pro multimeter on the battery to check on the phone's idea of
voltage? I have one at work, if it helps I can use a pro model that measures
accurately into the millivolt range. (Un)fortunately (?), mine works so I
expect actual figures.

I'm thinking this should settle the battery versus phone dispute?
Comment 24 peacock73 2010-01-05 23:46:55 UTC
Just so happens I just bought a pro-multimeter last weekend. Let me drop my
battery on it tonight and see what we shall see.
Comment 25 Ndi 2010-01-06 19:22:56 UTC
Results are in.

In N900, go to terminal and type
lshal | grep battery
we get:

STEP 1: 3817 mV

then power down N900, remove battery, use expensive multimeter, we get:

STEP 2: 3824 mV

then replug the battery, boot it, wait a little for the CPU to settle to a few
percent, then repeat step 1:

STEP 3: 3794 mV

Allow me to do the math:
Step 2-1: N900 minus multimeter: 7 mV. It's as precise as it gets, considering
that in the device, the battery is under load, (light as it might be). At the
very least, it's running terminal, lshal and backlight.

Strep 3-1: N900 minus N900, after a bootup. 23 mV. Knowing the device booted
up, it's likely to be drained a little, I expected it to be less than before.
By how much I can't say but bootuo isn't exactly light. Also, since it was
close to boot, it probably still ran media daemons and stuff. Also, if I wait
too long to settle, battery drains anyway.

Overall, I'd say that the device is ultraprecise. I'm thinking (i know it's non
linear, but bare with me) 4.2 minus some 3.2 cutoff that's about a volt so 10
mV is about one percent, I expect N900 to be able to guess battery level within
a percent for most of the battery's charge span.
Comment 26 Jukka N. 2010-01-06 19:41:57 UTC
The environment aspect isn't only about air temperature. It is about battery
temperature. And also the charging speed (wall charger 5V/1.2A compared to
PC/USB 5V/0.5A), draining speed and variance etc matter.

For example, if you play 3D game with the phone for 2 hours, the whole phone,
including the battery, is at around 50 C and drains the battery power quite
fast. It will get a lot different capacity result than relatively passive web
browsing, talking etc.

Heavy continuous battery usage matters a lot more than repeated cycles of low
and heavy battery usage. Also continuous heavy battery usage also makes the
phone a lot warmer that makes a dual effect from the battery temperature.

And even on laptops, the battery full charge capacity can vary few percent
between two consecutive charge cycles. Most devices just show the percentage
from current max charge capacity instead of design capacity. They also assume
the charge is at 100 % each time the charge level is toggled as full. In some
cases this can cause major changes in battery percentage. Eg. if the battery
reaches fully charged state when the laptop things it is at 90 %, it will jump
to 100 % from 90 %. Rare, but it happens even on laptops.

Considering that N900 shows the user the true information instead of trying to
hide it, it might even be better at measuring the capacity than other mobile
phones are. And by no means are the normal figures (90-95 % for example as new
phone battery) anything special. They are just what is to be expected. In fact,
even more variance would be expected from the huge size differences of laptops
to mobile phones.

As for the low full charge capacity of say 75 % on new phone battery, that is
definitely out of normal. And if it happens often, there is very likely a bug
somewhere. But it is not part of this bug report. File another bug report about
that issue instead. 

As for low charge speed from PC/USB charging, it may be there has been
advancement in the battery capacity measurements and N900 is actually measuring
the charge level from actual charging instead of the previous draining. In such
case, the result from slow charge might give much more accurate and stable
capacity amount. Especially if your usage on the phone is very similar on every
cycle.

As for battery degrading so fast... No, it is not about degrading, it is about
varying capacity mostly. If a new phone is giving full charge capacities
between say 91 % and 97% during a test of 20 full charge cycles, the battery
degrading is 3 % of the original. That is due to the battery being at least a
couple months old on all new phone as well as from the few usage cycles there
have been. The battery is only able to deliver the maximum capacity in ideal
conditions. Design capacity is measured in ideal conditions. Even all new
battery straight from manufacturing will show different capacity at laboratory
between different cycles, assuming there has been 'real life tests' instead of
constant usage and charge patterns on each cycle. The battery on N900 phone
does not appear to be worse than the batteries on laptops or other mobile
phones are based on the varying fully charged capacity or not getting design
capacity on new phone. (Do note, some high-end business laptop manufacturers do
actually set realistic end-user new battery capacity as design capacity instead
of the way Nokia does. As such, the design capacity has different meanings on
different places. As for Nokia concerned on N900 batteries, the end user will
not get the marketing 1320 mAh or battery showing design capacity with new
battery. But instead about 95 % (error margin +-3) of the marketed and about 98
% (error margin +-1.5) of the battery shown design capacity. These figures have
quite high error margin due to me not having bunch of batteries to test with to
get a good statistical sample.

In any case, there is nothing whatsoever pointing into anything strange going
on in the values most people are experiencing (90 % or higher at fully charged
on new phone, varying around 5 % between 2 charges). As such the cope of this
bug report is not a bug. It is a feature of the phone calculating maximum
percentage from the design capacity instead of the last max charge capacity.
This is in my opinion better way to do it. Gives the user a constant battery
charge level showing. Eg. a new phone at 60 % charge will last just as much as
2 years old battery with max charge of 60 %.


Therefore, this bug is closed and does not change from that. File a new
'enhancement' severity bug report if you want to change the way battery
percentage is shown. If you experience abnormal behavior (eg. something
significantly other than this feature normally gives), file a bug report
concerning that case.
Comment 27 Ndi 2010-01-06 19:55:24 UTC
While it's all true, I think it depends on what an affected user reports with a
multimeter. 

If voltage is different with a multimeter, or if the voltage varies wildly in
the phone with a reboot but does not on a multimeter, doesn't that constitute a
bug in the HAL? (assuming it's not hardware). 

I suggested the multimeter test to determine if it's the battery itself that
has a lower voltage or it's just reported as such. If multimeter supports
N900's assessment of the voltage then it's the battery and case closed.
Comment 28 krk969 (reporter) 2010-01-06 22:29:58 UTC
(In reply to comment #27)
> While it's all true, I think it depends on what an affected user reports with a
> multimeter. 
> 
> If voltage is different with a multimeter, or if the voltage varies wildly in
> the phone with a reboot but does not on a multimeter, doesn't that constitute a
> bug in the HAL? (assuming it's not hardware). 
> 
> I suggested the multimeter test to determine if it's the battery itself that
> has a lower voltage or it's just reported as such. If multimeter supports
> N900's assessment of the voltage then it's the battery and case closed.
> 

yes I agree with the comment here from Ndi.
But if its the battery what is the right forum to let Nokia know about this ?

The advertised 1320maH is either 
1. a value that needs to be taken with some threshold of variance( highly
unlikely the conclusion if the variance is high ) . This can be fixed in an
application. OR 
2. its a defect with the battery and maybe this software bug report can be
closed.
Comment 29 Jukka N. 2010-01-07 00:51:11 UTC
The battery voltage will drop depending on current drain depending on the
charge level. A battery at low charge level will get very significant voltage
drop from heavy usage.

The figures posted from phone itself and multimeter are just what is expected.
The phone at more or less idle still uses some amount of power, thus the
voltage is slightly lower than that of battery when not in use. Thus the slight
rise from measurement 1 into measurement 2. And as for starting up the phone.
It is a very battery intensive operation. Starting the phone uses about 3 % of
whole battery charge without having additional widgets etc stuff slowing down
the start. It will make a significant drop in the voltage for some time. And
even if waiting for the voltage to get back to normal, the charge level has
dropped a bit and thus the voltage is still somewhat lower. As such the
measurement 3 is in line as well.

The actual battery capacity varies with each battery from same manufacture
line. As such, there is no single design capacity in reality. The marketing
figure 1320 mAh is probably taken as 'highest capacity a battery may have'.
That is, most batteries are less than it. Based on various experience of the
design capacities the phone shows for different batteries, they are typically
in order of 1240-1280 mAh. That is 94-97 % of the marketed value. Not that much
less, but it is somewhat less. That is no reason for bug report. Yes, it is
slightly overrating the battery capacity on the Nokia, but not a bug.


As for the battery charge percentage when full. It is the latest measurement of
battery capacity divided by battery design capacity (which is battery specific
value set for the battery on testing after manufacture - not 1320 mAh). That is
a feature, not a bug. It also shows the battery wear level. If your battery is
95 % when fully charged in ideal conditions (eg. optimal temperature of perhaps
20 degrees celcius constant - phone not precent to heat and using very slow
speed of charging and discharging), the battery wear level is 5 %.

In real life conditions, the battery will never reach the ideal fully charged
capacity, but is likely to show perhaps 88-93 % varying on each charge. So, the
real wear level is slightly lower than what is shown. But the difference
between wear level and shown level stays about same. Thus, as a battery that
would charge to 60 % of design capacity in ideal conditions, the real life case
would show perhaps 53-58 %. Thus it is a good measure of the battery wear
level. And also a new phone at 60 % battery charge level will last as long as
an old battery that has fully charged capacity at 60 %.


Therefore, this is a feature and not a bug. All things people have reported
here have been clearly answered or are not in the scope of the bug report. As
such, do not post here unless you have something NEW regarding this exact bug
report. Post new bug reports for other bugs regarding battery.

This is not a forum, so this is not the place to excessively discuss about the
matter. Make a topic on the forum if you have further discussing about it.


This bug is closed - not a bug but a feature!
Comment 30 krk969 (reporter) 2010-01-07 01:19:18 UTC
(In reply to comment #29)
> The battery voltage will drop depending on current drain depending on the
> charge level. A battery at low charge level will get very significant voltage
> drop from heavy usage.
> 
> The figures posted from phone itself and multimeter are just what is expected.
> The phone at more or less idle still uses some amount of power, thus the
> voltage is slightly lower than that of battery when not in use. Thus the slight
> rise from measurement 1 into measurement 2. And as for starting up the phone.
> It is a very battery intensive operation. Starting the phone uses about 3 % of
> whole battery charge without having additional widgets etc stuff slowing down
> the start. It will make a significant drop in the voltage for some time. And
> even if waiting for the voltage to get back to normal, the charge level has
> dropped a bit and thus the voltage is still somewhat lower. As such the
> measurement 3 is in line as well.
> 
> The actual battery capacity varies with each battery from same manufacture
> line. As such, there is no single design capacity in reality. The marketing
> figure 1320 mAh is probably taken as 'highest capacity a battery may have'.
> That is, most batteries are less than it. Based on various experience of the
> design capacities the phone shows for different batteries, they are typically
> in order of 1240-1280 mAh. That is 94-97 % of the marketed value. Not that much
> less, but it is somewhat less. That is no reason for bug report. Yes, it is
> slightly overrating the battery capacity on the Nokia, but not a bug.
> 
> 
> As for the battery charge percentage when full. It is the latest measurement of
> battery capacity divided by battery design capacity (which is battery specific
> value set for the battery on testing after manufacture - not 1320 mAh). That is
> a feature, not a bug. It also shows the battery wear level. If your battery is
> 95 % when fully charged in ideal conditions (eg. optimal temperature of perhaps
> 20 degrees celcius constant - phone not precent to heat and using very slow
> speed of charging and discharging), the battery wear level is 5 %.
> 
> In real life conditions, the battery will never reach the ideal fully charged
> capacity, but is likely to show perhaps 88-93 % varying on each charge. So, the
> real wear level is slightly lower than what is shown. But the difference
> between wear level and shown level stays about same. Thus, as a battery that
> would charge to 60 % of design capacity in ideal conditions, the real life case
> would show perhaps 53-58 %. Thus it is a good measure of the battery wear
> level. And also a new phone at 60 % battery charge level will last as long as
> an old battery that has fully charged capacity at 60 %.
> 
> 
> Therefore, this is a feature and not a bug. All things people have reported
> here have been clearly answered or are not in the scope of the bug report. As
> such, do not post here unless you have something NEW regarding this exact bug
> report. Post new bug reports for other bugs regarding battery.
> 
> This is not a forum, so this is not the place to excessively discuss about the
> matter. Make a topic on the forum if you have further discussing about it.
> 
> 
> This bug is closed - not a bug but a feature!
> 

no further comments now. OK to close unless anybody else has a different
perspective.

thanks Jukka. However I must say that I had an android device earlier that
reported 100% battery charge, will dig in the code to see how it works and
re-open this if found neccessary.
what you have said here must hold good for all batteries including my android
that showed 100%.
maybe that was extrapolated in some way at app level( like in our case ratio of
"current" and "last full" might be close to 100%)to show 100% but will be good
to know.
Comment 31 Ndi 2010-01-07 01:51:35 UTC
Jukka:
"The figures posted from phone itself and multimeter are just what is
expected."

That's because my phone doesn't exhibit the bug, my post was a control. We're
waiting from peacock (who has the issue) to report his multimeter findings,
thus separating a battery drop from the ADC in the phone circuit and software.

Though I'm not really familiar with this bug system - if the OP has nothing to
add, is this closed? IMO this *could* still be a bug if peacock has a full
battery with phone showing 4000 mA and multimeter reporting 4200, e.g., though
it makes equal sense to me of it's closed and reopened if needed be.
Comment 32 Ryan Abel maemo.org 2010-01-07 04:19:19 UTC
(In reply to comment #21)
> sorry for this but it just hasnt got me convinced as a feature request this bug
> :-) or maybe its just me .
> 
> Andre/Jukka feel free to close it again if Im talking gibberish.
> 

Please try to reach a consensus before reopening a bug after previous consensus
was reached.

RESOLVING again. . . .
Comment 33 taril 2010-01-16 18:04:01 UTC
This problem is existed in the 2.2009.51-1 version too!

1. Fully recharged my N900: 92%
2. Replugged the charger, it finished recharging in 10 minutes: 95%
3. Replugged the charger, it finished recharging in 10 minutes: 95%
4- Replugged the charger, it finished recharging in 10 minutes: 91%

The system is never reached the 100% battery level after recharging.
Comment 34 Andre Klapper maemo.org 2010-01-20 16:01:26 UTC
*** Bug 8293 has been marked as a duplicate of this bug. ***
Comment 35 Andre Klapper maemo.org 2010-02-03 14:14:46 UTC
Jukka, is bug 8163 a duplicate of this report, or a different, valid issue?