Bug 7627 - Device does not always start charging when I connect it with USB cable to the computer
: Device does not always start charging when I connect it with USB cable to the...
Status: RESOLVED DUPLICATE of bug 6004
Product: Core
general
: 5.0/(1.2009.42-11)
: N900 Maemo
: Low normal with 1 vote (vote)
: ---
Assigned To: unassigned
: core-general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-04 11:02 UTC by Janne Pänkälä
Modified: 2010-01-20 20:06 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Janne Pänkälä (reporter) 2010-01-04 11:02:21 UTC
SOFTWARE VERSION:
1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 

1. I connect device to USB.
2. Charging does not start.


EXPECTED OUTCOME:

Charging would commence immediately after connection is made. 

ACTUAL OUTCOME:

Me checking cable from both ends and trying to figure out what is wrong.

REPRODUCIBILITY:
less than 1/10

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

This is not always reproducible.

Charging works everytime if screen is on or only little time has passed since
device was used last time.

If charging does not start I activate the device, remove cable and insert it
back again and charging starts everytime then.

Possibly power management issue?

I try to gather more knowledge as how to reproduce this.

I have not noticed such problems with AC outlet charger.
Comment 1 Janne Pänkälä (reporter) 2010-01-04 15:31:48 UTC
1) I had device loading trough USB yellow light blinking.
2) I removed the usb cable and checked the device and did not turn of the
screen from the righthand side button.
3) waited 1h 14mins 5[0-7] secs after screen went blank by itself.
4) Connected the USB. 
5) nothing happened.
6) removed the cable.
7) connected the USB cable
8) nothing happened.
9) removed the cable.
10) connected the USB cable
11) nothing happened.
12) removed the cable.
13) connected the USB cable
14) device started charging. (yellow light blinks)

On some occasions it starts to charge on first "disconnect reconnect" cycle.

This is kind of annoying since when I did not notice this behavior the device
ran our of battery. Now I always check the yellow blinking light when I wish to
charge the device.
Comment 2 Andre Klapper maemo.org 2010-01-04 16:53:27 UTC
I didn't totally get it - the device is off?
Note that there are bug 6470 and bug 7521 which might be related.
Comment 3 Janne Pänkälä (reporter) 2010-01-05 13:20:05 UTC
No the device is on all the time.
Comment 4 Janne Pänkälä (reporter) 2010-01-05 13:32:26 UTC
Similar, but not quite same as bug 7521. I tried to search for similar bug, but
did not find one.

I have had experience with device running out of battery and then unable to
power it on even when it is on charger. (Taking battery off and putting it back
on helps)

Just arrived to the office and 1st connect to USB did not start charging, but
second time it started. (yellow light started blinking)
Comment 5 Janne Pänkälä (reporter) 2010-01-05 13:35:24 UTC
Just as a thought. Is there a way to enable the led to inform device state more
accurately?

yellow blink, yellow, green, green blink (other colors?)

short blink short blink long blink. etc

Might help in creating accurate repro steps.
Comment 6 Janne Pänkälä (reporter) 2010-01-05 13:45:10 UTC
Settings that might be related are.

  Asetukset (Settings?)
    Näyttö  (Display/Screen?)
      30 seconds
      lock screen automatically  (yes)
      screen is on while loading (yes)
      touch screen vibration     (yes)
      powersave state            (yes)
Comment 7 Don Harder 2010-01-07 07:14:37 UTC
I have had this problem consistently when connecting to two different MacBook
Pro laptops. Once I disconnect it from the computer and reconnect, it allows me
to connect and to charge. But always on the second try. This happens when the
screen is on or off and the device is on.
Comment 8 Venomrush 2010-01-12 11:05:46 UTC
*** This bug has been confirmed by popular vote. ***
Comment 9 Venomrush 2010-01-12 11:56:08 UTC
Similar issue to bug 6004?
Comment 10 Janne Pänkälä (reporter) 2010-01-14 09:40:39 UTC
Venomrush: yes looks similar. I'll try to gather same information from my
device.
Comment 11 Janne Pänkälä (reporter) 2010-01-14 13:28:57 UTC
dmesg

[49751.794219] slide (GPIO 71) is now open
[49833.489685] kb_lock (GPIO 113) is now closed
[49833.770751] kb_lock (GPIO 113) is now open
[49835.364624] kb_lock (GPIO 113) is now closed
[49835.536437] kb_lock (GPIO 113) is now open
[49838.598907] kb_lock (GPIO 113) is now closed
[49838.833312] kb_lock (GPIO 113) is now open
[49839.614624] slide (GPIO 71) is now closed
[49873.786437] musb_hdrc periph: enabled ep1in for bulk IN, maxpacket 512
[49873.786468] musb_hdrc periph: enabled ep1out for bulk OUT, maxpacket 512
[49873.786529] g_file_storage gadget: high speed config #1

cat mode charger
b_idle
0


So yes this would look like a duplicate of bug report 6004
Comment 12 Janne Pänkälä (reporter) 2010-01-14 13:29:12 UTC

*** This bug has been marked as a duplicate of bug 6004 ***
Comment 13 Janne Pänkälä (reporter) 2010-01-20 20:06:49 UTC
I have been unable to reproduce this with 2.2009.51-1 so I assume it is fixed.