Bug 761 - (int-208098) PDF reader: Add support for 'fit visible' option
(int-208098)
: PDF reader: Add support for 'fit visible' option
Status: RESOLVED WONTFIX
Product: UI Specification
General
: 5.0:(20.2010.36-2)
: All All
: Low enhancement with 38 votes (vote)
: ---
Assigned To: Mikko Nurmi
: ui-specification-bugs
: http://arm.com/pdfs/DVI0035B_926_PO.pdf
: enhancement-it2006, ITOS2007HE-garage
:
:
  Show dependency tree
 
Reported: 2006-09-15 17:22 UTC by Siarhei Siamashka
Modified: 2011-11-15 12:24 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Siarhei Siamashka (reporter) 2006-09-15 17:22:14 UTC
When using PDF viewer with 'fit width' option, a lot of horizontal screen space
is often wasted by just white blank margins at left and right. PC version of
Adobe Acrobat Reader has 'fit visible' option that allows to use horizontal
screen space more efficiently and crop this unused blank space. Implementing
something like this can greately improve PDF Reader usability in my opinion.

Let's take the following PDF as an example: http://arm.com/pdfs/DVI0035B_926_PO.pdf
In 'fit width' mode font is quite small. After increasing zoom level we get much
more readable text and visually it seems to be be able to (almost) fit screen
horizontally. Probably we could get something looking like this but without a
horizontal scroller if 'fit visible' mode was implemented.
Comment 1 Maemo QA (deprecated) 2006-09-15 18:05:06 UTC
Thanks for your comments, marking this as an enhancement request.
Comment 3 Anders Rune Jensen 2008-04-29 20:34:04 UTC
I would really like this one as well. The problem is that if you're reading a
book where the text is centered, for every single page you have to manually fix
up the zoom selection, because it starts in the top left corner instead of in
the middle, where you where on the previous page.
Comment 4 Anders Rune Jensen 2008-04-29 20:38:48 UTC
What I described in the last comment is bug #2703.
Comment 5 Andre Klapper maemo.org 2008-11-17 00:33:31 UTC
I don't understand the issue here - you can either use "Fit width" or "Fit
page". The link does not work anymore.
Was this about landscape PDF files?

> 'fit width' option, a lot of horizontal screen space
> is often wasted by just white blank margins at left and right.

I've never seen this. "Fit width" just means to use the COMPLETE horizontal
screen space, doesn't it?

Can someone please explain this to me? :)
Comment 6 Siarhei Siamashka (reporter) 2008-11-17 01:02:47 UTC
(In reply to comment #5)
> I don't understand the issue here - you can either use "Fit width" or "Fit
> page". The link does not work anymore.
> Was this about landscape PDF files?
> 
> > 'fit width' option, a lot of horizontal screen space
> > is often wasted by just white blank margins at left and right.
> 
> I've never seen this. "Fit width" just means to use the COMPLETE horizontal
> screen space, doesn't it?
> 
> Can someone please explain this to me? :)

Yes, sure. Windows version of Adobe Acrobat reader has two related, but a bit
different settings: "Fit width" and "Fit visible". The former is used to scale
the page to fit all the horizontal space the screen. The latter goes even
further - it also identifies and cuts off blank parts of the page from left and
right. Some documents have really large blank margins at sides, wasting
precious space of the display, that's especially important for internet tablets
with relatively small display (compared to desktop) and only 800 pixels of
horizontal space. But I still recommend to take a look at the Acrobat Reader
application to get a better idea of what this option does and why it is useful.

In any case, feel free to close this feature request as WONTFIX. The right
solution would be probably to implement this useful feature in some third party
pdf reader application.
Comment 7 Siarhei Siamashka (reporter) 2008-11-17 01:11:22 UTC
BTW, googled a bit and here are the links to the similar feature request
reported against Evince application, which also refer to "Fit visible" option
of Acrobat Reader as a very useful feature:
https://bugs.launchpad.net/ubuntu/+source/evince/+bug/38291
http://bugzilla.gnome.org/show_bug.cgi?id=169676
Comment 8 Lucas Maneos 2009-08-20 13:04:32 UTC
FYI, people watching this bug may also be interested in bug 4930 (PDF Reader
doesn't use optimal screen width in fit width mode.).  Testing of the patch
welcome.
Comment 9 Andre Klapper maemo.org 2011-11-15 12:24:09 UTC
Nokia has no plans to fix this for Maemo5 or for MeeGo 1.2 Harmattan.
Closing as WONTFIX.