Bug 7603 - HildonTouchSelector example has wrong parameters in callback function
: HildonTouchSelector example has wrong parameters in callback function
Status: RESOLVED FIXED
Product: Example Applications
MaemoExamples
: 5.0
: All Maemo
: Low normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: Aapi Hämäläinen
: documentation@maemo.org
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-03 09:26 UTC by Francis Gastellu
Modified: 2010-05-17 16:49 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Francis Gastellu (reporter) 2010-01-03 09:26:03 UTC
SOFTWARE VERSION: maemo5 hildon-example

EXACT STEPS LEADING TO PROBLEM: 
1. Use the hildon touch selector example from either the maemoexamples package,
in the hildon-examples directory
(https://garage.maemo.org/svn/maemoexamples/trunk/hildon-examples/hildon-touch-selector-example.c)
or the documentation page
(http://wiki.maemo.org/Documentation/Maemo_5_Developer_Guide/Graphical_UI_Tutorial/Data_selection)
2. In the g_signal_connect call for the "changed" signal, give a value for the
user_data parameter instead of NULL.
3. In the signal callback function, read the user_data parameter back.

EXPECTED OUTCOME: The user_data should be the value given to the
g_signal_connect call.

ACTUAL OUTCOME: The user_data is NULL.

REPRODUCIBILITY: 10/10

OTHER COMMENTS: This happen because the example is wrong: the signal callback
function is missing a gint column parameter, which causes the user_data
parameter to receive it instead. This is not a bug in the SDK but a mistake in
the example. Since the user_data parameter is ignored in the original code, the
example works fine, but it leads to bugs and/or crashes as soon as one extends
the example code to pass along user data.
Comment 1 Claudio Saavedra 2010-01-04 09:46:14 UTC
Indeed, these docs are wrong. But that's a bug in the documentation, not in the
examples that are part of the library itself. I have no idea who maintains that
hildon-example package.
Comment 2 Jarmo Tikka nokia 2010-01-04 14:57:52 UTC
Maemo examples in Garage are part of Maemo documentation. I assign this to Aapi
for him to check.
Comment 3 Aapi Hämäläinen 2010-01-05 15:13:29 UTC
Fixed. The signature is now HildonTouchSelector*, gint, gpointer. (Thanks
Tapio.)
Comment 4 Andre Klapper maemo.org 2010-05-17 16:49:43 UTC
[Rearrangement of Documentation bug reports.]
Mass-moving old closed Developer Platform > Documentation tickets.
You can filter bugmail by searching for this comment.