Bug 7567 - (int-152666) Browser toolbar steals text focus in fullscreen mode with remapped arrow keys
(int-152666)
: Browser toolbar steals text focus in fullscreen mode with remapped arrow keys
Status: RESOLVED FIXED
Product: Browser
User interface
: 5.0/(3.2010.02-8)
: All Maemo
: Low minor (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: browser-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-02 03:13 UTC by Ryan Abel
Modified: 2010-03-15 20:51 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Ryan Abel (reporter) maemo.org 2010-01-02 03:13:49 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 

1. Set Paging and Home/End to Fn+Arrow keys.[1]
2. Fullscreen the browser window.
3. Press Home/End or Page-Up/Down.

EXPECTED OUTCOME:
Browser toolbar doesn't pull focus for no reason.

ACTUAL OUTCOME:
Browser toolbar pulls focus in fullscreen when trying to move around a text
field.

REPRODUCIBILITY:
Always

OTHER COMMENTS:
Arguably unsupported, but a bit confusing.

[1]http://blogs.igalia.com/berto/2009/12/17/remapping-the-n900-arrow-keys/


User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us)
AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9
Comment 1 Andre Klapper maemo.org 2010-01-11 11:50:33 UTC
"Checked with talk.maemo.org fields, not reproducible on nb 2010-01-7. Marking
as
Already fixed"
Comment 2 Ryan Abel (reporter) maemo.org 2010-01-22 22:18:28 UTC
*** Bug 8404 has been marked as a duplicate of this bug. ***
Comment 3 Ryan Abel (reporter) maemo.org 2010-01-30 13:24:16 UTC
*** Bug 8682 has been marked as a duplicate of this bug. ***
Comment 4 tuukka.tolvanen nokia 2010-02-13 15:51:08 UTC
*** Bug 9034 has been marked as a duplicate of this bug. ***
Comment 5 Matan Ziv-Av 2010-02-16 12:26:57 UTC
The bug is still there in 3.2010.02-8.002
Comment 6 timeless 2010-02-16 12:53:21 UTC
matan: while i'm glad that you've upgraded to the latest version, we don't
really need comments like that in our bugs. when a version with the fix is
available, the target milestone will be updated to reflect it, the current
target milestone is 5.0+ which is "after the latest available release". FWIW,
3.2010.02-8 was a minor update, you shouldn't expect a fix for this (or most
bugs) in such updates, instead they will probably, but not necessarily appear
in the next major update.

and fwiw, prefer "present" instead of "there". --Shalom.
Comment 7 Andre Klapper maemo.org 2010-03-15 20:51:36 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).