Bug 7566 - (int-152667) Browser toolbar steals text focus in fullscreen mode when "Auto focus address field" is enabled
(int-152667)
: Browser toolbar steals text focus in fullscreen mode when "Auto focus address...
Status: RESOLVED FIXED
Product: Browser
User interface
: 5.0/(2.2009.51-1)
: All Maemo
: Low minor (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: browser-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-02 03:10 UTC by Ryan Abel
Modified: 2010-03-15 20:51 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Ryan Abel (reporter) maemo.org 2010-01-02 03:10:57 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 

1. Load a page with a text field (talk.maemo.org post entry field is a good
option).
2. Tap the text field once then press an arrow key.

EXPECTED OUTCOME:
Browser toolbar doesn't pull focus for no reason.

ACTUAL OUTCOME:
Browser toolbar pulls focus in fullscreen when trying to move around a text
field.

REPRODUCIBILITY:
Always, after the first highlight of the text field.

OTHER COMMENTS:
The focus logic for the browser toolbar in fullscreen seems a bit . . . off.

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us)
AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9
Comment 1 Ryan Abel (reporter) maemo.org 2010-01-02 17:48:35 UTC
Note, also, that the Sym dialog causes the toolbar to steal focus, too.
Comment 2 timeless 2010-01-03 06:01:14 UTC
there's a preference, roughly:

options>options>Typing triggers urlbar

I'm not sure what the official strings are, use mine to follow those steps.

Please indicate whether toggling this preference affects the behavior you're
experiencing.
Comment 3 Ryan Abel (reporter) maemo.org 2010-01-03 21:12:37 UTC
(In reply to comment #2)
> Please indicate whether toggling this preference affects the behavior you're
> experiencing.
> 

Yes, that fixes it.

After reviewing this issue it looks like JS interacting with the text entry
field has a certain effect. I get it with the full reply page on Talk but not
the Quick Reply field at the bottom of threads, for instance.
Comment 4 Andre Klapper maemo.org 2010-01-11 12:00:06 UTC
"Checked with 'Post reply' page on talk.maemo.org, not reproducible on nb
2010.01-7. Marking as Alreadyfixed. If it's still visible for you please
provide exact steps."
Comment 5 Andre Klapper maemo.org 2010-03-15 20:51:35 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).