Bug 7538 - Can't change the background from homescreen on N900
: Can't change the background from homescreen on N900
Status: RESOLVED DUPLICATE of bug 6494
Product: Desktop platform
Home
: 5.0/(1.2009.42-11)
: N900 Maemo
: Medium normal (vote)
: ---
Assigned To: Mikko Nurmi
: ui-specification-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-31 23:21 UTC by Franco
Modified: 2010-01-11 16:05 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Franco (reporter) 2009-12-31 23:21:17 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Tap on N900 Homescreen to Edit
2. Open the Desktop Menu
3. Tap on "Change Background"

EXPECTED OUTCOME:
A window showing the themes and option to add an image to apply to the desktop
and set as background
ACTUAL OUTCOME:
Nothing happens. It goes back to the home screen in edit mode (option to move
the widgets and bookmarks)
REPRODUCIBILITY:
ALWAYS

EXTRA SOFTWARE INSTALLED:
Hermes, ForecaWeather, Bounce, Petrovich, Firefox
OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.6)
Gecko/20091201 Firefox/3.5.6
Comment 1 Ryan Abel maemo.org 2010-01-01 00:14:11 UTC
Can't reproduce it on 51-1. Do you know how you got to this state?
Comment 2 Franco (reporter) 2010-01-02 04:08:17 UTC
Trying to find a reason, I can only think because I added a .desktop file to
the .image folder on the n900.
Also have noticed that the change background option works if I have the USB
cable plugged and working in Mass storage mode (although no image file can be
choosen).
Comment 3 Jarno Parmonen 2010-01-07 01:45:13 UTC
Have you checked the .desktop file you added? I just downloaded some new
panoramic desktop backgrounds from n900wallpapers.com (both the images and the
.desktop file) and after trying to change them, hildon-desktop crashed and
returned back to the edit mode. I only knew it crashed, because I have crash
reporter installed.
I looked at the .desktop files with nano and seems they didn't have full path
on them. after adding full path (eq.
/home/user/MyDocs/.images/imagefilename.png) they work fine and don't crash the
desktop.
Comment 4 Ryan Abel maemo.org 2010-01-07 04:21:43 UTC
(In reply to comment #2)
> Trying to find a reason, I can only think because I added a .desktop file to
> the .image folder on the n900.
> Also have noticed that the change background option works if I have the USB
> cable plugged and working in Mass storage mode (although no image file can be
> choosen). 
> 

Can you try removing and replacing the .desktop file in question to see if it
changes the behavior?

On a related note, PR1.1 should allow you to use ultra-wide images for pano
desktops and splice it automatically, thus obviating the need to use .desktop
files.
Comment 5 Jarno Parmonen 2010-01-07 20:23:14 UTC
The owner of n900wallpapers.com emailed me that he will fix the path problem on
his side, but still it's little bit silly that malformed .desktop file can
crash the background changer.
Comment 6 Jarno Parmonen 2010-01-11 15:27:38 UTC
Did the server change cause the loss of this being marked as duplicate of bug
6494?
Comment 7 Andre Klapper maemo.org 2010-01-11 16:05:49 UTC
This seems to be the same issue as bug 6494 which has been fixed internally.
Marking as duplicate.

*** This bug has been marked as a duplicate of bug 6494 ***