Bug 7536 - (int-152926) Can't search album titles (GtkIconView) by typing on keyboard
(int-152926)
: Can't search album titles (GtkIconView) by typing on keyboard
Status: RESOLVED FIXED
Product: Media player
General
: 5.0/(3.2010.02-8)
: N900 Maemo
: Low normal with 2 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: media-player-bugs
:
:
:
: 8201
  Show dependency tree
 
Reported: 2009-12-31 21:12 UTC by Guy Salazar
Modified: 2010-03-15 20:54 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Guy Salazar (reporter) 2009-12-31 21:12:21 UTC
SOFTWARE VERSION:
(Settings > General > About product)  1.2009.42-11.002

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Launch media player
2. Select "Music" 
3. Select "All Albums" from top bar
4. Attempt to search for particular album via typing keywords on
keyboard...does not work.
5. Keyboard keyword search DOES work with Artists, however.  

EXPECTED OUTCOME:  Should search for albums using keywords inputed

ACTUAL OUTCOME:  Nothing at all

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)   Always

EXTRA SOFTWARE INSTALLED:  Wallpaper creator, Hermes, Zoutube, Transmission,
Ecoach

OTHER COMMENTS:  Again, this method works flawlessly when searching Artists,
but not when searching albums.  I have now over 2000 songs on my N900 and many,
many albums.  

User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1;
InfoPath.1; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729;
InfoPath.2)
Comment 1 Andre Klapper maemo.org 2010-01-01 19:38:03 UTC
Confirming.
That is because those are different widgets - "Artists" is a list like in
Application Manager, while "All Albums" is a view like in the "Photos" Image
Viewer. Bug 5388 did not fix the latter.
Comment 2 Claudio Saavedra 2010-01-04 09:50:49 UTC
And how is this a bug in the toolkit? Bug 5388 is not about GtkIconView, so
hardly it's going to change anything.

I think that by using HildonLiveSearch, mediaplayer could fix this easily. But
I think it is wise to assume that we won't add HildonLiveSearch support by
default inside a GTK+ widget, so it's up to them.
Comment 3 Quim Gil nokia 2010-01-11 23:43:58 UTC
Please file this as a usability bug to see if it gets attention in Fremantle
or, if it's too late, in Harmattan.
Comment 4 Andre Klapper maemo.org 2010-01-22 17:53:27 UTC
*** Bug 8412 has been marked as a duplicate of this bug. ***
Comment 5 Urho Konttori 2010-02-20 22:57:02 UTC
Fixed in PR1.2. 

GTKIconView now supports live search. 
ALso, media player has the support for live search. 

Kudos to Claudio for the First, to media player team for the second.
Comment 6 Claudio Saavedra 2010-02-22 13:27:47 UTC
(In reply to comment #5)

> GTKIconView now supports live search. 

It's the other way around, though: HildonLiveSearch supports the GtkIconView in
addition to GtkTreeView. Meaning, don't expect iconviews to magically gain a
live search, but you can add it easily.
Comment 7 Andre Klapper maemo.org 2010-03-02 15:12:31 UTC
*** Bug 9309 has been marked as a duplicate of this bug. ***
Comment 8 Andre Klapper maemo.org 2010-03-15 20:54:55 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).