Bug 7516 - e2fsprogs derivative packages not available?
: e2fsprogs derivative packages not available?
Status: RESOLVED FIXED
Product: Development platform
general
: 5.0-final
: All Maemo
: Low normal (vote)
: 5.0-update3
Assigned To: Janne Johansson
: dev-platform-general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-31 03:12 UTC by Bryan Jacobs
Modified: 2010-01-14 18:02 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Bryan Jacobs (reporter) 2009-12-31 03:12:00 UTC
SOFTWARE VERSION:
Maemo SDK 5.0 Final (+fremantle repositories)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Log in to a fresh scratchbox
2. Configure /etc/apt/sources.list with extras,extras-testing,extras-devel
repositories
3. apt-get install libss-dev

EXPECTED OUTCOME:
Install libss-dev

ACTUAL OUTCOME:
libss-dev not found

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
n/a

OTHER COMMENTS:
apt-get source e2fsprogs reveals that debian/control contains packages
libss-dev, libcomerr2, etc etc.  But it appears that only the primary e2fsprogs
and libuuid1 packages are actually available on the repositories!  Building the
package myself (via apt-get source and dpkg-buildpackage) works without
modifications and produces the expected packages, but that means that I can't
post anything using comerr to extras-devel...

These packages are IMPORTANT for porting software from Debian.
Comment 1 Soumya nokia 2009-12-31 11:49:31 UTC
re-assigned to Janne.
Comment 2 Bryan Jacobs (reporter) 2010-01-01 00:06:23 UTC
This seems to also be a problem for debconf; building from unmodified source
produces debconf-utils, but where is that package in the repositories?

There are probably other packages maimed this way.
Comment 3 Janne Johansson nokia 2010-01-11 10:18:55 UTC
The SDK intentionally doesn't provide all the binaries for all the source
packages released with the SDK. This is because all the binaries are not found
on the device either and developer relying on them being there might be in for
a surprise. This might also encourage some people to use the SDK repositories
on the devices to provide the extra packages and this really isn't a good idea.

Sometimes however packages are missing because of an error on our part. This
seems to be one of those cases and the requested binaries will be added with
the next update.

Thanks for the report :)
Comment 4 Janne Johansson nokia 2010-01-11 16:54:09 UTC
Update released today. The packages should now be available.