Bug 7515 - (int-144702) List of countries not shown on tapping the country picker button
(int-144702)
: List of countries not shown on tapping the country picker button
Status: RESOLVED FIXED
Product: Contacts
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Medium major (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: contacts-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-31 01:47 UTC by Peter Kral
Modified: 2010-03-31 19:17 UTC (History)
4 users (show)

See Also:


Attachments
screenshot of the error (74.78 KB, image/png)
2009-12-31 13:41 UTC, Peter Kral
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Peter Kral (reporter) 2009-12-31 01:47:34 UTC
SOFTWARE VERSION: as above
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 

1. I use the Czech language in my phone. 
2. I imported my contacts from Nokia N95 8GB via BT sync. 
3. I open a contact, where there are no address data present.
4. I tap on the picture to get into the editing mode.
5. Tap on "add entry" and choose address (or home address or work address).
6. I can manually enter street, PO Box, City, etc... details, but the country
has its own  blue active button. Strangely, there is the Czech republic (in
Czech language - see below) preset already (however I dont see it in the
contact view!).
7. I tap on that blue active button named "Česká republika" - an editable row
appears, with the "Česká republika" words. This can be deleted and/or renamed
to other country, but if I tap "Save", nothing happens. The window doesnt
close. If I tap above this window to get back one step, in the Country row
there is still that "Česká republika". If I switch to the English UI, there
works everything fine. If I tap on the "Czech republic", I will get a scroll
down menu with the list of all countries. There I can choose one and save it.
So now, if I want to enter the correct countries to my contacts, I have to
switch to English, enter them, and after switch back to Czech again. Funny is,
that after I entered the country like described in previous sentence and
switched back to Czech, I can change it already - I will get the scroll down
menu.

EXPECTED OUTCOME: working editing for Countries for Czech device language

ACTUAL OUTCOME: not possible to add country in Czech device language 

REPRODUCIBILITY: ALWAYS
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED: ukeyboard, etc...

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US)
AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.38 Safari/532.0
Comment 1 Andre Klapper maemo.org 2009-12-31 13:09:03 UTC
Hi,

I tried to reproduce this with a contact that has just the email address set.
The contact was not imported via syncing though, but Czech is set as Language
and Region here.

I could neither reproduce in the internal software version 2009.52-5 nor on a
fresh N900 running 1.2009.42-11.

(In reply to comment #0)
> 7. I tap on that blue active button named "Česká republika" - an editable row
> appears, with the "Česká republika" words. 

So you don't get the text field plus the list of countries below, but only the
text field? Can you attach a screenshot here (Control+Shift+P)?

> This can be deleted and/or renamed
> to other country, but if I tap "Save", nothing happens.

What exactly did you enter as country name, for example?
The "Hotovo" (Done/Save) button is not greyed out, it's simply nothing
happening?
Comment 2 Andre Klapper maemo.org 2009-12-31 13:10:29 UTC
(In reply to comment #0)
> Strangely, there is the Czech republic (in
> Czech language - see below) preset already

That's default and comes from setting the Regional settings to Czech.
Comment 3 Peter Kral (reporter) 2009-12-31 13:41:47 UTC
Created an attachment (id=1884) [details]
screenshot of the error

Reply to Comment #2:

I have attached the screenshot. Exactly as you said, no scroll-down menu with
coutries, only this screen. Its pity that the screencast recording doesnt
functioning properly in the Load-applet, I could show it to you in action. When
I tap on the "Hotovo" button, absolutely nothing happens.
Comment 4 Peter Kral (reporter) 2009-12-31 13:45:42 UTC
(In reply to comment #1)
I tried to enter more options, for example: Hungary, Czech republic, Česká
republika, etc... As you can see, I tried local country names or English
country names. 

And yes, as you can see on the screenshot, the Hotovo button is not greyed out,
after tapping on it, nothing happens.
Comment 5 Andre Klapper maemo.org 2010-01-04 13:13:53 UTC
Confirming.

This has been fixed in package
libosso-abook 4.20091214.1.0rtc+0m5
which is part of the internal build version
2009.52-6
(Note: 2009 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 6 Peter Kral (reporter) 2010-01-04 13:18:08 UTC
(In reply to comment #5)

Thanks a lot!
BR,
P.
Comment 7 Andre Klapper maemo.org 2010-01-25 18:41:01 UTC
*** Bug 8488 has been marked as a duplicate of this bug. ***
Comment 8 Yves-Alexis 2010-01-30 15:25:18 UTC
*** Bug 8693 has been marked as a duplicate of this bug. ***
Comment 9 Andre Klapper maemo.org 2010-03-15 20:53:16 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 10 Andre Klapper maemo.org 2010-03-31 19:17:10 UTC
*** Bug 8492 has been marked as a duplicate of this bug. ***