Bug 7513 - (int-152163) Initial sync fails with exchange 2007
(int-152163)
: Initial sync fails with exchange 2007
Status: RESOLVED FIXED
Product: Synchronization
Mail for Exchange
: 5.0/(1.2009.42-11)
: N900 Maemo
: Medium normal (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: activesync-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-31 01:19 UTC by Mathias Weyland
Modified: 2010-01-14 16:37 UTC (History)
3 users (show)

See Also:


Attachments
syslog (26.00 KB, text/plain)
2009-12-31 13:16 UTC, Mathias Weyland
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Mathias Weyland (reporter) 2009-12-31 01:19:24 UTC
SOFTWARE VERSION:

Maemo 5 Version 1.2009.42-11
libas-protocol-0 Version 0.0.1-53+0m5 

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Fill out the forms in Settings -> Mail for Exchange
2. Run initial sync from the Settings GUI
3. Blue progress bar goes to 50% and hangs

EXPECTED OUTCOME:
Setup completes with successful initial sync

ACTUAL OUTCOME:
Setup cannot be completed

REPRODUCIBILITY:
always, with email, contacts and calendar (and combinations
of these).

OTHER COMMENTS:
I'm filing a new bug report because the current bugs I could find were either
about Exchange 2003 or about some version 12.0/12.1 mismatch, but version
12.x doesn't even appear in the logs here, so this must be something 
different.
Comment 1 Andre Klapper maemo.org 2009-12-31 12:51:07 UTC
Thanks for reporting this (and for searching for existing tickets first).

Can you please:
1) Install syslog (see
http://wiki.maemo.org/Documentation/devtools/maemo5/syslog ) and reboot
2) Open X Terminal
[optional steps begin]
2A. Enter "sudo gainroot" (to do that make sure that you have installed
"rootfs" from the Application Manager)
2B. cat /dev/null > /var/log/syslog
[optional steps end]
3) Provide the output the following commands:
   gconftool-2 -s --type=int /apps/activesync/AsDaemon/Syslog/MinLogLevel 0
   gconftool-2 -s --type=int /apps/activesync/modest/Syslog/MinLogLevel 0
   gconftool-2 -s --type=int /apps/activesync/AsProvider/Syslog/MinLogLevel 0
   gconftool-2 -s --type=int /apps/activesync/AsBackup/Syslog/MinLogLevel 0
   gconftool-2 -s --type=int /apps/activesync/asapplet/Syslog/MinLogLevel 0
   gconftool-2 -s --type=int /apps/activesync/AsStatusApplet/Syslog/MinLogLevel
0
4) Attach the file /var/log/syslog from the device to this bug (if needed, copy
it first to the section that is visible in the File Manager: cp /var/log/syslog
/home/user/MyDocs/.documents/  )
Comment 2 Mathias Weyland (reporter) 2009-12-31 13:16:23 UTC
Created an attachment (id=1883) [details]
syslog

Andre,

My apologie, I had the logfile ready yesterday but somehow forgot to to attach
it. This is the file you asked for, grepped by "activesync" and trimmed to the
initial sync process.

Regards, Matt
Comment 3 Andre Klapper maemo.org 2009-12-31 14:01:01 UTC
Thanks!
Comment 4 Vitaly Repin 2010-01-02 13:41:09 UTC
Are you sure you are working with Exchange 2007, not 2003?

Dec 31 00:06:37 Nokia-N900-42-11 activesync[1644]: MS-ASProtocolVersions:
1.0,2.0,2.1,2.5


Exchange 2007 shall support 12.0 or 12.1 

This bug sounds like Exchange 2003 known issue for me.
Comment 5 Mathias Weyland (reporter) 2010-01-02 17:41:13 UTC
(In reply to comment #4)
> Are you sure you are working with Exchange 2007, not 2003?

I'm using the exchange server of the University I work for, and they announced
migration from 2003 to 2007 quite some time ago. There's a OWA setup on the
same host and the colour of the login page turned from yellow (IIRC) to
blue-ish after that migration, and at the bottom of that page says 

Connected to Microsoft Exchange
© 2007 Microsoft Corporation. All rights reserved. 

Is there a way to confirm the version directly?
Comment 6 Andre Klapper maemo.org 2010-01-11 12:01:56 UTC
"The used Exchange server supports ActiveSync protocol versions 1.0,2.0,2.1,2.5
None of these versions were supported by MfE client in SR release.
However, PR1.1 release supports ActriveSync protocol version 2.5, so it should
work with the upcoming PR1.1 release."
Note that this is not the 1.2009.44-1 release, but the release afterwards.
Comment 7 Andre Klapper maemo.org 2010-01-14 12:26:09 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 8 luvke 2010-01-14 15:54:33 UTC
Hey iv been reading your comments about this subject,
and this morning iv installed new update,
so the problem on this subject, should be resolved.

But when i fill everything needed
i see message 

"Error. Exchange server requires secure connection or account is disabled."

When i type off SECURE CONNECTION, new note comes
"Exchange account disabled. Access refused." 

My company use ME 2007.

Please help
Comment 9 Andre Klapper maemo.org 2010-01-14 16:37:25 UTC
(In reply to comment #8)
> so the problem on this subject, should be resolved.
> 
> But when i fill everything needed
> i see message 

Different issue. Bugzilla is not a forum. Please either file a new report if
you're sure that it's a software bug, or go to http://talk.maemo.org instead.