Bug 7484 - (int152929/int-186437) After playing music, hanging up a call, music returns to previous volume directly (can hurt ears)
(int152929/int-186437)
: After playing music, hanging up a call, music returns to previous volume dire...
Status: RESOLVED FIXED
Product: Multimedia
Pulseaudio
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low normal with 5 votes (vote)
: Harmattan
Assigned To: unassigned
: pulseaudio-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-30 14:03 UTC by Konstantinos Pavlou
Modified: 2011-01-18 15:06 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Konstantinos Pavlou (reporter) 2009-12-30 14:03:31 UTC
SOFTWARE VERSION:
1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
1. Tap on Menu > Media Player > Music
2. Tap on any song to listen
3. Tap on Multitasking > Menu > Phone (Make a phone call/Receive a phone call)
4. When you hang up the Music returns to its previous volume directly


EXPECTED OUTCOME: The Music to return to its previous volume fading in slowly

ACTUAL OUTCOME: The Music returns to its previous volume directly

REPRODUCIBILITY: always

EXTRA SOFTWARE INSTALLED: none that could affect the issue

OTHER COMMENTS: This bug has to be fixed, because such a problem can create
hearing problems, in case the volume is set to a high level
I haven't tested if it happens with videos and/or internet radio/fm radio.



User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US)
AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.38 Safari/532.0
Comment 1 Andre Klapper maemo.org 2009-12-30 14:57:33 UTC
Thanks for reporting this.
Reminded me a little bit of bug 6410 when reading this.

(Note to myself: int-141419, int-142700)
Comment 2 Andre Klapper maemo.org 2009-12-30 15:09:00 UTC
So I've set the Volume slider in the statusbar to maximum volume and listen to
some MP3 in Media Player.

> 3. Tap on Multitasking > Menu > Phone (Make a phone call/Receive a phone call)
> 4. When you hang up the Music returns to its previous volume directly

Which is okay, as for hanging up I have to remove the N900 from my ear and
press the red "End" button. Hence the phone is not near to my ear.

I currently miss to set the bug here.

Now for being called on the N900: At least for cellular calls, after the other
person has hung up, you get a few normal phone sounds plus a "Call
disconnected" on the screen. I had four or five seconds between the end of the
call and the music starting again.

So what exactly is your behaviour that makes you afraid of damaging your ears?
Maybe I just behave differently, hence trying to understand.
Comment 3 Konstantinos Pavlou (reporter) 2009-12-30 15:17:50 UTC
You could say that it is OK when you listen from the speakers.

What if you listen from the earphones? Depending the songs it could "hurt". It
happened to me and it was really annoying
Comment 4 Andre Klapper maemo.org 2009-12-31 16:59:08 UTC
(In reply to comment #3)
> What if you listen from the earphones?

Now that makes more sense - Would have been nice to mention earphones already
in comment 0 already.
Still, as the music volume is the same as before the call and you "survived"
this music volume before the call, it might be surprising after hanging up, but
should not create health problems...

Fading in is a nice idea indeed, but more like an enhancment request here.
Comment 5 Konstantinos Pavlou (reporter) 2009-12-31 17:09:17 UTC
(In reply to comment #4)

> Now that makes more sense - Would have been nice to mention earphones already
> in comment 0 already.
I'll try to be more specific next time :)

> Still, as the music volume is the same as before the call and you "survived"
> this music volume before the call, it might be surprising after hanging up, but
> should not create health problems...
> Fading in is a nice idea indeed, but more like an enhancment request here.

Even if it doesn't create health problems easily it's really annoying because
whenever it happens I am in a rush (or working on something) and I do not
expect the music to be directly that loud again.

Anyway, even if it is considered as an enhancement it should be fixed :)
Comment 6 Quim Gil nokia 2010-01-11 23:19:11 UTC
Changing severity as (usability) bug. Please file internally and let's watch it
for Harmattan if it's decided too lat for Fremantle.
Comment 7 Konstantinos Pavlou (reporter) 2010-01-11 23:54:04 UTC
(In reply to comment #6)
> Changing severity as (usability) bug. Please file internally and let's watch it
> for Harmattan if it's decided too lat for Fremantle.

I don't really believe that it is too late to fix this issue in N900's
Fremantle. :)
Comment 8 Andre Klapper maemo.org 2010-01-12 16:53:16 UTC
(In reply to comment #7)
> I don't really believe that it is too late to fix this issue in N900's
> Fremantle. :)

Unhelpful comment as you probably don't know internal workflows?
Comment 9 Andre Klapper maemo.org 2010-09-22 21:05:27 UTC
WONTFIX for Maemo5 according to Nokia, keeping this opened to handle this for
the version after Maemo5.
Comment 10 Andre Klapper maemo.org 2011-01-18 15:06:01 UTC
This issue has been FIXED for Harmattan (the software version after Maemo5).
According to Nokia this unfortunately is a WONTFIX for Maemo5.