Bug 7469 - Smart birthday-widget doesn't show up any birthdays or shows one on random
: Smart birthday-widget doesn't show up any birthdays or shows one on random
Status: RESOLVED FIXED
Product: Calendar
General
: 5.0/(1.2009.42-11)
: All Maemo
: Low normal (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: calendar-general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-30 07:12 UTC by Tomi R.
Modified: 2010-01-15 14:10 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Tomi R. (reporter) 2009-12-30 07:12:31 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Launch Calendar from Applications
2. Select one day and add new Smart birthday
3. Add Calendar-widget to the desktop

EXPECTED OUTCOME: Smart birthdays shown on calendar-widget

ACTUAL OUTCOME: No Smart birthdays are shown in calendar-widget or are shown by
unknown time (and even then with only one birthday)

REPRODUCIBILITY: 10/10
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED: Pidgin, Irreco, FM Radio, Recorder, Stopish

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-US)
AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.0.249.43 Safari/532.5
Comment 1 Neil MacLeod maemo.org 2009-12-30 12:55:55 UTC
This now appears to be fixed in PR1.1/2.2009.51-1. I just added a birthday of 4
Jan 1984 to a contact and the smart birthday is now showing in my Calendar
Widget.
Comment 2 Andre Klapper maemo.org 2009-12-30 13:49:21 UTC
Thanks for reporting this.

> EXACT STEPS LEADING TO PROBLEM: 
> 1. Launch Calendar from Applications
> 2. Select one day and add new Smart birthday

For future reference, please provide exact click-by-click steps. This does not
explain how *exactly* you can do this...

Closing as per Neil's last comment.
Comment 3 Andre Klapper maemo.org 2010-01-14 12:29:58 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 4 Tomi R. (reporter) 2010-01-14 14:10:09 UTC
(In reply to comment #3)
> The problem reported here should be fixed in the update released today for
> public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
> Please leave a comment if the problem is not fixed for you in this update
> version.
> 

Well it seems to be fixed someway but not completely. The widget shows now only
the current day, not the coming ones.
Comment 5 Neil MacLeod maemo.org 2010-01-14 14:59:13 UTC
(In reply to comment #4)
>
> Well it seems to be fixed someway but not completely. The widget shows now only
> the current day, not the coming ones.
> 

Just tested this and there may be a "refresh" issue with the widget but
otherwise it (and this bug resolution) seems fine.

My test:

1. Current date is 14 Jan 2010
2. Add a new birthday of 14 Jan 1985 to a contact and click Save
3. Look at the dashboard Calendar widget - birthday for contact is showing as
"Today"
4. Change birthday of the same contact to 15 Jan 1985, and Save
5. Look at the dashboard Calendar widget - birthday for contact is still
showing as "Today"
6. Tap on Calendar widget - confirm birthday for contact is 15 Jan 2010, close
Calendar (and return to desktop widget)
7. Widget now displays correct birthday of contact as 15 Jan 2010.

I repeated the 4 through 7 advancing one day at a time until 29 Jan 2010 when
the widget (after manually "refreshing") stopped displaying the
birthday/contact so it appears the widget is showing birthdays occurring during
the next 14 days (in my test case, birthdays in the period 14 Jan 2010 -> 28
Jan 2010).

Obviously I'm testing with new birthdays that I have added to contact after
this has been fixed in 51-1... I have a birthday for a contact of 29 Jan that
was added before I upgraded to 51-1, this should - hopefully - appear in the
widget automatically tomorrow (or maybe Saturday).
Comment 6 Neil MacLeod maemo.org 2010-01-15 04:54:01 UTC
It's now Friday 15 Jan 02:53 and the smart birthday for 29 Jan has now appeared
in my desktop calendar widget... I'd say this is now working in 2.2009.51-1,
unless there is some step we are missing from this bug report.
Comment 7 Neil MacLeod maemo.org 2010-01-15 04:57:50 UTC
The only "bug" I can see in 2.2009.51-1 - and which would need it's own bug
report - is that the Calendar widget does not automatically recognise when a
birth date is changed in the Contacts database. Since people don't often change
their date of birth this could, in my opinion, be considered a relatively minor
issue that is hardly worth addressing.
Comment 8 Andre Klapper maemo.org 2010-01-15 14:10:17 UTC
Closing as per last comments.