Bug 7454 - IRC Plugin (IDLE) Closes Channels on Proxy
: IRC Plugin (IDLE) Closes Channels on Proxy
Status: RESOLVED INVALID
Product: Chat & Call & SMS
Messaging
: 5.0/(1.2009.42-11)
: All Maemo
: Low normal with 2 votes (vote)
: ---
Assigned To: rtcomm@maemo.org
: im-chat-bugs
:
: upstream
: 5139
:
  Show dependency tree
 
Reported: 2009-12-29 18:47 UTC by Alex Stansfield
Modified: 2010-06-30 22:15 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Alex Stansfield (reporter) 2009-12-29 18:47:58 UTC
SOFTWARE VERSION:
Maemo: 1.2009.42-11.203.2
Telepathy-IDLE: 0.1.5-1

EXACT STEPS LEADING TO PROBLEM:
1. Setup Plugin to connect to IRC Proxy (ctrlproxy)
2. Connect to Proxy
3. Connection made
4. IRC Channels on other IRC Client (X-Chat) are closed
5. Reopen Channel from X-Chat 
6. One second later it closes again

EXPECTED OUTCOME:
Open IRC channels remain open allowing me to chat in channel in XChat and
receive private messages to the phone

ACTUAL OUTCOME:
Open IRC Channels are closed moments after the IRC plugin connects. You can
reopen then from X-Chat but then moments later are closed again.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.1.6)
Gecko/20091201 Firefox/3.5.6 FirePHP/0.3
Comment 1 Alex Stansfield (reporter) 2009-12-29 18:59:55 UTC
Firstly I should say that I'm using:
account-plugin-idle 0.4

Basically I run an IRC proxy (ctrlproxy) that's designed to keep me logged in
on some channels on a particular network so when I disconnect my client and
then reconnect it sends me anything i've missed.

What I wanted was for the telepathy-idle plugin to connect to the proxy too so
that when I'm sent private messages they appear on the phone.

The plugin connects fine and the messages work as I'd hoped. Unfortunately a
side effect was that I was removed from the channels I was in on the network. I
rejoined them from X-Chat but moments later I was removed again.

I know multiple clients are work fine with this proxy as I've left X-Chat
running at work and used it at home at the same time.

My *guess* is that because the plugin doesn't yet work with IRC channels and
only private messages, when the proxy sends the plugin data from a channel it
just tells the proxy to close it.
Comment 2 Mikhail Zabaluev nokia 2009-12-29 19:18:27 UTC
We should have a Bugzilla component in Extras for Idle and other free protocol
add-ons.

Meanwhile, you could file a bug upstream at https://bugs.freedesktop.org. File
under product Telepathy and component idle.

This might be related:
https://bugs.freedesktop.org/show_bug.cgi?id=24273
Comment 3 Alex Stansfield (reporter) 2009-12-29 19:26:14 UTC
I was unsure about posting under this product and component as IDLE is extras
but couldn't find anywhere else relevant to post it.

That bug looks exactly like the problem I'm having. I'll add a comment there.

Many thanks.
Comment 4 Olivier CrĂȘte 2009-12-29 19:58:14 UTC
The problem is that Maemo5 currently does not have a handler for multi-user
text channels (aka irc channels). This will be fixed in an upcoming release.
Comment 5 Andre Klapper maemo.org 2009-12-29 23:56:42 UTC
See bug 5139.
Comment 6 Alex Stansfield (reporter) 2009-12-30 14:45:21 UTC
I added a comment to his bug on freedesktop:
http://bugs.freedesktop.org/show_bug.cgi?id=24273

Will Thompson from collabora.co.uk responded to say he had a patch for
telepathy-idle that would get it to handle proxies so they didn't close the
channels:
http://git.collabora.co.uk/?p=user/wjt/telepathy-idle-wjt.git;a=shortlog;h=refs/heads/proxy-mode

Whilst it will be nice to see proper channel support in Fremantle I'm guessing
it's some way off. Is there any chance that this patch can be included in the
fremantle build of telepathy-idle?
Comment 7 Mikhail Zabaluev nokia 2009-12-30 14:50:35 UTC
(In reply to comment #6)
> Is there any chance that this patch can be included in the
> fremantle build of telepathy-idle?

Maybe. Unfortunately, we don't yet have the component name in Bugzilla to
assign this to Telepathy extras.
Comment 8 Alex Stansfield (reporter) 2009-12-30 14:58:12 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > Is there any chance that this patch can be included in the
> > fremantle build of telepathy-idle?
> 
> Maybe. Unfortunately, we don't yet have the component name in Bugzilla to
> assign this to Telepathy extras.
> 

Is there anything I can do to help with that?
Comment 9 Andre Klapper maemo.org 2010-01-06 15:52:31 UTC
(In reply to comment #7)
> Maybe. Unfortunately, we don't yet have the component name in Bugzilla to
> assign this to Telepathy extras.

Assuming that Telepathy extras is not officially supported, the procedure for
maintainers is described at http://wiki.maemo.org/Bugs:Adding_Extra_products
Comment 10 Andre Klapper maemo.org 2010-04-26 15:15:05 UTC
I don't know if this is the right place as this is not officially supported by
Maemo.
I guess that this should be filed at https://bugs.freedesktop.org/ , Product:
Telepathy, Component: m5-account-plugins instead.
Comment 11 Andre Klapper maemo.org 2010-06-30 22:15:53 UTC
Please file this issue upstream (see comment 10).