Bug 7453 - Title of currently playing song doesn't update on internet radio
: Title of currently playing song doesn't update on internet radio
Status: VERIFIED DUPLICATE of bug 5305
Product: Media player
General
: 5.0/(1.2009.42-11)
: N900 Maemo
: Low normal (vote)
: ---
Assigned To: unassigned
: media-player-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-29 18:40 UTC by Bartosz Taudul
Modified: 2010-05-28 14:04 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Bartosz Taudul (reporter) 2009-12-29 18:40:10 UTC
SOFTWARE VERSION:
1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
1. Add the following radio to the internet radio list:
http://bezkitu.com/sluchaj.m3u
2. Go to http://bezkitu.com/ramowka.php and ensure that currently there's no
programme playing. If there's some programme, its title will be set as stream
title for the its whole duration. Outside of programmes various songs are
played and stream title is updated on every song change.
3. Start radio playback.
4. Notice that stream title corresponds to what is currently playing.
5. Wait for song to change.
6. Notice that stream title did not change.
7. Stop and start playback.
8. Notice that stream title again corresponds to what is currently playing.

EXPECTED OUTCOME:
Stream title displayed by media player is updated when it changes.

ACTUAL OUTCOME:
Stream title displayed by media player does not change.

REPRODUCIBILITY:
Almost always. There are single cases when this works as expected.

OTHER COMMENTS:
I have noticed this issue with other radio also
(http://scenemusic.unfy.org/necta), but bezkitu.org is the one I'm absolutly
sure this happens with good repro.

It might be also good idea to simultaneously start playback of radio stream for
example in foobar2000, to be sure that stream title is changing and when.

Please test this bug in two scenarios:
1. Media player is in the foreground, screen is not locked. Make sure the timer
ticks; having media player in task list will not do.
2. Media player is in the background and/or the screen is locked.
It seems this may influence repro and be the cause of problem.
Comment 1 Bartosz Taudul (reporter) 2010-01-14 20:23:36 UTC
Duplicate of bug 5305?

Can't verify though due to bug 7995.
Comment 2 Bartosz Taudul (reporter) 2010-01-15 21:40:58 UTC

*** This bug has been marked as a duplicate of bug 5305 ***
Comment 3 dpuricelli 2010-05-28 01:27:12 UTC
I can confirm, unfortunately PR 1.2 brought back this bug.

I wanna add some more info: I noticed that title song is updated when the phone
is *not* locked, even if Media Player is in the background, while the title
song is *never* updated when the phone is locked.
Comment 4 Andre Klapper maemo.org 2010-05-28 14:04:15 UTC
(In reply to comment #3)
> I can confirm, unfortunately PR 1.2 brought back this bug.

This ticket is closed as duplicate. Please don't comment here but on the
"original" one if you want your comments to be also read. :)