Bug 7450 - Application sorting ignores first 12 items
: Application sorting ignores first 12 items
Status: RESOLVED WORKSFORME
Product: Desktop platform
Application Menu
: 5.0/(2.2009.51-1)
: All Maemo
: Low normal with 1 vote (vote)
: ---
Assigned To: unassigned
: task-navigator-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-29 17:50 UTC by Andrew Flegg
Modified: 2010-03-10 12:18 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Andrew Flegg (reporter) maemo.org 2009-12-29 17:50:58 UTC
SOFTWARE VERSION:
2.2009.51-11

EXACT STEPS LEADING TO PROBLEM: 
1. Install "Attitude", "Hermes, "Vim" and "Conboy" from Extras (although any
GUI apps will do)
2. Tap top-left icon to get to application menu
3. Select "More..."

EXPECTED OUTCOME:
Applications are shown in a sensible order, and as new applications are added
they match expectations. For example, "Documents to Go" adds three icons; I
would expect "Sheets To Go", "Slideshow To Go" and "Word To Go" to appear next
to each other.

ACTUAL OUTCOME:
The first twelve applications shown are defined by Nokia and fixed in their
positions. They are, in order, "Notes", "PDF reader", "File manager", "RSS",
"Sketch", "App manager", "Blocks", "Chess", "Mahjong", "Marbles", "Backup", "X
Terminal".

Third party applications are then shown alphabetically.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
AccDisplay, ATI85, Attitude, Battle Gweled, Conboy, Copernicum, ForecaWeather,
gPodder, GPXView, Hermes, liqflow, Lybniz, ..., Vagalume, Vim, vpnc GUI, Word
To Go.

OTHER COMMENTS:
Compared with PR1.0 where the apps were shown in mtime of the .desktop file
this would appear to be an improvement:

  * apps don't shift position when upgraded
  * the order after the first 12 is deterministic

However there are two downsides:

  * Why are the first 12 special? Why not sort them alphabetically as well,
then the user would have all the apps in an expected order.
  * Documents To Go's 3 icons appear far apart, despite being semantically
related.


User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.6)
Gecko/20091201 Firefox/3.5.6 (.NET CLR 3.5.30729)
Comment 1 Andre Klapper maemo.org 2009-12-29 23:52:12 UTC
Those 12 are special because they are default applications I assume.
Also see bug 6932. I don't think that this is a bug, but a design decision...
Comment 2 Andrew Flegg (reporter) maemo.org 2009-12-30 00:46:36 UTC
(In reply to comment #1)
> Those 12 are special because they are default applications I assume.
> Also see bug 6932. I don't think that this is a bug, but a design decision...

To play Devil's Advocate - why does a user care, after 6 months of having the
device, that 12 of the 60-100 apps they have installed came by default? Will
such a user value Notes more than Conboy, Mahjong more than SuperTux?

After all, Nokia don't seem to value them enough to put them on the first
screen, instead they are buried - half-Fremantlised - behind the "More..."
option.
Comment 3 Andrew Flegg (reporter) maemo.org 2009-12-30 18:58:28 UTC
To remove the prioritisation of the first 12 items:

1) Open /etc/xdg/menus/hildon/applications.menu
2) Remove the <Include .../> lines from within the <Layout> section; leaving
only <Merge type="all"/>

This will result in "More..." being entirely sorted alphabetically.

From: http://talk.maemo.org/showpost.php?p=442281&postcount=5
Comment 4 Andrew Flegg (reporter) maemo.org 2010-01-02 21:31:48 UTC
It's actually worse than that: even the sorting is buggy, the items are sorted
by .desktop filename, not localised label. So, if you have an item called "RSS"
defined by osso-feed-reader.desktop and "File manager", defined by
osso-file-manager.desktop; the former will appear BEFORE the latter.
Comment 5 Andre Klapper maemo.org 2010-01-04 20:20:23 UTC
(In reply to comment #2)
> To play Devil's Advocate - why does a user care, after 6 months of having the
> device, that 12 of the 60-100 apps they have installed came by default? Will
> such a user value Notes more than Conboy, Mahjong more than SuperTux?

Nokia currently considers letting the user rearrange the menu items (bug 6401).

> After all, Nokia don't seem to value them enough to put them on the first
> screen, instead they are buried - half-Fremantlised - behind the "More..."
> option.

That is bug 5743 which is also currently being worked on.

Hence I'm personally wondering whether to import this or whether to say
"WORKSFORME once bug 5743 and bug 6401 are fixed"...
Comment 6 Urho Konttori 2010-03-10 12:18:33 UTC
As per last comment, worksforme ;)