Bug 7446 - (int-152036) Unlocking SIM card from control panel fails
(int-152036)
: Unlocking SIM card from control panel fails
Status: RESOLVED FIXED
Product: Settings and Maintenance
Control panel
: 5.0/(2.2009.51-1)
: All Maemo
: High critical (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: control-panel-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-29 15:45 UTC by Tomasz Dominikowski
Modified: 2010-03-15 20:56 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Tomasz Dominikowski (reporter) 2009-12-29 15:45:05 UTC
SOFTWARE VERSION:
(Settings > General > About product)

2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Skip typing your PIN when phone boots up
2. Go to Settings
3. In the menu, pick Unlock SIM card (rough translation from Polish UI, the
button on the right)

EXPECTED OUTCOME:

Don't display the numbers I'm typing in and actually unlock my SIM card.

ACTUAL OUTCOME:

It displays the numbers I'm typing in and doesn't unlock my SIM card. Always
says "Operation failed" (rough translation from Polish).

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)

Always.

EXTRA SOFTWARE INSTALLED:

Doesn't matter.

OTHER COMMENTS:

You can also type your PIN and unlock the SIM card when the phone boots, it
doesn't have any effect on the behaviour described above. Which makes even less
sense, since the SIM card is already unlocked, but the button is still active
and you can try to basically unlock an already unlocked card (and fail every
time as well).

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.9.1.6)
Gecko/20091215 Ubuntu/9.10 (karmic) Firefox/3.5.6
Comment 1 Andre Klapper maemo.org 2009-12-29 15:58:44 UTC
Is this device locked to a certain operator, not a SIM card?
int-143863 looks similar but has been fixed before PR1.1...

Which exact company is this about?
Comment 2 Tomasz Dominikowski (reporter) 2009-12-29 16:02:02 UTC
Hmm, not sure if I understand. This is HWID 2001 prototype, not locked to any
operator. Unlocking a SIM card means typing my PIN and thus registering to the
network. It works fine when the phone boots, but when you skip that procedure
there and try to unlock the card using the new facility in Settings, it never
works. The button is also available even if my card is already unlocked.
Comment 3 Andre Klapper maemo.org 2009-12-30 02:34:02 UTC
Thanks! Very good catch!
Totally confirming, also in English (UK). Plus I get "Operation failed" too.

It's "Enter code for unlocking SIM card".

(In reply to comment #0)
> You can also type your PIN and unlock the SIM card when the phone boots, it
> doesn't have any effect on the behaviour described above. Which makes even less
> sense, since the SIM card is already unlocked, but the button is still active

That's a different known bug which has not been fixed yet. Feel free to file a
separate issue.
Comment 4 Tomasz Dominikowski (reporter) 2009-12-30 13:32:52 UTC
If I understand correctly, the visibility of the button depending on whether
the user registered to the network upon bootup is a separate issue?
Comment 5 Andre Klapper maemo.org 2009-12-30 13:40:21 UTC
Yes. If you want to file a separate public ticket, feel free to set
"int-148173" as Alias.
Comment 6 Andre Klapper maemo.org 2010-01-22 13:29:52 UTC
This has been fixed in package
osso-connectivity-ui-l10n 6.0+r7510+0m5
which is part of the internal build version
2010.02-5
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 7 Andre Klapper maemo.org 2010-03-15 20:56:03 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).