Bug 7445 - (int-133951) mobile4arab.com: After zooming in, sometimes cannot drag to the right side
(int-133951)
: mobile4arab.com: After zooming in, sometimes cannot drag to the right side
Status: VERIFIED FIXED
Product: Browser
MicroB engine
: 5.0/(2.2009.51-1)
: N900 Maemo
: Medium normal with 1 vote (vote)
: 5.0/(10.2010.19-1)
Assigned To: Oleg Romashin
: microb-bugs
: http://ar-ar.facebook.com/
:
:
:
  Show dependency tree
 
Reported: 2009-12-29 15:09 UTC by Adib
Modified: 2010-06-18 19:11 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Adib (reporter) 2009-12-29 15:09:48 UTC
SOFTWARE VERSION: 42-11
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. open web browser
2. open for example www.mobile4arab.com
3. zoom in 2 or 3 times
4. try to slide to the right side.. it wount..

EXPECTED OUTCOME:
like other websites slide left and right



User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US)
AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.38 Safari/532.0
Comment 1 Andre Klapper maemo.org 2009-12-29 23:50:14 UTC
Thanks for reporting this.

What are other websites where this happens?

I currently guess that some JavaScript on that webpage triggers this issue.
I can partially reproduce it in the current internal version 52-5 - it
sometimes works, sometimes it does not.
Comment 2 timeless 2009-12-30 11:04:05 UTC
I thought we already had a public bug for this. The standard report of this is
Arab Facebook (it also affects Hebrew, and is roughly iiuc a split between a
bug in Gecko upstream and poor design by Facebook and friends).
Comment 3 Andre Klapper maemo.org 2009-12-30 16:55:50 UTC
(In reply to comment #2)
> The standard report of this is Arab Facebook (it also affects Hebrew

Any internal bug ID? Could not find one...
Comment 4 Adib (reporter) 2009-12-30 18:16:35 UTC
here are some other websites:

http://ar-ar.facebook.com/
http://www.startimes2.com
http://www.bramjnet.com/vb3
http://www.4electron.com
Comment 5 timeless 2009-12-31 04:40:14 UTC
https://bugzilla.mozilla.org/show_bug.cgi?id=526477

the summary here could use a rewrite (steal the one from bmo?)
Comment 6 timeless 2010-01-15 00:28:06 UTC
fwiw, romaxa indicated to me this week he had a fix for this
Comment 7 Adib (reporter) 2010-01-31 23:36:14 UTC
In new firefox this has resolved.. And it works good now.
But still the same for MicroB..
Comment 8 timeless 2010-01-31 23:43:23 UTC
adib: thanks, but we don't need such comments here.

fixed internally in 10.2010.03-12

please note that this build number is totally random and has no relationship to
anything else. Andre will come along and indicate when there's a build
available with this fix for you to use.
Comment 9 Andre Klapper maemo.org 2010-02-10 15:31:30 UTC
This has been fixed in packages
microb-eal 2.9.5-1.4+0m5
tablet-browser-view 2.2.6-1.2+0m5
which are part of the internal build version
10.2010.03-12
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 10 tuukka.tolvanen nokia 2010-02-26 23:03:35 UTC
*** Bug 9287 has been marked as a duplicate of this bug. ***
Comment 11 Andre Klapper maemo.org 2010-03-15 20:51:33 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).