Bug 7436 - Bluetooth does not start media player
: Bluetooth does not start media player
Status: RESOLVED WONTFIX
Product: Media player
General
: 5.0:(10.2010.19-1)
: N900 Maemo
: Unspecified enhancement with 2 votes (vote)
: ---
Assigned To: unassigned
: media-player-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-29 03:48 UTC by max.schrems
Modified: 2012-03-24 11:41 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description max.schrems (reporter) 2009-12-29 03:48:05 UTC
SOFTWARE VERSION: Latest Software for N900
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))

After connectiong BT headphones with remote control buttons, the player has to
be started manually in order to me able to use the headphones

EXPECTED OUTCOME: The media player should react to AV-bluetooth-remote-controll
without the need of starting it

ACTUAL OUTCOME:

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1;
Trident/4.0; GTB6; .NET CLR 1.1.4322)
Comment 1 Andre Klapper maemo.org 2009-12-29 15:04:21 UTC
Thanks for reporting this.

(In reply to comment #0)
> SOFTWARE VERSION: Latest Software for N900
> (Settings > General > About product)

That's vague, depending on what you have access to.
Please provide the exact version number.

> EXACT STEPS LEADING TO PROBLEM: 
> After connectiong BT headphones with remote control buttons

Please explain *in detail* what you do (e.g. tap on OK) and what you see (e.g.
message > Connection Failed appears)

Also mention the exact hardware, model etc.
Comment 2 Venomrush 2010-03-20 02:45:23 UTC
Is this still reproducible in the latest firmware 3.2010.02-8?

Can you please state which bluetooth device it is?
Can you also please describe the steps in details leading the to the problem.
Comment 3 Andre Klapper maemo.org 2010-04-14 13:58:26 UTC
Max, can you please answer Venomrush's questions?
Comment 4 max.schrems (reporter) 2010-04-14 16:50:05 UTC
I am using a Phillips SHB 9000 Stereo Headset and the N900 at the latest
software version (3.2010.02-8)

The two divices are pairing perfectly and communicate just as well.

If seems that the control commands that are sent from the headset to the N900
are not forwardet to the media player as long as it is not the active task on
the screen.

If you are automatically paring the divices, you have to manually start the
media player in order to then be able to use the control buttons on the
headphone.

I would suggest, that AV-Control signals from a bluetooth device are
automatically starting the media player.
Comment 5 Fredrik Wendt 2010-04-21 16:31:47 UTC
I think this is a duplicate of Bug 5331.
Comment 6 Andre Klapper maemo.org 2010-05-28 21:32:22 UTC
This week Nokia released the Maemo5 update version 10.2010.19-1 for public
(also called "PR1.2").
If you have some time we kindly ask you to test again if the problem reported
here still happens in this new version - just leave a comment (and feel free to
update the "Version" field to the new version if it's still a problem).
Comment 7 Fredrik Wendt 2010-06-01 14:06:23 UTC
I just tried this with PR1.2:
0. Turn phone on.
1. Turn bluetooth on (not visible, headset and phone paired before step 0)
2. Turn headset on.
3. Headset icon appears and bluetooth icon turns blue. Banner appears saying
"Connected to [name of BT device/headset]"
4. Press play on the headset.

Expected
5. Music starts playing

Actual
5. The machine starts working (CPU load goes up and down) and finally a Banner
is displayed saying (translated): "The media could not be played. Sound is in
use by another program" (original message in Swedish: Det gick inte att spela
media. Ljudet används av ett annat program.)

Workaround
4. Tap on the media widget on the home screen.
5. Press play on headset
Comment 8 Fredrik Wendt 2010-06-01 14:32:56 UTC
The headset used: SonyEricsson HBH-DS970
In the workaround, I tapped the top part of the media widget to start the media
player (tapping the play button doesn't work).
Comment 9 Andre Klapper maemo.org 2012-03-24 11:41:17 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )