Bug 7415 - (int-152679) When accepting a call, music playback not paused & keeps on playing muted
(int-152679)
: When accepting a call, music playback not paused & keeps on playing muted
Status: RESOLVED FIXED
Product: Multimedia
Media streamer
: 5.0/(2.2009.51-1)
: ARM Maemo
: Low normal with 20 votes (vote)
: 5.0/(20.2010.36-2)
Assigned To: internet-tablet-addons@nokia.com
: media-streamer-addon-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-29 00:15 UTC by Tariq
Modified: 2010-10-26 19:47 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Tariq (reporter) 2009-12-29 00:15:59 UTC
SOFTWARE VERSION: 1.2009.42-11.003

EXACT STEPS LEADING TO PROBLEM: 
1. Play some music
2. Receive a phone call 

EXPECTED OUTCOME: Music pauses when phone call comes in, resumes after ending
the call from when you got the call.

ACTUAL OUTCOME: Music actually keeps on playing, but is muted while you're on
the phone. After ending the conversation, volume comes back, and you've now
either skipped a portion of the song or several songs depending on how long
you've been on the phone.

REPRODUCIBILITY: always
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED: I've experienced this problem out of the box before
installing in applications.

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.6)
Gecko/20091201 Firefox/3.5.6 (.NET CLR 3.5.30729)
Comment 1 Andre Klapper maemo.org 2009-12-29 12:48:13 UTC
Thanks for reporting this.

> EXACT STEPS LEADING TO PROBLEM: 
> 1. Play some music

This is too vague to reproduce - as written, please provide an exact step by
step explanation here by mentioning every action/click.
Comment 2 Alan Peery 2009-12-29 14:09:34 UTC
*** This bug has been confirmed by popular vote. ***
Comment 3 Tariq (reporter) 2010-01-02 04:07:15 UTC
(In reply to comment #1)
> Thanks for reporting this.
> 
> > EXACT STEPS LEADING TO PROBLEM: 
> > 1. Play some music
> 
> This is too vague to reproduce - as written, please provide an exact step by
> step explanation here by mentioning every action/click.
> 

Thanks for your reply, and i apologize for taking this long to respond.
Regarding the first step, If i had to make it less vague, then here's the exact
step by step explanation

1. Click on the menu icon from the desktop
2. Click on the Media Player application
3. Select the Music player
4. Play any track (from playlist, artist, albums, or all songs view)
5. When receiving a phone call, click on Answer button
6. End phone call by either pressing the End button or having the other party
hang up first

I really don't know how to make it any less vague. Furthermore, in case this is
important, I want to mention that the same problem happens if you launch the
Media Player application from a desktop shortcut, or play an audio file
straight from the file manager. In case it's necessary, here are the step by
step instructions for both scenarios:

1. Click on Media Player application shortcut from the desktop
3. Select the Music player
4. Play any track (from playlist, artist, albums, or all songs view) by
clicking on it
5. When receiving a phone call, click on Answer button
6. End phone call by either pressing the End button or having the other party
hang up first

Or

1. Click on the menu icon from the desktop
2. Click on More
3. Click on File Manager
4. Browse to folder that has the audio file you want
5. Click on the audio file to launch it in the music player
6. When receiving a phone call, click on Answer button
7. End phone call by either pressing the End button or having the other party
hang up first

If you need me to make it any less vague, please let me know what you think
might be missing. Thanks.
Comment 4 Andre Klapper maemo.org 2010-01-11 17:41:43 UTC
*** Bug 6954 has been marked as a duplicate of this bug. ***
Comment 5 Andre Klapper maemo.org 2010-01-11 17:42:54 UTC
First of all: We've lost some data due to bug 7797 - sorry for that.
Restoring state.
Comment 6 Alan Peery 2010-02-13 20:31:53 UTC
This does not appear to be a consistent behaviour, but it's still not quite
right.  I tested it this way:

1) Start media player playing download podcast.
2) Set up other mobile to dial N900 when I press one final button.
3) Wait until the media player comes up on a nice minute boundary.
4) Dial the N900
5) Accept the call.

When I had a 30 second call this way, there time of the recording moved forward
10 seconds.  Neither a nice clean pause, nor the minutes-long playing-in-mute
described by the first submission.
Comment 7 Omri Hurvitz 2010-02-25 17:26:13 UTC
Just to add some information, I feel that the playback should pause as soon as
the phone starts ringing.
Even if I reject an incoming call, I skip a few seconds of playback
(significant for audiobooks...)
Also, playback should pause when I make a call (common case - I am in my car
listening to an audiobook, I remember I need to call the last number I dialed;
I press the redial button on my Bluetooth headset; the phone will redial - but
will not pause the playback).
Comment 8 Thomas Perl 2010-04-11 15:40:32 UTC
*** Bug 9258 has been marked as a duplicate of this bug. ***
Comment 9 Andre Klapper maemo.org 2010-10-26 19:47:38 UTC
According to internal comments by Nokia this should be fixed in in the public
update 20.2010.36-2 that was released yesterday.
Please leave a comment if this is not the case.