Bug 7394 - (int-152034) Some photos are missing EXIF DateTimeOriginal data
(int-152034)
: Some photos are missing EXIF DateTimeOriginal data
Status: RESOLVED FIXED
Product: Images and Camera
Camera
: 5.0/(2.2009.51-1)
: All Maemo
: Low normal with 1 vote (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: camera-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-28 01:25 UTC by Thomas Perl
Modified: 2010-03-15 20:54 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Thomas Perl (reporter) 2009-12-28 01:25:22 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Make lots of photos in one evening
2. Upload all photos to the computer
3. Examine the EXIF Timestamps (e.g. sort by DateTimeOriginal)

EXPECTED OUTCOME:

All files have correct DateTimeOriginal data

ACTUAL OUTCOME:

A few files do not have DateTimeOriginal (although they do have some other tags

REPRODUCIBILITY:

less than 1/10 (about one photo per evening)

OTHER COMMENTS:

I can use the file "mtime" to fake the DateTimeOriginal tag, but that's just a
workaround, and won't work if the file is directly shared via "Sharing". I can
provide example data on request.
Comment 1 Thomas Perl (reporter) 2009-12-28 01:26:28 UTC
FYI: Might be related to bug 7145, but in this case, there is no time set and
none visible, whereas for the other bug, the time is set to 1970, that's why I
created a new bug report. Feel free to merge if this is the same bug.
Comment 2 Javier Fernández 2010-01-20 21:01:10 UTC
Did you manually tag the photos ? Perhaps using the tagcloud in post-capture
view. 
Did you enable the geotagging ?
Comment 3 Thomas Perl (reporter) 2010-01-20 21:20:41 UTC
(In reply to comment #2)
> Did you manually tag the photos ? Perhaps using the tagcloud in post-capture
> view. 

No, I did not manually tag the photos on the device.

> Did you enable the geotagging ? 

Yes, I have enabled geotagging that night. It was an indoor event, and the
cellular connectivity was not too good, so not every photo has a geotag, but
the device tried to acquire GPS coordinates and sometimes even succeeded, not
just all the time during that night.
Comment 4 Javier Fernández 2010-01-20 21:38:47 UTC
I kind of remember a gstreamer-plugins-bad bug about the metadata insertion
through the pipeline to the final picture file and some metadata fields missing
because the reverse geocoding ones (country, city, suburb) were not correcty
added. I don't mean the geotags has nothing to do with the DateTimeOriginal,
but the mechanism to insert the metadata fail when it finds an incorrect geotag
to be inserted as well. 

I dont remember the bug number right now, but i remember having a discussion
about that and the plans to fix it as soon as possible. It should be fixed now,
indeed. Let see whats happens.
Comment 5 Thomas Perl (reporter) 2010-01-20 21:43:11 UTC
(In reply to comment #4)
> I dont remember the bug number right now, but i remember having a discussion
> about that and the plans to fix it as soon as possible. It should be fixed now,
> indeed. Let see whats happens.   

I have not been able to reproduce this last weekend, although I have not made
many photos. I'll post here if I can reproduce it in the future. If after some
weeks I'm not able to reproduce this (with geotagging enabled), this bug can be
closed, if nobody else is able to reproduce it anymore.
Comment 6 Andre Klapper maemo.org 2010-02-17 20:01:43 UTC
"No one has reported this problem again in the public bugzilla, nor the testers
in the internal bugtracker. This bug seems to be already FIXED in internal
version 2010.05-13."
Comment 7 Andre Klapper maemo.org 2010-03-15 20:54:32 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).