Bug 7388 - Updating software removes desktop shortcuts
: Updating software removes desktop shortcuts
Status: CLOSED FIXED
Product: Desktop platform
Home
: 5.0/(1.2009.42-11)
: N900 Maemo
: Medium minor (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: home-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-27 23:35 UTC by Florian Boor
Modified: 2010-03-02 14:06 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Florian Boor (reporter) 2009-12-27 23:35:23 UTC
EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Create a shortcut for an application on the desktop
2. Upgrade packages 


EXPECTED OUTCOME:
Updating an application to which we have a shortcut on the desktop should not
have any (visible) impact on the shortcut.

ACTUAL OUTCOME:
The desktop shortcuts disappear.

REPRODUCIBILITY:
This happened for all application (all third party) I had shortcuts for (e.g.
Conboy, FBReader iirc.)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
I'll try to reproduce with the 5+ version.

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.1.6)
Gecko/20091215 Ubuntu/9.10 (karmic) Firefox/3.5.6
Comment 1 Florian Boor (reporter) 2010-01-05 11:33:28 UTC
Can't reproduce this with PR1.1 any more. Tested with several apps - seems to
be fixed.
Comment 2 Urho Konttori 2010-01-05 21:52:26 UTC
setting as fixed as per last comment. (for pr1.1)
Comment 3 Andre Klapper maemo.org 2010-01-14 12:29:06 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 4 Venomrush 2010-03-01 22:44:42 UTC
Verifying for PR1.1

Upgraded recaller and desktop shortcut is still there after the upgrade.