Bug 7380 - CallLog should give options to call with other methods (Skype, SIP etc)
: CallLog should give options to call with other methods (Skype, SIP etc)
Status: RESOLVED WONTFIX
Product: Chat & Call & SMS
Call Application UI
: 5.0/(2.2009.51-1)
: All Maemo
: Low enhancement with 7 votes (vote)
: ---
Assigned To: rtcomm@maemo.org
: call-ui-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-27 17:13 UTC by Giorgos Logiotatidis
Modified: 2012-03-24 11:46 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Giorgos Logiotatidis (reporter) 2009-12-27 17:13:21 UTC
SOFTWARE VERSION:
1.2009.42-11.003

EXACT STEPS LEADING TO PROBLEM: 
1. You have a number in the call log which is unknown (e.g. you received a call
from that number)
2. You click on that number and you get among others a "call" option
3. The phone directly calls the number using the route which was used in the
first place (e.g. if it was a cell call, it will make a cell call)

EXPECTED OUTCOME:
Provide a list with all available calling options: cell, sip, skype out etc

ACTUAL OUTCOME:
Direct calling using predefined method, which in the case of a missed call is
not selected by the user. E.g. I have a missed call from the cellular network
but I want to call back using SIP

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.6)
Gecko/20091215 Ubuntu/9.10 (karmic) Firefox/3.5.6
Comment 1 iKnead Dough 2009-12-29 23:18:31 UTC
If someones airtime minutes are sparse it is especially important to be able to
call back using SIP or another method.

The annoyance of this bug is compounded by the fact that you can't even copy
the number in order to paste it as a new SIP call.
Comment 2 Andre Klapper maemo.org 2010-01-18 20:11:19 UTC
*** Bug 7998 has been marked as a duplicate of this bug. ***
Comment 3 Andre Klapper maemo.org 2012-03-24 11:46:56 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )