Bug 7375 - (int-145196) account-plugin-butterfly - delete contacts doesn't work
(int-145196)
: account-plugin-butterfly - delete contacts doesn't work
Status: RESOLVED FIXED
Product: Chat & Call & SMS
Telepathy
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low normal with 2 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: rtcomm@maemo.org
: telepathy-bugs
: https://bugs.freedesktop.org/show_bug...
:
:
:
  Show dependency tree
 
Reported: 2009-12-27 14:59 UTC by Christian Wilken
Modified: 2010-03-18 13:56 UTC (History)
6 users (show)

See Also:


Attachments
Updated Telepathy backend (version 0.4.59-1) (78.89 KB, application/deb)
2010-02-03 19:07 UTC, Marco Barisione
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Christian Wilken (reporter) 2009-12-27 14:59:07 UTC
SOFTWARE VERSION:
account-plugin-butterfly *any version* (even 0.4)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Login to MSN via butterfly plugin
2. Delete contact (msn contact)
3. Logout
4. Login again

EXPECTED OUTCOME:
Contact will not re-appear (shouldn't show up first case as they don't exist on
Live site!).
If using account-plugin-haze instead the contacts I've deleted on Live during
the years don't appear in the first case. The reason I'm trying to switch to
butterfly is that it seems to be the "standard" for Maemo 5 (it's a dependency
for "Extra protocol plugins for Maemo" (telepathy-plugin-extras?)). 

ACTUAL OUTCOME:
Contact re-appears.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux armv7l; en-GB; rv:1.9.2a1pre)
Gecko/20090928 Firefox/3.5 Maemo Browser 1.4.1.21 RX-51 N900
Comment 1 Andre Klapper maemo.org 2009-12-28 15:25:47 UTC
Thanks for reporting this.
account-plugin-butterfly is not officially supported by Nokia.
According to
https://maemo.org/packages/package_instance/view/fremantle_extras-testing_free_armel/account-plugin-butterfly/0.2/
the bugtracker for this product is located at
https://bugs.freedesktop.org/enter_bug.cgi?product=Telepathy&component=butterfly

Please file a bug report there.
Comment 2 Christian Wilken (reporter) 2009-12-28 15:40:46 UTC
(In reply to comment #1)
> Thanks for reporting this.
> account-plugin-butterfly is not officially supported by Nokia.
> According to
> https://maemo.org/packages/package_instance/view/fremantle_extras-testing_free_armel/account-plugin-butterfly/0.2/
> the bugtracker for this product is located at
> https://bugs.freedesktop.org/enter_bug.cgi?product=Telepathy&component=butterfly
> 
> Please file a bug report there.
> 

Thanks for the info Andre.

There is already a bug report here ->
https://bugs.freedesktop.org/show_bug.cgi?id=19903
Comment 3 Andre Klapper maemo.org 2009-12-28 15:47:09 UTC
Ah, cool.
Comment 4 Olivier Crête 2009-12-28 19:19:37 UTC
This is actually a bug in the maemo UI, which shows contacts in the publish
list while it should only show "stored" or "subscribe". There is an internal
bug about this and it should be fixed in an upcoming release.
Comment 5 Christian Wilken (reporter) 2009-12-28 21:28:47 UTC
(In reply to comment #4)
> This is actually a bug in the maemo UI, which shows contacts in the publish
> list while it should only show "stored" or "subscribe". There is an internal
> bug about this and it should be fixed in an upcoming release.
> 

Thanks for clarifying Oliver.

If it's a bug in the Maemo UI how come I'm not seeing this using the haze
plugin? Is it using some kind of workaround?
Comment 6 Olivier Crête 2009-12-28 21:34:26 UTC
Possibly libpurple is already doing some kind of filtering, I'm not sure how it
works.
Comment 7 Marco Barisione 2009-12-29 17:11:30 UTC
I think this is actually 2 separate bugs.
Contacts deleted on the windows client and visible on maemo is due to the
official client behaving in a weird way.
The other problem is the impossibility to delete a contact using butterfly.
I wrote a fix for both bugs that hopefully will be released soon.
Comment 8 Arsalan 2010-02-03 17:01:59 UTC
(In reply to comment #7)
> I think this is actually 2 separate bugs.
> Contacts deleted on the windows client and visible on maemo is due to the
> official client behaving in a weird way.
> The other problem is the impossibility to delete a contact using butterfly.
> I wrote a fix for both bugs that hopefully will be released soon.
> 

When will we see the big fixed version? I installed 0.7 and it has the same
bug. I tried 0.8 but unfortunately, it does not support video call, which is 
my only reason for using this plugin instead of Haze.
Comment 9 Marco Barisione 2010-02-03 18:54:00 UTC
Both of the fixes should be in the next public released version.
Comment 10 Arsalan 2010-02-03 18:56:15 UTC
(In reply to comment #9)
> Both of the fixes should be in the next public released version.
> 

Any idea when that might be? 

Also, another bug that I noticed is that sometimes it does not remember my
nickname and instead it just shows my email address when I sign in but after
few minutes it fixes itself.
Comment 11 Andre Klapper maemo.org 2010-02-03 19:05:55 UTC
(In reply to comment #10)
> Also, another bug that I noticed
Different issue. See https://bugzilla.gnome.org/page.cgi?id=bug-writing.html


This has been fixed in package
eds-backend-telepathy 0.4.59-1+0m5
which is part of the internal build version
2010.02-6
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 12 Marco Barisione 2010-02-03 19:07:09 UTC
Created an attachment (id=2208) [details]
Updated Telepathy backend (version 0.4.59-1)

Actually the EDS telepathy backend is open source, so if you want you can try
installing the attached .deb that should solve the problem of the deleted MSN
contacts still visible on the N900.

Note that this is *not* an official release of this package; it has not been
tested on a released image but only in the internal private builds. Take a
backup before trying this as things could go horribly wrong. If that happens
you cannot blame neither me nor Nokia :P
Comment 13 Pierre Ossman 2010-02-14 14:35:02 UTC
I'd like to test your updated package, but where do I find the original one
(0.4.56-1) if I want to downgrade again?
Comment 14 Andre Klapper maemo.org 2010-03-15 20:52:18 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 15 Timur Kristóf 2010-03-18 13:56:48 UTC
It doesn't let me install the .deb file from comment #12, but it says:
"Incompatible application package."