Bug 737 - (int-37112) PDF reader middle button behaviour to next page
(int-37112)
: PDF reader middle button behaviour to next page
Status: CLOSED WONTFIX
Product: Utilities
PDF reader
: 2.0
: All All
: Medium normal with 4 votes (vote)
: ---
Assigned To: Maemo QA (deprecated)
: pdf-reader-bugs
: http://konttoristhoughts.blogspot.com...
:
:
:
  Show dependency tree
 
Reported: 2006-08-07 15:07 UTC by Urho Konttori
Modified: 2008-09-04 22:05 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Urho Konttori (reporter) 2006-08-07 15:07:13 UTC
I was just yesterday reading The Tux magazine on my 770. They use a wide screen
format with two to three columns. Lots of images, a brilliant magazine indeed.
Works really fast too on the it 2006. While I was reading it though, I had
problems reading it comfortably. If I used the fit to width -option, which I
love, the font was too small to be read at a relaxed distance. Fortunately 770
has excellent zoom options. I zoomed in once or two times, depending on the page
and reading was a bliss. ... Until I had to change page. In fit to width mode,
you can just press arrow right to go to the next page. Unfortunately that menas
that I have to zoom out two times to fit width mode, press next page button and
then zoom in two times before I can read the next page. That's 5 presses to get
to the next page. Unfortunately that's often not even enough. The right button
press registers much too easily two presses when I press it just once, after
which I have to try to go back one page with the left button. Left button
naturally behaves just like the right one. The same applies to the image viewer.  

Well, to get things more comfortable, I noticed that I can switch to normal mode
from the fullscreen mode and use the icons at the bottom of the page to go to
the next page and then I'd switch back to fullscreen mode. Only 2 button presses
and one screen tap to go to the next page. Quite an improvement, but still,
there is no reason why it needs to take more than one press. 

Enter navigation middle button. At the moment it is used to switch to fullscreen
and back. But what's the need when 770 has a dedicated button to just to do
that. So, it figures that a change is needed. How about using the navigation
middle button to go to the next page (or show the next image in image viewer)?
It would be a simple solution and the current button behaviour would not be missed.
Comment 1 Maemo QA (deprecated) 2006-08-07 18:22:57 UTC
Thanks for the report, it has been forwarded to UI specification maintainer.
Unfortunately, these types of problems tend to take quite a long time to fix.
Comment 2 Urho Konttori (reporter) 2006-08-07 21:12:43 UTC
FBreader supports using the + and - zoom buttons for previous and next pages. I
think this is also a good solution, as you usually setup the zoom at the
beginning of reading a book. Then the page turning, the repetitive task, should
be buttoned, not the setup once task, like it's now. 

Also, same applies to image viewer. WHy not setup the zoom to be defined by
selecting top left corner of zoom and then dragging to lower right and release
the zoom buttons to previous / next use.
Comment 3 Maemo QA (deprecated) 2006-08-09 16:05:27 UTC
The suggestion has been noted by UI designer. Thus resolving this as REMIND.
Tapping Menu key and selecting Page->Previous/Next page also changes the page.
Comment 4 Maemo QA (deprecated) 2006-08-28 10:57:36 UTC
*** Bug 751 has been marked as a duplicate of this bug. ***
Comment 5 Andre Klapper maemo.org 2008-08-27 10:52:19 UTC
Getting rid of "RESOVLED REMIND" - this bug is closed as INVALID internally
because some Specifications have been changed - I'd rather use WONTFIX in Maemo
Bugzilla.

Sorry for the email noise.
Comment 6 Urho Konttori (reporter) 2008-09-04 22:05:07 UTC
Yeah, well, evince is so far superior pdf reader to the nokia default reader
that I'm very comfortable using that instead of the buit in one, so I'm also
happy to keep this closed. Shame that n810 doesn't have by default evince.