Bug 7362 - (int-226625) XMPP client doesnt log off if device is shut down on NATed connection
(int-226625)
: XMPP client doesnt log off if device is shut down on NATed connection
Status: RESOLVED FIXED
Product: Chat & Call & SMS
XMPP
: 5.0/(3.2010.02-8)
: All Maemo
: Unspecified normal with 1 vote (vote)
: Harmattan
Assigned To: rtcomm@maemo.org
: xmpp-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-27 02:41 UTC by dect
Modified: 2011-02-28 17:49 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description dect (reporter) 2009-12-27 02:41:49 UTC
SOFTWARE VERSION:
(Settings > General > About product)
Current production firmware as of December 2009 (42-11).

EXACT STEPS LEADING TO PROBLEM: 

1. Use N900 connected NATed via WLAN router to jabber server
2. Push little on/off button on top of device and shut down system using popup
menu
3. Device turns off
4. NATed connection to jabber server stays connected showing my jabber account
as "online" to others.

EXPECTED OUTCOME:
Jabber account should be logged off automatically while device turns off
showing my account as "offline" to others.

ACTUAL OUTCOME:
Account stays connected showing "online" status to other accounts. CRITICAL:
Since Jabber server thinks my account is online offline messages are not stored
server side and get lost!!!

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

None

OTHER COMMENTS:

NATed WLAN connection from N900 using a Fritzbox 7170 router to jabber Erlang
Jabber server (ejabberd).
Comment 1 Bartosz Taudul 2009-12-27 16:52:37 UTC
What if someone walks out of WIFI range, while being connected to jabber? Isn't
it the same scenario? Jabber servers should check if messages are arriving to
the client before discarding them on their side.
Comment 2 dect (reporter) 2009-12-28 13:57:45 UTC
I am not sure if the XMPP protocol stack checks for this kinda handshake (have
to reasd the specs). All I have experienced this far is that my jabber account
stays online on ejabberd 2.1.0 version which is a mature XMPP server written in
Erlang language and quite popular (I think even Facebook uses an customized
version of it) when I turn off the device.

I think it should be fixed quite easy as sending a logout request to the jabber
server in case the device is turned off or shutdown on low battery.

Leaving your hotspots wifi range is another topic, but not that critical since
I have setup my N900 to handover to 2G or 3G if available automatically.
Comment 3 Josh Triplett 2010-01-24 21:57:00 UTC
If you kill -9 your IM client on some other system, do you get the same
behavior?

In general, your jabber server really needs to handle the possibility that the
client might go away without any warning.
Comment 4 Venomrush 2010-03-24 01:17:59 UTC
Is this still reproducible with the latest firmware 3.2010.02-8?
Comment 5 foobar 2010-04-01 17:18:46 UTC
(In reply to comment #4)
> Is this still reproducible with the latest firmware 3.2010.02-8?

yes.
Comment 6 Mikhail Zabaluev nokia 2011-02-28 17:49:13 UTC
Should work as expected in Harmattan.