Bug 7359 - (int-138610) Chat window for jabber / xmpp is not always updated with new incoming messages
(int-138610)
: Chat window for jabber / xmpp is not always updated with new incoming messages
Status: RESOLVED FIXED
Product: Chat & Call & SMS
Messaging
: 5.0/(1.2009.42-11)
: All Maemo
: Medium normal with 4 votes (vote)
: 5.0/(2.2009.51-1)
Assigned To: rtcomm@maemo.org
: im-chat-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-27 01:16 UTC by dect
Modified: 2010-01-14 12:28 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description dect (reporter) 2009-12-27 01:16:05 UTC
SOFTWARE VERSION:
(Settings > General > About product)
Official firmware for production units as of December 2009 (week 42).

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Open Jabber chat with contact using Miranda IM
2. Start chatting
3. Dont let the unit fall into standby (let the screen go blank)

EXPECTED OUTCOME:
New chat messages should be displayed in chat window when they where received.

ACTUAL OUTCOME:
Actually after a few lines of chatting I hear audible notifications of a new
jabber chat message received from my contact. However the chat window doesnt
display the new message / doesnt update its contents. If I type a new message
it is displayed in the chat window, still missing the received message.

I can see only the new messages when I close the chat window and reopen it,
doing a refresh the hard way. 

REPRODUCIBILITY:
always, 8/10

EXTRA SOFTWARE INSTALLED:

None

OTHER COMMENTS:

Server side Erlang Jabber Daemon (ejabberd) v2.1.0 was used; Miranda version of
my contact not known yet.
Comment 1 Mikhail Zabaluev nokia 2009-12-28 16:21:26 UTC
We need to see if it's only a scrolling problem. Did you try to pan the chat
view all the way to the bottom?
Comment 2 dect (reporter) 2009-12-29 00:59:13 UTC
Yes I tried to scroll to the bottom of the chat history after I heard the new
chat message jingle. However the scroll list stopped on a previous message I
received from my contact and not the lastest one received.

BTW: The chat window was not reseized using the volume buttons (at standard
size from factory defaults).
Comment 3 Mikhail Zabaluev nokia 2009-12-29 15:35:35 UTC
Thank you for reporting. We should investigate this.
Comment 4 Christoph 2010-01-10 21:23:17 UTC
I have the same problem, but only with one contact.
Could it be, that this happens if you have more than one jabber account
and the other one can be reached via different accounts ?
Comment 5 useless.invention 2010-01-10 21:27:12 UTC
*** This bug has been confirmed by popular vote. ***
Comment 6 useless.invention 2010-01-10 21:41:22 UTC
I have this issue with Google IM. 

Suspect this may happen with IM conversations that have been going on for a
while / have a lot of history.
Comment 7 Andre Klapper maemo.org 2010-01-11 13:32:22 UTC
This has been fixed in package
telepathy-gabble 0.8.7-0maemo1+0m5
which is part of the internal build version
2.2009.44-2
(Note: 2009 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 8 Andre Klapper maemo.org 2010-01-14 12:28:59 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.