Bug 7335 - (int-152180) Browser shows strong font kerning bugs (esp. when zooming)
(int-152180)
: Browser shows strong font kerning bugs (esp. when zooming)
Status: VERIFIED FIXED
Product: Browser
Zooming
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low normal with 12 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: browser-zooming-bugs
: http://www.kuro5hin.org/
:
:
:
  Show dependency tree
 
Reported: 2009-12-26 02:48 UTC by micu
Modified: 2010-05-26 18:14 UTC (History)
7 users (show)

See Also:


Attachments
1st screenshot showing the issue (69.95 KB, image/png)
2009-12-26 02:50 UTC, micu
Details
2nd screenshot showing the bug (104.58 KB, image/png)
2009-12-26 02:50 UTC, micu
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description micu (reporter) 2009-12-26 02:48:15 UTC
The mozilla browser shipped with the N900 shows strong font kerning bugs,
especially (or maybe even only) when zooming in. I do not observe these issues
anywhere else on Maemo except for websites rendered in the browser.

This makes this key feature on the N900 (the brillant browser) a lot less
usable. 

I'll attach screenshots that show this issues.
Comment 1 micu (reporter) 2009-12-26 02:50:07 UTC
Created an attachment (id=1855) [details]
1st screenshot showing the issue
Comment 2 micu (reporter) 2009-12-26 02:50:33 UTC
Created an attachment (id=1856) [details]
2nd screenshot showing the bug
Comment 3 Bartosz Taudul 2009-12-27 17:12:53 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 micu (reporter) 2010-01-03 23:44:00 UTC
I doubt whether tagging this usability bug as beeing low priority is the
smartest thing on earth to do.

For the following reason:

The N900 misses some features its competitors (like the Apple iPhone,
Android-Phones or the Palm Pre) provide. And it offers some unique features;
the most important three of them are imho:

1. A large amount of the Maemo code is free Software (FOSS) [Ok, this is true
for Android as well]
2. Maemo is a standard Debian-compatible GNU+Linux-Distro
3. It has an outstanding Browser with Flash support.

If a usability bug like this diminishes the user experience of this important
component to this extent, imo it should be considered harmful.
Comment 5 Andre Klapper maemo.org 2010-01-04 00:13:34 UTC
Priority by default is low. If a developer decides differently, that's up to
him/her.
Comment 6 micu (reporter) 2010-01-04 15:19:30 UTC
> Priority by default is low. If a developer decides differently,
> that's up to him/her.

Well okay. I reported the bug with high priority, but it was set to low
priority by aklapper e€t openismus.com afterwards. Maybe he/she did this only
because the bug reporter must not set the priority himself.
Comment 7 Andre Klapper maemo.org 2010-01-04 15:22:06 UTC
(In reply to comment #6)
> I reported the bug with high priority

We are currently working on upgrading Bugzilla so reporters cannot set this
field anymore.
Comment 8 gemi 2010-01-20 14:22:21 UTC
Can we increase the priority and severity of this bug?
It makes the browser look very ugly (this is on release 2.2009.51-1.002).
The Fennec browser does not exhibit this problem.
Comment 9 Andre Klapper maemo.org 2010-01-20 14:25:19 UTC
No, see https://bugs.maemo.org/page.cgi?id=fields.html#bug_severity
Comment 10 gemi 2010-01-20 15:26:00 UTC
(In reply to comment #9)
> No, see https://bugs.maemo.org/page.cgi?id=fields.html#bug_severity
So, is there anyone looking into this?
Comment 11 Andre Klapper maemo.org 2010-01-20 15:33:01 UTC
Yes, it's proposed for PR1.2, but adding "Are there news?" comments slow down
work, as much as I can understand general criticism on missing transparency
here (offtopic for this ticket, but also see bug 630).
Comment 12 gemi 2010-01-20 15:41:07 UTC
(In reply to comment #11)
> Yes, it's proposed for PR1.2, but adding "Are there news?" comments slow down
> work, as much as I can understand general criticism on missing transparency
> here (offtopic for this ticket, but also see bug 630).
Possibly just set the status to ASSIGNED and add a short comment
such as "work in progress" :-)
Comment 13 Neil MacLeod maemo.org 2010-01-20 15:57:54 UTC
This is almost certainly the "hinting" (not kerning) bug from Mozilla:

https://bugzilla.mozilla.org/show_bug.cgi?id=470440

Presumably the same fix has (or will) be applied to MicroB, or MicroB will
integrate the latest Mozilla Gecko in a future release.

FYI: This bug is already fixed in the latest Fennec aka Firefox Mobile for
Maemo.
Comment 14 Ryan Abel maemo.org 2010-01-23 01:08:30 UTC
Is there any way to up the priority on this one? This is really a blocker for
usable zoom. . . .
Comment 15 tuukka.tolvanen nokia 2010-02-28 17:26:04 UTC
f ~ 10.2010.06
Comment 16 Andre Klapper maemo.org 2010-03-15 12:37:43 UTC
*** Bug 9550 has been marked as a duplicate of this bug. ***
Comment 17 Andre Klapper maemo.org 2010-03-15 20:51:31 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).