Bug 7327 - (int-130385) Xvid encoded videos unwatchable
(int-130385)
: Xvid encoded videos unwatchable
Status: RESOLVED FIXED
Product: Multimedia
gstreamer
: 5.0/(1.2009.44-1)
: All Maemo
: Low normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: gstreamer-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-25 16:01 UTC by Johannes Siipola
Modified: 2010-03-15 20:55 UTC (History)
2 users (show)

See Also:


Attachments
Screenshot of the thumbnail views (52.15 KB, image/png)
2009-12-25 16:07 UTC, Johannes Siipola
Details
Video playback with the green area blocking the view. (614.08 KB, image/jpeg)
2009-12-25 16:08 UTC, Johannes Siipola
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Johannes Siipola (reporter) 2009-12-25 16:01:59 UTC
SOFTWARE VERSION:
1.2009.24-11

EXACT STEPS LEADING TO PROBLEM: 
1. Open a Xvid-encoded video in Media Player

EXPECTED OUTCOME:

File plays properly.

ACTUAL OUTCOME:

A large green block is obscuring most of the video, only leaving a stripe of it
visible in the upper part of the screen.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

-

OTHER COMMENTS:

Tested on 2 different sets of videos, same result. All the files play perfectly
on mplayer.

Videos encoded with following settings:

Resolution: 576 x 320
Format: XVID
Bitrate: 941 kbps
FPS: 25
Codec: ffodivx

Resolution: 704 x 384
Format: XVID
Bitrate: 901 kbps
FPS: 23.976
Codec: ffodivx

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fi; rv:1.9.1.6)
Gecko/20091201 Firefox/3.5.6
Comment 1 Johannes Siipola (reporter) 2009-12-25 16:07:02 UTC
Created an attachment (id=1853) [details]
Screenshot of the thumbnail views
Comment 2 Johannes Siipola (reporter) 2009-12-25 16:08:25 UTC
Created an attachment (id=1854) [details]
Video playback with the green area blocking the view.
Comment 3 Andre Klapper maemo.org 2009-12-28 15:56:48 UTC
Thanks for reporting this.

Either a duplicate of bug 6963 or of bug 6823 I'd say.
Pick your favorite one, please. :)
Comment 4 Johannes Siipola (reporter) 2009-12-29 19:31:38 UTC
Bug 6823 is totally unrelated, and I can't really think this as a duplicate of
6963 since it only refers to some small artefacts occurring in video playback.
Comment 5 Johannes Siipola (reporter) 2010-01-08 10:06:13 UTC
Some more technical information of another set of files that refuse to display
correctly:

Video 
ID : 0 
Format : MPEG-4 Visual 
Format profile : Simple@L3 
Format settings, BVOP : No 
Format settings, QPel : No 
Format settings, GMC : No warppoints 
Format settings, Matrix : Default (H.263) 
Codec ID : XVID 
Codec ID/Hint : XviD 
Duration : 24mn 38s 
Bit rate : 1 189 Kbps 
Width : 640 pixels 
Height : 480 pixels 
Display aspect ratio : 4:3 
Frame rate : 23.976 fps 
Resolution : 8 bits 
Colorimetry : 4:2:0 
Scan type : Progressive 
Bits/(Pixel*Frame) : 0.161 
Stream size : 210 MiB (89%) 
Writing library : XviD 0.0.09 (UTC 2003-03-25)
Comment 6 Andre Klapper maemo.org 2010-01-12 13:32:33 UTC
This has been fixed in package
openmax-omap3430-ti 0.200941-1+0m5
which is part of the internal build version
2.2009.42-7
(Note: 2009 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 7 Johannes Siipola (reporter) 2010-01-15 20:46:30 UTC
Confirmed to be fixed in PR1.1.
Comment 8 Andre Klapper maemo.org 2010-03-15 20:55:44 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).