Bug 7315 - (int-151990) X Terminal application icon looks ugly compared with previous versions
(int-151990)
: X Terminal application icon looks ugly compared with previous versions
Status: RESOLVED WONTFIX
Product: Desktop platform
Icons
: 5.0/(2.2009.51-1)
: All Maemo
: Low minor with 9 votes (vote)
: ---
Assigned To: unassigned
: icons-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-24 19:02 UTC by Andrew Flegg
Modified: 2010-01-12 16:37 UTC (History)
7 users (show)

See Also:


Attachments
Comparison of X Terminal icons (5.68 KB, image/png)
2009-12-24 19:03 UTC, Andrew Flegg
Details
Ubuntu (Karmic) Terminal Icon (2.62 KB, image/png)
2009-12-30 02:40 UTC, Neil MacLeod
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Andrew Flegg (reporter) maemo.org 2009-12-24 19:02:27 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Install 1.2009.42-11
2. Bring up application picker > More...
3. Look at X Terminal icon.
4. Repeat steps 2 & 3 for 2.2009.51-1

EXPECTED OUTCOME:
X Terminal icon remains the same.

ACTUAL OUTCOME:
The X Terminal icon has lost its nice sheen, and has gained a bright green.
Given the Terminal doesn't have green by default, this seems a somewhat
arbitrary choice. The icon looks *very* dated compared with the version which
has been used, in various guises, in all Maemo versions to date.

REPRODUCIBILITY:
always

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.6)
Gecko/20091215 Ubuntu/9.10 (karmic) Firefox/3.5.6
Comment 1 Andrew Flegg (reporter) maemo.org 2009-12-24 19:03:27 UTC
Created an attachment (id=1847) [details]
Comparison of X Terminal icons

On the left, the earlier (IMHO prettier) X Terminal icon.
On the right, the new 2.2009.51-1 X Terminal icon.
Comment 2 Tim Watt 2009-12-24 22:02:01 UTC
my apologies for the harsh tone, but the transparent highlight when you click
the icon dos't blend into the background properly leaving the white highlight
chomped off the resulting look, is one that makes me think of a sloppy graphic
design job done by a student experimenting with mouse over effects for the
first time.
Comment 3 Andre Klapper maemo.org 2009-12-28 16:04:31 UTC
Design choices are always stuff to agree and to disagree on.
So, what is the exact bug, expect that it subjectively looks ugly and that
there is no green around in the app itself? :)
Comment 4 Andrew Flegg (reporter) maemo.org 2009-12-28 19:28:05 UTC
(In reply to comment #3)
> Design choices are always stuff to agree and to disagree on.
> So, what is the exact bug, expect that it subjectively looks ugly and that
> there is no green around in the app itself? :)

1) It subjectively looks ugly, having lost some of the subtle effects of the
earlier one.
2) It objectively bears no relation to the application: the cursor is wrong,
green is not one of the default colours and few people have green as a
foreground or background colour.
Comment 5 Andre Klapper maemo.org 2009-12-29 17:30:46 UTC
"The xterm icon was redesigned to match with the rest of the icon style, and to
stand out from the other square-like icons in that particular view."
Comment 6 Neil MacLeod maemo.org 2009-12-29 17:42:06 UTC
(In reply to comment #5)
> "The xterm icon was redesigned to match with the rest of the icon style, and to
> stand out from the other square-like icons in that particular view."
> 

Please ask the designer to redesign it again - the new one is, frankly, pants
and a backward step in comparison with the old one (which itself isn't great,
so there is room for improvement). I must admit this seems to be a case of
change for changes sake.

Would Nokia consider suggestions from the community?
Comment 7 Andre Klapper maemo.org 2009-12-29 17:50:58 UTC
(In reply to comment #6)
> Would Nokia consider suggestions from the community?

Don't know - let's try?
Comment 8 Andre Klapper maemo.org 2009-12-29 17:55:03 UTC
"Back in the days, green on black was used as a standard on terminals. That was
the inspiration. The dominantly white icon was too confusable with some of the
other app icons, namely file manager and backup; practically, this version
"works" better in terms of standing out more while keeping with the rest of the
style."
Comment 9 Neil MacLeod maemo.org 2009-12-29 18:04:39 UTC
(In reply to comment #8)
> "Back in the days, green on black was used as a standard on terminals. That was
> the inspiration. The dominantly white icon was too confusable with some of the
> other app icons, namely file manager and backup; practically, this version
> "works" better in terms of standing out more while keeping with the rest of the
> style."
> 

Maybe consider changing/improving the Backup icon in that case - it's hard to
tell at first glance that it's meant to be a safe and is an unusual choice as
most backup/restore icons typically include an arrow (or two)... but perhaps
this going a little OT.
Comment 10 Andrew Flegg (reporter) maemo.org 2009-12-29 18:46:57 UTC
(In reply to comment #8)
> "[...] too confusable with some of the other app icons, namely file
> manager and backup [...]"

See bug 7450 for a solution to "Backup" and "X Terminal" are next to each
other. But I agree with Neil - the Backup icon is very vague and the File
manager one isn't much better. All IMHO, of course.

> this version "works" better in terms of standing out more [...]"

So would a bright red block ;-)

How did the poor users cope with OS2005, OS2006, OS2007, OS2008, and PR1.0?!
All those accidental backups when people wanted to open X Terminal!
Comment 11 Neil MacLeod maemo.org 2009-12-30 02:40:08 UTC
Created an attachment (id=1873) [details]
Ubuntu (Karmic) Terminal Icon

Starter for 10 - this icon shouldn't be confused with other icons on the N900.

One thing I don't like about the old or even new icon is the presence of the
"dollar" ($) sign - end-users might confuse it for a financial application.
Comment 12 Urho Konttori 2010-01-05 21:53:22 UTC
Fixed in PR1.1. Sorry that you'll have to wait, but it's just a little longer.
Comment 13 Andrew Flegg (reporter) maemo.org 2010-01-07 00:42:27 UTC
(In reply to comment #12)
> Fixed in PR1.1. Sorry that you'll have to wait, but it's just a little longer.

To clarify the fix: has it reverted to the earlier version, have the colours
changed or is it a different icon altogether (such as the Ubuntu one Neil
attached)?
Comment 14 Urho Konttori 2010-01-12 15:12:35 UTC
Sorry, I misunderstood the situation here. So, the fix is the green one. It's
not going to be changed for PR1.1.
Comment 15 Aniello Del Sorbo 2010-01-12 15:14:21 UTC
Thus, this is a WONTFIX. isn't it?
Comment 16 Martin Gimpl nokia 2010-01-12 15:35:00 UTC
A few comments from the graphics department:

First of all, no matter what we do to the icon, someone is going to be
displeased with its looks. The current version is most certainly not "dated" in
terms of its quality, it's in fact more in line with the other icons
graphically and more modern. If by "dated" Andrew meant "makes me think of the
70's", then the icon is working as intended.

The icon also works better in terms of being more recognizable and unique.

The suggestion here to use the Ubuntu terminal icon is strange, considering it
does not resemble the color scheme of the app any more than green-on-black. It
is also a *straight* rip from OS X. I'm not against using a lesser-than sign
instead of the dollar in theory (it might indeed be confused with money), but 
the dollar is actually more representative of the actual app than what was
suggested here; open the terminal and look at it yourself.

We cannot change the existing brand icons, so going in to fiddle with backup or
file manager is simply not possible.

I'm sorry if you guys don't like the new icon, but it's not like we changed it
for arbitrary, subjective reasons.
Comment 17 Ryan Abel maemo.org 2010-01-12 16:03:06 UTC
(In reply to comment #16)
> I'm sorry if you guys don't like the new icon, but it's not like we changed it
> for arbitrary, subjective reasons.
> 

Those reasons don't particularly require that the new icon has to be ugly,
however. . . .
Comment 18 Andre Klapper maemo.org 2010-01-12 16:08:25 UTC
Fixing status.
Comment 19 Neil MacLeod maemo.org 2010-01-12 16:17:10 UTC
(In reply to comment #16)
> A few comments from the graphics department:
> 

Welcome. :)

> The suggestion here to use the Ubuntu terminal icon is strange

It wasn't a suggestion to copy it, it was simply offered as an example of
alternatives from other OSes that also have xterm loud and proud.

> If by "dated" Andrew meant "makes me think of the 70's", then the
> icon is working as intended.

I think that's unfair on command shells - they're just as relevant today as
they were in the 60s or 70s! :)

> I'm not against using a lesser-than sign
> instead of the dollar in theory (it might indeed be confused with money), but 
> the dollar is actually more representative of the actual app than what was
> suggested here; open the terminal and look at it yourself.

Yes, the dollar sign is the default prompt in xterm, but then the default
colour scheme is also black-on-white yet the new icon is green on black so it
would seem that strict accuracy isn't essential in terms of this icon.

The icon just needs to be meaningful and ideally attractive, and not something
that could possibly be confused with some other purpose (one argument given so
far is that the old icon could be confused with the Backup app - though I'm not
really sure how - yet the dollar sign I'm fairly sure will cause non-technical
users to believe the xterm app may have Financial connotations)

> 
> I'm sorry if you guys don't like the new icon, but it's not like we changed it
> for arbitrary, subjective reasons.
> 

What were the reasons for changing it again? From the outside looking in it
does appear to have been fairly arbitrary, as I don't know if anybody was aware
it needed changing until now.
Comment 20 Martin Gimpl nokia 2010-01-12 16:34:38 UTC
(In reply to comment #19)

> > If by "dated" Andrew meant "makes me think of the 70's", then the
> > icon is working as intended.
> 
> I think that's unfair on command shells - they're just as relevant today as
> they were in the 60s or 70s! :)

Well, not to the majority of computer users, and even less to mobile phone
users. I wasn't trying to hark on CLI's, in fact I'm a big fan of them myself.
Still, like it or not, to most people they represent the past. Silly me,
thinking the color choice would be appreciated by the people who the terminal
was made for.

> 
> > I'm not against using a lesser-than sign
> > instead of the dollar in theory (it might indeed be confused with money), but 
> > the dollar is actually more representative of the actual app than what was
> > suggested here; open the terminal and look at it yourself.
> 
> Yes, the dollar sign is the default prompt in xterm, but then the default
> colour scheme is also black-on-white yet the new icon is green on black so it
> would seem that strict accuracy isn't essential in terms of this icon.

The metaphor wasn't changed since the original bug against the icon was related
to its graphical style and the confusion with other icons.


> The icon just needs to be meaningful and ideally attractive, and not something
> that could possibly be confused with some other purpose (one argument given so
> far is that the old icon could be confused with the Backup app - though I'm not
> really sure how - yet the dollar sign I'm fairly sure will cause non-technical
> users to believe the xterm app may have Financial connotations)
> 

It's a matter of visual cognition. Similarly shaped and colored icons (or any
visual elements, for that matter) get confused with each other if you're not
paying attention. By distinguishing the icons from each other on a low level
(in terms of visual cognition), we can better guide the eye and allow for
finding the right icon faster. The original bug wouldn't have been raised if
that was not indeed the case.

> > 
> > I'm sorry if you guys don't like the new icon, but it's not like we changed it
> > for arbitrary, subjective reasons.
> > 
> 
> What were the reasons for changing it again? From the outside looking in it
> does appear to have been fairly arbitrary, as I don't know if anybody was aware
> it needed changing until now.
> 

In addition to the reason above, the icon also did not fit with the standard
style of the other preinstalled app icons.
Comment 21 Andrew Flegg (reporter) maemo.org 2010-01-12 16:37:56 UTC
(In reply to comment #20)
> [...] The original bug wouldn't have been raised if [...]

What original bug?

> In addition to the reason above, the icon also did not fit with the standard
> style of the other preinstalled app icons.

Is there a style guide for these icons? It never looked out-of-place to me, so
I'd like to know what the elements of the icon which didn't fit *were*.