Bug 7263 - (int-152305) Media player uses space as artist name when looking up artwork
(int-152305)
: Media player uses space as artist name when looking up artwork
Status: RESOLVED WONTFIX
Product: Data
Meta Tracker
: 5.0/(1.2009.42-11)
: All Maemo
: Low normal with 8 votes (vote)
: ---
Assigned To: unassigned
: metatracker-bugs
: http://live.gnome.org/MediaArtStorage...
:
:
:
  Show dependency tree
 
Reported: 2009-12-23 16:23 UTC by Andrew Flegg
Modified: 2010-10-26 23:51 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Andrew Flegg (reporter) maemo.org 2009-12-23 16:23:51 UTC
SOFTWARE VERSION:
1.2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
1. Create a cover art file according to the spec above, i.e. download
http://bleb.org/software/maemo/mediaart/cover.jpg as
/home/user/.cache/media-art/album-23a524105a0da7a32f784bdf4deca0ae-3fc6c445f579cf98c46527b176a019e5.jpeg

This is because the artist is "Alanis Morissette" and the album is "Jagged
Little Pill" (as seen in the Media Player); and the MD5s of "alanis morissette"
and "jagged little pill" are 23a524105a0da7a32f784bdf4deca0ae and
3fc6c445f579cf98c46527b176a019e5 respectively.

2. Download the http://bleb.org/software/maemo/mediaart/all-i-really-want.mp3
to /home/user/MyDocs/.sounds/

3. Open Media Player
4. Tap "Music"
5. Open "Artists" from the app menu
6. Scroll to "Alanis Morissette" and select.
7. Tap "All I Really Want"

EXPECTED OUTCOME:
At step 6, the thumbnail of the album art is shown. And it is shown when the
track starts playing.

ACTUAL OUTCOME:
No album art image is shown.

REPRODUCIBILITY:
always

OTHER COMMENTS:
Changing the image to
/home/user/.cache/media-art/album-7215ee9c7d9dc229d2921a40e899ec5f-3fc6c445f579cf98c46527b176a019e5.jpeg
DOES make the image appear. But this is the fallback case (artist as ' '), and
results in two albums with the same name sharing the album art (e.g. two albums
called "Greatest Hits")


User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.6)
Gecko/20091201 Firefox/3.5.6 (.NET CLR 3.5.30729)
Comment 1 Andrew Flegg (reporter) maemo.org 2009-12-29 15:04:18 UTC
Hmm, odd stuff seems to be happening:

http://talk.maemo.org/showpost.php?p=439664&postcount=35
Comment 2 Andrew Flegg (reporter) maemo.org 2009-12-29 19:24:15 UTC
(In reply to comment #1)
> Hmm, odd stuff seems to be happening:
> 
> http://talk.maemo.org/showpost.php?p=439664&postcount=35

In retrospect, I think that's because the cover.jpg & MP3 were put
side-by-side. This bug is about other things trying to interact with Tracker
using the specification above. Whilst it is using ' ' rather than <artist> as
the first part of the hash, that is impossible AND causes conflicts when two
albums are called the same thing.
Comment 3 Andrew Flegg (reporter) maemo.org 2009-12-29 19:29:53 UTC
Further steps to reproduce which show this isn't just a problem with other
things trying to interoperate using the same specification, but also affects
users with two albums with the same name:

http://talk.maemo.org/showpost.php?p=445422&postcount=66
Comment 4 John Steele Scott 2010-01-04 12:48:01 UTC
Looking at
<http://maemo.gitorious.org/tracker/tracker/blobs/fremantle/src/tracker-extract/tracker-extract-mp3.c>,
around line 2080, the calls to tracker_process_albumart() pass NULL instead of
an artist name. Why?

Bug 6911 "Albums with the same name but by different artists are mixed
together" suggests that perhaps the media player does not use the artist name
when grouping albums.
Comment 5 Andre Klapper maemo.org 2010-01-11 12:15:22 UTC
"The decision to drop the artist from the equation were made based on the
requests from media player/mafw to handle collection albums with several
different artists together as one album. This collection album use case was
given priority over the possible case of several artists having albums with the
same name (based only on metadata there is no way of knowing whether songs with
the same album name but different artist belong to the same collection album or
not)
Currently there is no intention to change this behavior although I do agree
that it is both inconvenient for people who wish to push album art directly to
the cache and those who have several albums with the same name.
Resolving as WONTFIX (at least for the moment)"
Comment 6 Andrew Flegg (reporter) maemo.org 2010-01-11 12:37:28 UTC
Can someone who fully understands the algorithm and the spec then please update
the Developer Guide etc. to reference the fact that Maemo 5 does NOT implement
the MediaArtStorageSpec. The spec is often referred to, but does not conform
with what Maemo 5 does:

http://live.gnome.org/MediaArtStorageSpec

Given this spec seemed to be largely written for Maemo 5, it's surprising that
during implementation a "better" way was discovered.
Comment 7 Andre Klapper maemo.org 2010-01-23 19:19:28 UTC
*** Bug 6911 has been marked as a duplicate of this bug. ***
Comment 8 Frederik Niedernolte 2010-01-31 08:24:50 UTC
This bug is really annoying when you have a lot of "Greatest Hits" albums.
There should be a possibility to solve this. I don't know this problem from
other phones.
http://talk.maemo.org/showthread.php?t=40721&highlight=greatest+hits
Comment 9 Andre Klapper maemo.org 2010-10-26 20:08:46 UTC
Andrew: I've posted your comment 6 three times internally, no answer.
Feel free to draw your own conclusions.
Comment 10 Andrew Flegg (reporter) maemo.org 2010-10-26 23:51:19 UTC
Apple solved the "collection" issue by introducing a new ID3 tag, "TCMP":

http://warped.org/blog/2009/05/02/itunes-setting-the-compilation-flag-on-mp3s-using-perl/

CC'ing Dave as a documentation bug issue.