Bug 7256 - (int152017/int-200564) Maemo should use en_GB as default fallback in locales
(int152017/int-200564)
: Maemo should use en_GB as default fallback in locales
Status: RESOLVED WONTFIX
Product: Desktop platform
Internationalization
: 5.0:(10.2010.19-1)
: All Maemo
: Low normal with 7 votes (vote)
: ---
Assigned To: unassigned
: i18n-bugs
:
: patch
:
:
  Show dependency tree
 
Reported: 2009-12-23 13:16 UTC by Juan A. Suarez Romero
Modified: 2011-03-30 11:04 UTC (History)
7 users (show)

See Also:


Attachments
Use en_GB as fallback locale (308 bytes, patch)
2009-12-23 13:20 UTC, Juan A. Suarez Romero
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Juan A. Suarez Romero (reporter) 2009-12-23 13:16:20 UTC
EXACT STEPS LEADING TO PROBLEM:

1. Select a non-oficial language in Maemo

EXPECTED OUTCOME:
All strings should be translated to selected language.
No identifiers should be shown. If a translation is not available for that
string, then en_GB translation should be used.

ACTUAL OUTCOME:
If a string has no translation, it shows an identifier

REPRODUCIBILITY:
Always

EXTRA SOFTWARE INSTALLED:
Can be tested with posix-locales-sksk and slovak-l10n package.
Comment 1 Juan A. Suarez Romero (reporter) 2009-12-23 13:20:00 UTC
Created an attachment (id=1833) [details]
Use en_GB as fallback locale

This patch uses en_GB as fallback locale.
Comment 2 Andre Klapper maemo.org 2009-12-28 16:30:38 UTC
Thanks for the patch!
Which exact version is this about?
Comment 3 Juan A. Suarez Romero (reporter) 2010-01-04 09:38:14 UTC
(In reply to comment #2)
> Thanks for the patch!
> Which exact version is this about?
> 

Not sure. I've tried with the latest version of public Maemo5. I think it
should work for older versions too.
Comment 4 Tuomo Tanskanen 2010-03-02 13:26:32 UTC
This sounds like a blocker for translating Extras apps, its not basically
possible to have all languages covered without a fallback. With one-line simple
patch, can anyone think why its not done already?
Comment 5 Gyarmati Roland 2010-03-02 14:18:56 UTC
I tried the patch by Juan in internal release 10.2010.08-18 and it seems to
work without problems and properly. I use the hu_HU translations for dev.
Comment 6 Kulakov Kirill 2010-04-02 12:35:46 UTC
Similar problem in scratchbox when use non-English language (for example
Russian). Patch hides identifiers.
Comment 7 Andre Klapper maemo.org 2010-04-30 15:01:18 UTC
*** Bug 10061 has been marked as a duplicate of this bug. ***
Comment 9 Gary Birkett 2010-06-24 18:12:16 UTC
(In reply to comment #6)
> Similar problem in scratchbox when use non-English language (for example
> Russian). Patch hides identifiers.
> 

I do not think this should prevent the patch from being used, but should be
considered and a potential further patch may be required?
(to disable this modification when run in scratchbox)

for now, applied to the gitorious repository and undergoing internal testing.

http://maemo.gitorious.org/fremantle-hildon-desktop/osso-af-startup/commit/64d387f93f72ff51bc36056c1f1d5a0c4982d03a

thank you all for input, hopefully we should get this integrated.
Comment 10 Andre Klapper maemo.org 2010-06-30 13:46:59 UTC
This has been fixed in package
osso-af-startup 1.80-3+0m5
which is part of the internal build version
2010.26-1
(Note: 2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 11 Andre Klapper maemo.org 2010-08-02 17:10:17 UTC
Nokia's internal latest comment:
"Unfortunately this bug caused a regression on startup-wizard.
And as well unfortunately, it is too late to retry another implementation to
fix this bug, as it could cause another similar regressions. Hence WONTFIX."
Comment 12 Andre Klapper maemo.org 2010-10-26 20:18:24 UTC
Let's try to get this in for Harmattan (the version after Maemo5) at least...
reopening. WONTFIX for Maemo5 as said.
Comment 13 Andre Klapper maemo.org 2011-03-30 10:44:12 UTC
Forwarding internal WONTFIX:

--- Comment from Scheibengruber Jorgen (Nokia) 2011-03-03 ---
Logical ids is something that Nokia uses in their source-code. Nobody forces
third parties to do the same, they can just use plain english in their
source-code and if there is no translation available, then that's what will
show up.
So this is not a problem for third party applications, it is only a problem for
people who want to translate the applications that Nokia built into languages
that are not provided by Nokia. Unless I miss something.

--- Comment from Binnema Dirk-Jan (Nokia) 2011-03-03 ---
Jorgen: good point, and indeed, Qt does the replacement like gettext:

"If none of the translation files contain a translation for sourceText in
context, this function returns a QString equivalent of sourceText."

So this only applies to the masochists that voluntarily want to use logical
ids; that makes this task a bit less important, resetting priority to 'low'.

side-note: gettext/glibc actually already have built-in support for a fallback
language (multiple even, in priority order), see LANGUAGES.

So, going to WONTFIX this bug.  But it could be argued that it's actually a
'WORKSFORME' -- developers outside Nokia should simply use English for all
strings and the UI will fall back to it if there is no other translation.

Simply stay away from logical id's, and all will be fine.
Comment 14 Juan A. Suarez Romero (reporter) 2011-03-30 11:02:50 UTC
(In reply to comment #13)
> Forwarding internal WONTFIX:
> 
> --- Comment from Scheibengruber Jorgen (Nokia) 2011-03-03 ---
> Logical ids is something that Nokia uses in their source-code. Nobody forces
> third parties to do the same, they can just use plain english in their
> source-code and if there is no translation available, then that's what will
> show up.
> So this is not a problem for third party applications, it is only a problem for
> people who want to translate the applications that Nokia built into languages
> that are not provided by Nokia. Unless I miss something.


The point is that if I want to add a new (let's say exotic or whatever)
language, what I want to see is that for those non-translated applications, at
least I can read them in a normal language, let's say english, and not seeing
logical ids that are meaningless.

When I set up my desktop environment to other language that is not english, at
least I can still see the non-translated applications in english.

But this doesn't work with Maemo or Nokia applications: when setting a language
for which Nokia applications haven't been translated, it *should* show all the
messages in english, and not the logical IDs as it is doing right now. The
patch does precisely that: switch to English if there is no translation.

So yes, the problem is for Nokia applications.
Comment 15 Juan A. Suarez Romero (reporter) 2011-03-30 11:04:44 UTC
(In reply to comment #14)
> The point is that if I want to add a new (let's say exotic or whatever)
> language, what I want to see is that for those non-translated applications, at
> least I can read them in a normal language, let's say english, and not seeing
> logical ids that are meaningless.
> 


Just to make things clearer: when I talk about applications, I mean Nokia
applications. For external applications, the right way to do is that they
shouldn't use logical IDs but english sentences.