Bug 723 - (int-86015) Media Player can not access authenticated streams
(int-86015)
: Media Player can not access authenticated streams
Status: RESOLVED WONTFIX
Product: Media player
General
: 5.0-beta
: All All
: Medium enhancement with 1 vote (vote)
: ---
Assigned To: unassigned
: media-player-bugs
: http://andrew.triumf.ca/reqauth/diode...
: ITOS2007HE-garage
:
:
  Show dependency tree
 
Reported: 2006-07-26 21:36 UTC by Charles Snider
Modified: 2010-01-28 23:20 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Charles Snider (reporter) 2006-07-26 21:36:27 UTC
Audio Player can not access any stream that requires authentication and in 
particular, when attempting to access a Slim Server stream. Audio Player 
will not pass authentication request, simply responds with "Audio Stream 
not found at given address".
Comment 1 Maemo QA (deprecated) 2006-08-03 14:40:32 UTC
Will be handled as a feature request. Thanks for your feedback!
Comment 3 Andre Klapper maemo.org 2008-05-30 11:44:42 UTC
can someone please provide an example URL (and maybe even an example account
;-) ?
Comment 4 Andre Klapper maemo.org 2008-08-04 17:20:49 UTC
From bug 3483:

Placed WAV file at http://andrew.triumf.ca/reqauth/
user=password="test"

HTTP "Referer" is also not passed to media player (some sites might
possibly check this to make users navigate via the "official" links)
Comment 5 Andre Klapper maemo.org 2008-08-04 17:21:19 UTC
*** Bug 3483 has been marked as a duplicate of this bug. ***
Comment 6 Andre Klapper maemo.org 2008-08-04 18:00:22 UTC
note to myself: blocked by int-86015
Comment 7 Andre Klapper maemo.org 2008-11-06 19:30:36 UTC
Moving to Media Player as this is still valid for 4.1.
Comment 8 Quim Gil nokia 2009-01-25 00:49:26 UTC
In Fremantle is is not possible to play
http://andrew.triumf.ca/reqauth/diodes.wav as a 'radio station'.

There is no error message. After a couple of seconds of "Connecting" the player
shows OO.OO position and dosn't move from there.

The underlying problem remains the same. No authentication is handled yet.

What I wonder is whether this is a bug from the developers perspective, as it
might happen that there is no requirement for this.
Comment 9 Andre Klapper maemo.org 2009-03-24 15:52:47 UTC
(In reply to comment #8)
> What I wonder is whether this is a bug from the developers perspective, as it
> might happen that there is no requirement for this.

Quim, any chances to find out? Can't myself...
Comment 10 Quim Gil nokia 2009-04-14 22:59:37 UTC
Testing with Fremantle w16 an error message appears in the Media Player:
"Invalid URL".

You can try filing a bug in Fremantle. I think that the chances that Media
Player is not required to deal with authenticated streams are high, but who
knows. And it's a way to provide input to the team.
Comment 11 Quim Gil nokia 2009-05-10 02:57:04 UTC
Same in w19, and I don't expect this to be fixed unless they get a bug since
I'm quite sure this is not specified.

Still, I fail myself to see how widespread is this need to have authenticated
streams...
Comment 12 Quim Gil nokia 2009-05-18 23:09:15 UTC
Well, it seems this is en enhancement request from a reporter that hasn't
followed the request over the years (I'm not complaining). No votes, no
comments apart from timeless, Andre and me.

Resolving as WONTFIX.
Comment 13 John Perez 2010-01-28 23:20:22 UTC
N900 media player also cannot easily access any stream that requires
authentication.

If I manually edit a playlist, adding http basic access authentication to each
entry, it does work.  For example:

http://test:test@andrew.triumf.ca/reqauth/diodes.wav

Media player does not on its own seem to recognize or have a mechanism for
responding to authentication requests, which would be useful.