Bug 7210 - Cannot enter a URL containing a tilde ('~').
: Cannot enter a URL containing a tilde ('~').
Status: VERIFIED DUPLICATE of bug 5314
Product: Browser
User interface
: 5.0/(1.2009.42-11)
: All Maemo
: Low normal (vote)
: ---
Assigned To: unassigned
: browser-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2009-12-22 01:04 UTC by John Steele Scott
Modified: 2009-12-22 18:01 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description John Steele Scott (reporter) 2009-12-22 01:04:13 UTC
SOFTWARE VERSION: 2009.42-11.003

EXACT STEPS LEADING TO PROBLEM: 
1. Open Browser.
2. Select the URL bar.
3. Begin entering a URL of the form "https://foo.com/~bar". To enter the '~',
you need to press <blue arrow><Sym> to bring up the symbol entry on-screen
keyboard. Then press the '~' symbol.

EXPECTED OUTCOME:
The on-screen keyboard should disappear, and the tilde symbol '~' should be
appended to the text in the URL bar.

ACTUAL OUTCOME:
The tilde key on the on-screen keyboard changes colour, but the text is not
entered into the URL bar.

REPRODUCIBILITY:
Always.

EXTRA SOFTWARE INSTALLED:
Adblock.

OTHER COMMENTS:
This happens with every key in the same row as tilde in the symbol keyboard.
(grave accent, accute accent, caret, tilde, umlaut, diareses, ring, etc). Other
symbols from the keyboard can be input with no problems.

I guess this is a problem with the on-screen keyboard, not really the browser,
but I'm reporting it in the browser because that's where I saw it.
Comment 1 timeless 2009-12-22 02:49:44 UTC
So, some keyboard layouts on some operating systems use something called "dead"
keys. they are usually visible in on screen keyboards as colored/depressed.

In some platforms you can press <space> after a dead key to trigger the actual
characters. This works in sales

In some places, pressing a dead key twice will trigger the actual character.
This will work in a future service release.

The reason that ~ is a dead key is so that you can write:

español

a more complete list from http://en.wikipedia.org/wiki/Tilde indicates:
ÃãẼẽĨĩÑñÕõP̃p̃ŨũṼṽỸỹ

The user interface is well, unfortunate, but this is not a bug in the browser.
And the UI team has already iterated to try to improve it slightly for a future
service release
Comment 2 timeless 2009-12-22 02:51:22 UTC
http://en.wikipedia.org/wiki/Dead_key
Comment 3 John Steele Scott (reporter) 2009-12-22 02:56:50 UTC
(In reply to comment #1)
> The user interface is well, unfortunate, but this is not a bug in the browser.

Ah, it's easy when you know how. I agree that pressing the key twice to insert
it will make it easier for people who have not used dead keys before.

Thanks for the info, and sorry for the noise.
Comment 4 Andre Klapper maemo.org 2009-12-22 16:00:54 UTC
Actually the same issue as bug 5314.

*** This bug has been marked as a duplicate of bug 5314 ***