Bug 7200 - sms fail delivery info returns when sms delivered
: sms fail delivery info returns when sms delivered
Status: CLOSED FIXED
Product: Chat & Call & SMS
Messaging
: 5.0/(1.2009.42-11)
: N900 Maemo
: Medium normal (vote)
: 5.0/(2.2009.51-1)
Assigned To: rtcomm@maemo.org
: im-chat-bugs
:
:
: int-134062
:
  Show dependency tree
 
Reported: 2009-12-21 21:14 UTC by samuli.silvius
Modified: 2010-03-02 14:06 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description samuli.silvius (reporter) 2009-12-21 21:14:28 UTC
SOFTWARE VERSION: 5.0/1.2009.42-11


EXACT STEPS LEADING TO PROBLEM: 

1. sms delivery report is enabled
2. Open conversations and old conversation (sms) thread
3. send new sms message to thread
4. opponent phone is OFF and conversations shows correctly that sms delivery
failed and red failure mark is shown in thread message and also red triagle in
the conversations main window
5. opponent party turns his/her mobile ON
6. I have still conversations message thread open and see correctly that
message is delivered and also red failure mark disappears.
7. If now closing conversations thread, the failure mark returns back to the
message and also red triagle to the main window.

EXPECTED OUTCOME: Failure mark of failure delivery should disappear for ever
when message is successfully delivered.

ACTUAL OUTCOME: Failure mark of delivery is coming back when message is closed,
even if message was delivered successfully (failure mark was only temporarily
cleared)

REPRODUCIBILITY: always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:
Comment 1 Mikhail Zabaluev nokia 2009-12-22 13:23:37 UTC
I think this is the same problem internally as the one reported in bug #7212.
Comment 2 Andre Klapper maemo.org 2010-01-14 12:33:20 UTC
Today Nokia released the Maemo5 update version 2.2009.51-1 for public (also
called "PR1.1" sometimes).
If you have some time we kindly ask you to test again if the problem reported
here still happens in this new version - just leave a comment (and feel free to
update the "Version" field to the new version if it's still a problem).
Comment 3 shinydoofy 2010-01-14 19:26:08 UTC
Just tested it - it works "better". Thank you! :)
The failure icon isn't shown anymore - very good. It seems there are two
possible scenarios:
1. Don't leave the contact's messaging history: there's an icon with an arrow
pointing upwards (I'm sending my message to my service provider). After a few
seconds, the icon disappears.
2. Close both the message history and the messaging app so that there's no open
window and open them up again: There's a timestamp next to the message I last
sent saying when I sent my message / when it was accepted by my service
provider.
When the delivery report note pops up, it's changed to when the message was
received by the other party. The el.db database is updated, start_time and
end_time differ.

Say you did it the second way because you just wanted to send out a message
like "Sorry, I'm stuck in traffic and can't make it in time" and close both
windows. There will be no way to see if the message was successfully received
by the other party.
On my N70 there was a tab called reports ("Berichte" in German) where you could
see which message was delivered and which one was still in transit with your
service provider or the other party's provider ("Unerledigt" - not done) and
which one has reached its destination ("Gesendet" - sent). Is it possible to
implement such a feature?

All this also applies to bug 7212 as well, of course.
Comment 4 Mikhail Zabaluev nokia 2010-01-18 11:28:15 UTC
(In reply to comment #3)
> Just tested it - it works "better". Thank you! :)

Thanks for your feedback. Are you reporting this against 2.2009.51-1 now?
Comment 5 Mikhail Zabaluev nokia 2010-01-18 11:41:08 UTC
(In reply to comment #3)
> 2. Close both the message history and the messaging app so that there's no open
> window and open them up again: There's a timestamp next to the message I last
> sent saying when I sent my message / when it was accepted by my service
> provider.
> When the delivery report note pops up, it's changed to when the message was
> received by the other party. The el.db database is updated, start_time and
> end_time differ.
> 
> Say you did it the second way because you just wanted to send out a message
> like "Sorry, I'm stuck in traffic and can't make it in time" and close both
> windows. There will be no way to see if the message was successfully received
> by the other party.

Click into the message to see the detailed view; the Delivered status is
displayed in the header.
I don't see anything else to fix.
Comment 6 shinydoofy 2010-01-18 11:48:30 UTC
Ugh... I didn't see that it wrote sent or delivered. That clears it up, of
course. Thanks :)
Comment 7 Venomrush 2010-03-01 22:39:25 UTC
This issue cannot be seen by me since PR1.1 (2.2009.51-1)